Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-27-2005, 04:11 PM   #1
la_muss
Scooby Newbie
 
Member#: 89872
Join Date: Jun 2005
Location: NNJ
Vehicle:
2001 Impreza RS
Black

Unhappy I need help with my 95L !!

I got a beater -1.8L. I took out the battery because front bumper needed paint job and I had to unplug headlights etc. I put the battery back and nothing works except for the emergency lights and the sound that the key is in the ignition. It has been sitting in my driveway for a moth, but when I put a battery from a different car did not work either. Maybe there is something I have to do ? Please help me out guys !! I thought that the car had some auto alarm device but I don't see anything like that. Thank you guys.
* Registered users of the site do not see these ads.

Last edited by la_muss; 08-27-2005 at 04:39 PM.
la_muss is offline   Reply With Quote
Old 08-28-2005, 07:59 AM   #2
tmeh
Scooby Newbie
 
Member#: 30800
Join Date: Dec 2002
Chapter/Region: E. Canada
Location: Ontario
Vehicle:
2000 .7 RS

Default

are there any lights on the dash when you turn the key on?
tmeh is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I need some assistance, need help with my build Harnicka Built Motor Discussion 9 09-08-2009 01:58 PM
Need help with my hoses! Need a tech Please darkcrave Factory 2.0L Turbo Powertrain 9 04-17-2009 03:06 PM
Need help with my 32 Mods for my 32'nd birthday effort Koji North West Impreza Club Forum -- NWIC 9 09-08-2008 07:46 PM
I need help with my 02 Wagon Suspension! Hate my Teins natoli4 Brakes, Steering & Suspension 50 03-23-2006 08:21 PM
I need Help with my install! HELP! mrubino83 Factory 2.0L Turbo Powertrain 4 04-08-2004 01:11 AM


All times are GMT -4. The time now is 05:21 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.