Welcome to the North American Subaru Impreza Owners Club Friday August 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-29-2005, 12:19 AM   #1
Evil Dr. Scoob
Scooby Newbie
 
Member#: 19193
Join Date: May 2002
Chapter/Region: MAIC
Location: Mount Airy, MD
Vehicle:
2005 LGT
Regal Blue

Default Starter problem?

Ok, I know I've been dedicated to the NA forums for a while now, L-power and all that, but I broke down and got a '05 LGT on July 1.

So now the 98 L can be "played with" more extensively, but this means it sits for a few days between starts. And if it is longer than a few days, the first key turn does nothing at all. Turning the key again gets a little crank, then more and more until it starts at the 3rd turn. My concern is that my starter is worn out and that it should be replaced. Seems like there should be some bushings or something in it that are worn out.

Is this a problem or am I just fishing for things to work on?

Chris
* Registered users of the site do not see these ads.
Evil Dr. Scoob is offline   Reply With Quote
Old 08-29-2005, 04:21 AM   #2
marcus12
Scooby Specialist
 
Member#: 45613
Join Date: Oct 2003
Chapter/Region: NESIC
Location: Columbia, CT
Vehicle:
2005 Legacy GT Ltd.
Satin White Pearl

Default

sounds like a starter to me...do you hear a "whirring" or any other noise when you turn the key?

//marcus
marcus12 is offline   Reply With Quote
Old 08-29-2005, 01:30 PM   #3
Evil Dr. Scoob
Scooby Newbie
 
Member#: 19193
Join Date: May 2002
Chapter/Region: MAIC
Location: Mount Airy, MD
Vehicle:
2005 LGT
Regal Blue

Default

I should check again, but I seem to recall a clicking noise.

C
Evil Dr. Scoob is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Starter problems turns into locked up engine problem Minnesota1 Factory 2.5L Turbo Powertrain 8 12-05-2007 06:03 PM
starter problems aschnell Factory 2.5L Turbo Powertrain 4 10-25-2003 09:33 PM
('93-'01) '98 obs starter problem geepondy Impreza Forum 2 07-01-2003 05:51 PM
Starter problem 2000vfr800 Factory 2.0L Turbo Powertrain 2 10-14-2002 10:30 AM
Starter Problem darkangelgrafix Warranty Issues & SOA Problems 3 09-18-2002 09:28 AM


All times are GMT -4. The time now is 07:41 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.