Welcome to the North American Subaru Impreza Owners Club Tuesday July 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-26-2002, 11:00 PM   #1
scoobydude1999
Scooby Newbie
 
Member#: 20560
Join Date: Jun 2002
Exclamation Knock knock...

to anyone that can help; i have a strange knocking sound in the front end of my 1999 2.5rs that occurs under accelleration and braking as well as in the occassional corner. the calipers and all suspension points are all to factory spec. is it possibly a problem with the drive axles or cv joints? any help is appreciated.
* Registered users of the site do not see these ads.
scoobydude1999 is offline   Reply With Quote
Old 06-27-2002, 06:26 PM   #2
minix42@
Scooby Newbie
 
Member#: 548
Join Date: Nov 1999
Location: pittsburgh, PA USA
Vehicle:
'98 Impreza RS
dinged up faded black

Default

check the swaybar mounts. They have a reputation for creaking when they're dirty/dry. Generic grease or something should be fine, something that doesn't dry/leak out right away would be even better. I have confidence you can figure that out. Let us know if that works. If not, maybe we can narrow it down a bit more.

Is it a single knock when weight is being transfered fore/aft, left/right? or a long series of knocks? Does it only happen while acelerating or engine braking? or does it do it in neutral/coasting as well? Bumpy roads? going Slow/Fast? uneven roads, like when first entering a parkinglot?

Most of all.... What kind of car?!!? Don't worry, we'll figure it out sooner or later.

mike
minix42@ is offline   Reply With Quote
Old 06-28-2002, 12:12 AM   #3
blaznasn
Scooby Specialist
 
Member#: 6750
Join Date: May 2001
Location: norcal
Default

i was about to post that too, i am getting the same noise, usually only in 1-3rd gear, and it happens in the same situations as you.

the noise isnt like a knock on wood is it, it kind of sounds like "doob doob" something like that, haha.

tre
blaznasn is offline   Reply With Quote
Old 06-28-2002, 10:06 AM   #4
scoobydude1999
Scooby Newbie
 
Member#: 20560
Join Date: Jun 2002
Default

this happens during accelleration as well as braking and occasionally durring low speed (less than 5 mph) turns. i double checked the 19mm strut nuts (kyb) and the 12mm top nuts and both were torqued properly. after that i sprayed the suspension pivots as well as the sway pivots and drop links with wurth spray lube. still have the same problem. thanks for the advice, keep it coming.
scoobydude1999 is offline   Reply With Quote
Old 06-28-2002, 02:36 PM   #5
minix42@
Scooby Newbie
 
Member#: 548
Join Date: Nov 1999
Location: pittsburgh, PA USA
Vehicle:
'98 Impreza RS
dinged up faded black

Default

Let's start by learning what you drive. Impreza/Legacy/WRX/Other ? Manual/automatic transmission ? What year ? Lots of miles ?

You also mentioned Kyb struts... Did you install them yourself, or have a shop/friend do it? New springs as well?? Any other aftermarket or replacement parts?
minix42@ is offline   Reply With Quote
Old 06-28-2002, 03:00 PM   #6
minix42@
Scooby Newbie
 
Member#: 548
Join Date: Nov 1999
Location: pittsburgh, PA USA
Vehicle:
'98 Impreza RS
dinged up faded black

Default

oops, just reread your first post..... 99 RS. sorry bout that.

so anyways.....
minix42@ is offline   Reply With Quote
Old 06-28-2002, 03:02 PM   #7
scoobydude1999
Scooby Newbie
 
Member#: 20560
Join Date: Jun 2002
Default

it's a 1999 2.5rs with 65k on it. the kyb struts were on it when i bought it last fall with 55k on it. no idea how long ago they were installed. it has the stock front sway bar and an fhi 20mm rear bar. the struts have eibach 1.5" lowering springs (std tire rack kit). i have installed rubber tubing over the top and bottom coils of the front springs to eliminate the possibilty of rubbing on the perches. there are no tower braces on the car and it is driven hard on a daily basis. no doubt at a few of the local track days soon. i would like remedy this problem but this car seems to require a less than normal approach to cure its idiosincracies.
scoobydude1999 is offline   Reply With Quote
Old 06-29-2002, 02:04 AM   #8
minix42@
Scooby Newbie
 
Member#: 548
Join Date: Nov 1999
Location: pittsburgh, PA USA
Vehicle:
'98 Impreza RS
dinged up faded black

Default

I'm getting a creaking noise right now myself. At first it was less obvious, and I thought it was comming from the front as well. Now that it's had some time to grow louder, it's definately from the rear swaybar. I'm not saying that this is your problem, just saying don't rule it out if you're not sure.

I'd suggest jacking the front up so that the suspension is unweighted, and check that the springs sit snugly when the struts are fully extended. Keep your eyes open for anything else suspicous under there. More suggestions to come... ...must sleep now though.
minix42@ is offline   Reply With Quote
Old 07-02-2002, 03:23 PM   #9
scoobydude1999
Scooby Newbie
 
Member#: 20560
Join Date: Jun 2002
Default

sorry its taken so long to respond to the last post. stopped by my friends import shop and took him out for a ride to see if he could hear the knocking. it took several tries to make happen repeatedly but we finally figured out that it was the stock strut hats going bad that is making the noise. best way to check this is to have a friendput their hand on the hat while you turn the wheel back and forth. the slight change in the angle of the strut will make the hat "knock" or "pop" if it is going bad. its a difficult one to diagnose but a very cheap fix. there are an assortment of replacements on the market including kyb, sti, cusco, and of course stock. i opted for the kyb. hope your fix is as cheap as mine. thanks again for the input. --erik
scoobydude1999 is offline   Reply With Quote
Old 01-09-2006, 07:18 PM   #10
Schlad
Scooby Newbie
 
Member#: 25433
Join Date: Sep 2002
Location: SoCal
Vehicle:
2003 WRX SW
all we'll drive

Default

When you say "strut hats" do you mean strut tops? Or I guess you can say with a picture what part you had to replace. I don't recall strut tops being a cheap fix though. Perhaps my definition of "cheap" is different than yours as well.
Schlad is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Knock, knock, knocking.. 05 STi | UTEC Timmy Burns UTEC 15 02-24-2006 07:09 PM
*knock knock knock* at my front door.... eurojax Off-Topic 17 05-09-2005 09:03 AM
Knock Knock.....who's there? ScoobieSnaX Factory 2.0L Turbo Powertrain 17 07-11-2002 04:46 PM
Knock knock... scoobydude1999 Service & Maintenance 0 06-26-2002 10:54 PM


All times are GMT -4. The time now is 08:53 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.