Welcome to the North American Subaru Impreza Owners Club Tuesday July 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-02-2005, 08:16 PM   #1
farrell
Scooby Specialist
 
Member#: 47746
Join Date: Nov 2003
Location: east stroudsburg PA
Vehicle:
2000 Impreza 2.5 RS
silverhorn

Default Stall after strong rev or drive???

just upgraded to a wrx turbo...running 25 engine with 2.2 ecu. i had a smaller turbo on it before. when i give it a good rev or drive...after boosting the car and letting off the gas or slowing to a stop the car will stall. any suggestions?
* Registered users of the site do not see these ads.
farrell is offline   Reply With Quote
Old 09-03-2005, 07:54 AM   #2
REDI-wgn
Scooby Specialist
 
Member#: 38068
Join Date: Jun 2003
Chapter/Region: South East
Location: Miami FL
Vehicle:
03 WRX Wagon

Default

actually just this morning on my way to work my car started doing this.mine is jus a wrx(wrong forum) but i would let off the gad and neutral and the idle would drop as normal then it would start to hunt(fluctuate) 750-1500 rpm about twice before it shuts off. Im going to pull of the throttle body and clean it along with the IAC valve. I havnt dug into my engine as yet so for it to be valve lash is unlikely(hopefully), and i am holding full boost and dont seem to have a miss. Ill let you know what happens even though it may be a different problem.
REDI-wgn is offline   Reply With Quote
Old 09-03-2005, 09:37 AM   #3
farrell
Scooby Specialist
 
Member#: 47746
Join Date: Nov 2003
Location: east stroudsburg PA
Vehicle:
2000 Impreza 2.5 RS
silverhorn

Default

k. thanks, let me know
farrell is offline   Reply With Quote
Old 09-03-2005, 05:41 PM   #4
REDI-wgn
Scooby Specialist
 
Member#: 38068
Join Date: Jun 2003
Chapter/Region: South East
Location: Miami FL
Vehicle:
03 WRX Wagon

Default

mine was iac, cleaned it off properly before leaving work and everything is fine now, no more stalling.

most likely that will be your cause as well, at least hopefully as it is an easy fix.
REDI-wgn is offline   Reply With Quote
Old 09-03-2005, 07:54 PM   #5
Ssleeping
Scooby Newbie
 
Member#: 60353
Join Date: Apr 2004
Location: Bozeman, Montana
Vehicle:
2002 Stg. 4 WRX
WRB

Default

I have te same problem w/ my WRX after a turbo upgrade. I will clean the IAC.
Ssleeping is offline   Reply With Quote
Old 09-03-2005, 08:33 PM   #6
Tats
Scooby Specialist
 
Member#: 5692
Join Date: Apr 2001
Chapter/Region: Tri-State
Location: Lovely Florida, NY
Vehicle:
WTF? YES! I am
better than you!

Default

Check for vacuum leaks too.
Tats is offline   Reply With Quote
Old 09-05-2005, 01:31 PM   #7
farrell
Scooby Specialist
 
Member#: 47746
Join Date: Nov 2003
Location: east stroudsburg PA
Vehicle:
2000 Impreza 2.5 RS
silverhorn

Default

stupid question...how do you check for vacume leaks?
farrell is offline   Reply With Quote
Old 09-05-2005, 03:51 PM   #8
REDI-wgn
Scooby Specialist
 
Member#: 38068
Join Date: Jun 2003
Chapter/Region: South East
Location: Miami FL
Vehicle:
03 WRX Wagon

Default

get carb cleaner , or similar, and spray around intake manifold area and surrounding and any hoses from intake manifld, it idle changes, thats where you leak is.
some people use a cigarette and let the smoke get sucked in my the leak
REDI-wgn is offline   Reply With Quote
Old 09-05-2005, 03:54 PM   #9
Unsung Boxer
Scooby Specialist
 
Member#: 37196
Join Date: May 2003
Location: WA state
Default

Quote:
Originally Posted by REDI-wgn
get carb cleaner , or similar, and spray around intake manifold area and surrounding and any hoses from intake manifld, it idle changes, thats where you leak is.
some people use a cigarette and let the smoke get sucked in my the leak
this method is fine, just please make sure you dont have old spark plug wires... I have seen guys light an engine bay on fire doing this due to plug wires arcing to ground.

-Jake
Unsung Boxer is offline   Reply With Quote
Old 09-05-2005, 08:31 PM   #10
03scubaru
Scooby Newbie
 
Member#: 83557
Join Date: Mar 2005
Location: Ohio
Vehicle:
2003
PSM Now with 405 whp

Default

If you are venting your bov this could also be the problem.
03scubaru is offline   Reply With Quote
Old 09-06-2005, 08:13 AM   #11
farrell
Scooby Specialist
 
Member#: 47746
Join Date: Nov 2003
Location: east stroudsburg PA
Vehicle:
2000 Impreza 2.5 RS
silverhorn

Default

i figured it out. the maf sensor was to close to the turbo. go figure. extended it out about 7 inches from the turbo and ....tada ..... no more stalling!
farrell is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Stupid RS stalls after driving for more than 30 minutes. GC_Anthony Normally Aspirated Powertrain 8 12-04-2007 12:31 PM
Volkswagen on track to hit goals after strong Q3 NYCshopper Non-Subaru News & Rumors 0 10-27-2006 08:02 AM
Car stalled after a short drive... KIMUTAKU Vancouver Impreza Club Forum -- VIC 6 10-31-2005 04:05 AM
engine stall after hard break from regular driving?? nantong2 Legacy Forum 0 09-12-2004 03:26 AM
OBS 1.8L stalling after refueling...HELP redobs Technical Forum Archive 7 08-08-2000 10:14 AM


All times are GMT -4. The time now is 10:29 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.