Welcome to the North American Subaru Impreza Owners Club Wednesday September 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-19-2005, 05:18 AM   #1
skuwahara
Scooby Newbie
 
Member#: 92562
Join Date: Aug 2005
Location: San Diego
Default 2K RS: Coolant Leak and Sloshing Sound

Hey guys,
I have recently discovered that my 2k rs is leaking coolant pretty bad after smelling sweetness during driving. I will get that taken care of at the dealership, as I recently had work done on the engine.

However I had a few questions about this whole thing, and was hoping I could try to understand whats going on.

1. The coolant is leaking in 2 locations.. right under the engine and at the front, where the radiator connects to the block. Seeing as how it seems to be leaking from more than 1 location, could there be an issue with the pressure of the cooling system, a corrosive additive, or somethig else just wrong?

2. At about the same time this issue occured, I started noticing that at initial startup, there would be a watery sloshing sound coming from my engine when I would rev it. The sound would go away though after a minute or so. Is this a coolant related issue or possibly something else?

Any advice and info would be great.
Thanks in advance
* Registered users of the site do not see these ads.
skuwahara is offline   Reply With Quote
Old 09-19-2005, 07:34 AM   #2
Boom05rs25
Scooby Newbie
 
Member#: 95157
Join Date: Sep 2005
Location: N.W Subs Chicago, Il.
Vehicle:
05 Impreza RS 2.5
OBP 5spd Winged

Default

Take it in right away.....make sure you put some water or coolent in there.....the sound you hear is the lack of coolent in the system as it starts to presurrize its like a straw with a hole in it....the leak is more then likly only in one spot and run off is making it seem like multiple leaks "ei"lower rad hose,water pump,radiator so on.....take it in right away!!
Boom05rs25 is offline   Reply With Quote
Old 09-19-2005, 11:18 AM   #3
C-daleRidr
Scooby Specialist
 
Member#: 18074
Join Date: Apr 2002
Location: Norman, Oklahoma
Vehicle:
2008 Speed3
Black

Default

Mine did the same thing when my headgasket blew. What's your mileage?
C-daleRidr is offline   Reply With Quote
Old 09-19-2005, 11:37 AM   #4
mrpedal
Scooby Newbie
 
Member#: 71361
Join Date: Sep 2004
Chapter/Region: BAIC
Location: SFBay
Vehicle:
2000 Impreza 2.5RS
silver

Default been there.

SOA will warranty MY00 head gasket... Mine was replaced at just over 60K before I bought it (the radiatior failed and it overheated. The Dealer replaced the radiatior and said things were fine. Two years and a couple leakdown tests later, they fixed the gasket, new cyl head, and a bunch of other stuff.) Don't forget to get them to add the Bars-leak....er,
Radiator Coolant Conditioner when they're done.

Another thread on the matter.
mrpedal is offline   Reply With Quote
Old 09-19-2005, 04:46 PM   #5
medfurd
Scooby Newbie
 
Member#: 65227
Join Date: Jun 2004
Location: WA
Default

Sometimes my 99' Forester 5MT, when cold, will make a sort of watery churning sound behind the dash. I'm pretty sure it's just the water pump flowing coolant through the heater core and hoses.
medfurd is offline   Reply With Quote
Old 09-19-2005, 10:35 PM   #6
skuwahara
Scooby Newbie
 
Member#: 92562
Join Date: Aug 2005
Location: San Diego
Default thanks

thanks for your help everyone.
yea, i'll be taking it in tomorrow. i filled up the resvoir with lots of coolant for my drive up (hopefully not too much, if there is such a thing).

to reply to the question about the mileage, its a car with 116K, but a brand new stock engine in it that has about 2K on it. The dealership threw in a 30,000 mile warranty with the engine, and I'm hoping this will get covered, since it seems to be an issue with the connection of the cooling system to the engine.

thanks also about the water churning sounds. thats good to know, and hopefully i wont have to hear it too much more.
skuwahara is offline   Reply With Quote
Old 09-20-2005, 10:09 AM   #7
DreddRS25
Scooby Specialist
 
Member#: 51642
Join Date: Dec 2003
Chapter/Region: TXIC
Location: San Antonio, Texas
Vehicle:
2001 Impreza RS
BRP

Default

Yep my 01RS make the watery sound every so often on start up and even occasionally during stop and go traffic.
DreddRS25 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant leak and need help hellr4iser Newbies & FAQs 4 05-29-2009 08:57 AM
Coolant leak and hiss... Nick Boxler Factory 2.0L Turbo Powertrain 12 04-06-2009 04:29 PM
Water sloshing sound when revving and clutch in? affinity1 Newbies & FAQs 7 04-02-2006 11:07 PM
STI 04 water sloshing sound in cowl area WickedSTI Impreza Forum 5 04-20-2005 04:12 PM
sloshing sound + low coolant OneInchPunch Service & Maintenance 3 03-27-2004 04:39 PM


All times are GMT -4. The time now is 05:05 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.