Welcome to the North American Subaru Impreza Owners Club Friday December 2, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 09-21-2005, 12:16 AM   #1
saloonracer
Scooby Newbie
 
Member#: 62687
Join Date: May 2004
Chapter/Region: South East
Location: Aventura, FL
Vehicle:
2007 Its a Suby
Yeah..its stock :)

Default sulfur smell

OK...so all of a sudden my Suby's exhaust smells horrible. It smells like sulfur. I checked the cat's and they look fine. There is no smell underneath the car, the only place it smells bad is out the muffler.
The cars fine. No check light and my fuel milage seems normal.

What can be causing this? Is it something internally? Oil in the sparkplugs? or misfiring?

It is a very strong smell...I can smell it when the car stopped at a light.
The only thing I could think of is some bad fuel I got or something?

ANy suggestions or ideas would be very helpfull.

cheers
* Registered users of the site do not see these ads.
saloonracer is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-21-2005, 12:18 AM   #2
g-pimpin
Scooby Specialist
 
Member#: 95510
Join Date: Sep 2005
Chapter/Region: NESIC
Location: MA
Vehicle:
02 WRX
15 STI

Default

I went to a dealer for this before and they said it was nothing, so im just going to go catless
g-pimpin is offline   Reply With Quote
Old 09-21-2005, 12:56 AM   #3
jimbobrand
Scooby Specialist
 
Member#: 21935
Join Date: Jul 2002
Chapter/Region: TXIC
Location: San Antonio, TX
Vehicle:
2010 '13 BRZ Premium
WR Blue Pearl

Default

I get this smell too but during acceleration on the highway. I think its from a small exhaust leak and possibly something with one of the cats.
-Jim
jimbobrand is offline   Reply With Quote
Old 09-21-2005, 01:07 AM   #4
saloonracer
Scooby Newbie
 
Member#: 62687
Join Date: May 2004
Chapter/Region: South East
Location: Aventura, FL
Vehicle:
2007 Its a Suby
Yeah..its stock :)

Default

now just if anyone was wondering...my car has just hit 20k miles.

It should in now way be the cat yet ...right?
saloonracer is offline   Reply With Quote
Old 09-21-2005, 01:59 AM   #5
mrpedal
Scooby Newbie
 
Member#: 71361
Join Date: Sep 2004
Chapter/Region: BAIC
Location: SFBay
Vehicle:
2000 Impreza 2.5RS
silver

Default

that's what the smell like when they go bad. Has this been happening for a while, say couple hundred miles? If so, you might have a pending CEL code. Swing by an autozone and ask them to pull a code for you, see if there are any stored like a 0420.

Good news is if your cat is bad, it's under epa warranty till 80K miles.
mrpedal is offline   Reply With Quote
Old 09-21-2005, 11:50 AM   #6
saloonracer
Scooby Newbie
 
Member#: 62687
Join Date: May 2004
Chapter/Region: South East
Location: Aventura, FL
Vehicle:
2007 Its a Suby
Yeah..its stock :)

Default

its only been there for about 80 miles or less. Is this something Subaru needs to fix? I have a borla header so I think they might blame that. I am under the impression that subaru warranty will fix a problem/part unless something else is the direct cause of the problem/malfunction. Almost like a ciruit where if the cause is in-line and infront of the problem, and it isnt a subaru part, your on your own.
saloonracer is offline   Reply With Quote
Old 09-21-2005, 04:10 PM   #7
Boom05rs25
Scooby Newbie
 
Member#: 95157
Join Date: Sep 2005
Location: N.W Subs Chicago, Il.
Vehicle:
05 Impreza RS 2.5
OBP 5spd Winged

Default

Quote:
Originally Posted by saloonracer
its only been there for about 80 miles or less. Is this something Subaru needs to fix? I have a borla header so I think they might blame that. I am under the impression that subaru warranty will fix a problem/part unless something else is the direct cause of the problem/malfunction. Almost like a ciruit where if the cause is in-line and infront of the problem, and it isnt a subaru part, your on your own.
Your right Subaru will deny till there blue in the face .....Not worth wasting your breath....replace it with aftermarket high flow.....you'll thank us in the morning!!
Boom05rs25 is offline   Reply With Quote
Old 09-21-2005, 04:30 PM   #8
mrpedal
Scooby Newbie
 
Member#: 71361
Join Date: Sep 2004
Chapter/Region: BAIC
Location: SFBay
Vehicle:
2000 Impreza 2.5RS
silver

Default yup

Quote:
Originally Posted by Boom05rs25
Your right Subaru will deny till there blue in the face .....Not worth wasting your breath....replace it with aftermarket high flow.....you'll thank us in the morning!!

Yeah, SOA will tell you that the borla made it run too rich, and that is what killed the cat. A high-flow will set you back a couple hundred, but you'll be happy you did it.

Still no cel?
mrpedal is offline   Reply With Quote
Old 09-21-2005, 05:06 PM   #9
svek
*** Banned ***
 
Member#: 82259
Join Date: Mar 2005
Chapter/Region: BAIC
Location: koledge at csus
Vehicle:
1999 impreza 2.2L
Brilliant Red <4EAT Club>

Default

i know when you run the engine hard for a while, like a nice canyon run, it will smell like sulphur
svek is offline   Reply With Quote
Old 09-21-2005, 07:28 PM   #10
mrpedal
Scooby Newbie
 
Member#: 71361
Join Date: Sep 2004
Chapter/Region: BAIC
Location: SFBay
Vehicle:
2000 Impreza 2.5RS
silver

Default

It doesn't smell like hot brakes or clutch, does it?
mrpedal is offline   Reply With Quote
Old 09-21-2005, 07:39 PM   #11
Danny Boy
Scooby Specialist
 
Member#: 94938
Join Date: Aug 2005
Chapter/Region: NESIC
Vehicle:
'99 Hybrid RS Coupe
don't-pull-me-over Silver

Default

I don't think thats anything bad at all. It happens to me almost every time I drive it hard. I forget exactly what it was, but I researched it a while ago and it was nothing.

Danny Boy
Danny Boy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sulfur smell with hi-flow cat (stageII)? sayonara Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 06-23-2004 12:56 AM
('93-'01) Gas/sulfur smell in cabin when I punch it dingo dave Impreza Forum 7 03-19-2004 01:03 PM
sulfur smell after WOT runs? Redline8k Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 12 05-11-2002 09:30 PM
sulfur smell phatroksek Normally Aspirated Powertrain 7 04-11-2002 01:05 PM
('93-'01) sulfur smell with high revs? (going too fast too quick?) nkodemus82 Impreza Forum 5 04-18-2001 06:44 PM

All times are GMT -4. The time now is 04:14 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.