Welcome to the North American Subaru Impreza Owners Club Saturday August 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-30-2005, 11:45 AM   #1
drewdogg
Scooby Specialist
 
Member#: 90003
Join Date: Jun 2005
Chapter/Region: MWSOC
Location: Mars, PA
Vehicle:
2005 STi
OBP

Default Running Lean - Maybe?

Hey guys, I finished a 1.8->2.2 swap running on 1.8 ecu a few weeks ago and have been kinda fine tuning and chasing CEL's since then. I got most all CEL's except for a EGR temp sensor, which according to FSM's there isnt one... but any way im side tracking the real problem......

Right now when i try to push the car fairly hard or better yet when i try to give it more gas than it takes to cruise, or am going up a hill fairly steadily and try to push it more, the engine will bog. The engine will just lose all power and feel almost like im downshifting. I back off the gas a bit and it jumps right back to where it left off-literally. This is getting real annoying especially when i wanna accelerate any more than an old lady. I did put in a 2.5 fuel pump in so i doubt its not getting enough gas, but im thinking that since this is doing it under heavier loads and im opening the throttle letting in more air than the engine/ecu can handle... maybe(?)

Could even be the idle air control letting in too much air. I did try blocking it off cuz i was having idle problems for a while and it ran great when it was hot. But then when the engine was cold, it was having trouble starting so i put a smaller hose on it to allow some air so it would start, but small enough to drive. Maybe i'll give blocking that off another try.

Any thoughts are greatly appreciated.
* Registered users of the site do not see these ads.
drewdogg is offline   Reply With Quote
Old 09-30-2005, 03:52 PM   #2
Storm
Scooby Guru
 
Member#: 5218
Join Date: Mar 2001
Chapter/Region: MWSOC
Location: SAUL'S Motorsports
Vehicle:
96L Most Over-
Developed Beater

Default

Try a tank of good gas to make sure it's not pulling timing under load. 1.8 ECUs have agressive timing maps....moreso than some other ECUs.

A small clamp on the fuel return line will temporarily bump fuel pressure as you increase the amount you crimp it. With this and a gauge, it can be useful in seeing if you're getting enough fuel (regardless of what pump you have in).

Jay Storm
Storm is offline   Reply With Quote
Old 09-30-2005, 04:27 PM   #3
drewdogg
Scooby Specialist
 
Member#: 90003
Join Date: Jun 2005
Chapter/Region: MWSOC
Location: Mars, PA
Vehicle:
2005 STi
OBP

Default

Ok i'll try that...

Oh i meant to put this in before, but i'm also getting around 21 mpg!!!
drewdogg is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sti car runs lean wont stay running =( with (video!) sti3573 Factory 2.5L Turbo Powertrain 28 12-16-2009 01:24 PM
wrx runs better in warm weather. Am i running lean? DLBWRXR Factory 2.0L Turbo Powertrain 7 01-16-2006 09:59 AM
Running lean on top end ('98 vs. '99)? Force[FED] Legacy Forum 3 01-29-2001 01:00 PM
How Do U Know if Your Car is Running Lean? Xscreamer General Forum Archive 7 08-29-2000 09:45 PM
Running Lean? What type of Gauges? Ethan Technical Forum Archive 4 05-24-2000 11:59 AM


All times are GMT -4. The time now is 12:49 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.