Welcome to the North American Subaru Impreza Owners Club Saturday April 25, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-28-2005, 05:53 PM   #1
PR_WRX
Scooby Newbie
 
Member#: 45943
Join Date: Oct 2003
Location: Jacksonville, fl
Vehicle:
2007 wrx
black

Default Help! 05 STI gauge cluster in 04 WRX

I bought an 05 STI gauge cluster for my 04 wrx. The only issue I'm having is the plug that goes on the left side that controls the fuel and temp gauge is different. I've already search and no one has the answer, everything is about the b28 pin but that's only for 02-03. Please help! Thanks!
* Registered users of the site do not see these ads.
PR_WRX is offline   Reply With Quote
Old 09-29-2005, 11:15 AM   #2
Phatron
Scooby Guru
 
Member#: 36033
Join Date: Apr 2003
Chapter/Region: SCIC
Location: Tuning Lab
Vehicle:
CEO PhatBottiTuning
2006 STi GTX3582 + Meth

Default

05's are not plug n play with any other year.
i would suggest selling the 05 cluster and just getting an 04
Phatron is offline   Reply With Quote
Old 09-29-2005, 12:01 PM   #3
vwown3d
Scooby Specialist
 
Member#: 69991
Join Date: Sep 2004
Chapter/Region: South East
Location: USA
Vehicle:
Leh Keen
Approved

Default

would an 05 sti cluster fit in an 05 wrx?
vwown3d is offline   Reply With Quote
Old 09-30-2005, 01:38 PM   #4
o2sys
Scooby Guru
 
Member#: 43842
Join Date: Sep 2003
Chapter/Region: Tri-State
Location: NYC
Vehicle:
200? WRX STI
Aspen White

Default

u didnt search enough, i had the same problem, and i posted a thread about it...look at the plug and the harness carefully, if u cut the ridges of the plug a certain way it will fit, u will have like two pins left over on the cluster but thats ok, it serves other purposes that the WRX doesnt have so it will all function correctly.
o2sys is offline   Reply With Quote
Old 09-30-2005, 01:45 PM   #5
aznguyjac
Scooby Newbie
 
Member#: 87488
Join Date: May 2005
Location: toronto
Default

Quote:
Originally Posted by vwown3d
would an 05 sti cluster fit in an 05 wrx?
i wonder if the 05 sti cluster will fit plug n play in the 05RS as well.....
if so, i can put the cluster into my "wish list"
aznguyjac is offline   Reply With Quote
Old 09-30-2005, 01:48 PM   #6
o2sys
Scooby Guru
 
Member#: 43842
Join Date: Sep 2003
Chapter/Region: Tri-State
Location: NYC
Vehicle:
200? WRX STI
Aspen White

Default

it does fit, just u need to slightly modify the fuel/temp plug and dont forget to cut the b28 wire
o2sys is offline   Reply With Quote
Old 09-30-2005, 04:01 PM   #7
Einherjar
Scooby Newbie
 
Member#: 15582
Join Date: Feb 2002
Chapter/Region: MAIC
Location: 12 Second Wagon!!
Vehicle:
2002 STi Wagon
Full STi swap

Default

I know they fit, but I hear some people have problem with a buzzing, which I presume is the shift beep. Does the shift light & beep work if you put a 05 cluster into a 02 wrx? Thanks.
Einherjar is offline   Reply With Quote
Old 09-30-2005, 04:30 PM   #8
Okita Souji
Scooby Newbie
 
Member#: 41097
Join Date: Aug 2003
Chapter/Region: SCIC
Location: Riverside, CA
Vehicle:
2005 WRX
Aspen White

Default

you don't need to cut any wires for the 04-05s. B28 is the cruise indicator light thats on the gauge cluster on the 04-05 models.
Okita Souji is offline   Reply With Quote
Old 09-30-2005, 04:42 PM   #9
o2sys
Scooby Guru
 
Member#: 43842
Join Date: Sep 2003
Chapter/Region: Tri-State
Location: NYC
Vehicle:
200? WRX STI
Aspen White

Default

Quote:
Originally Posted by Einherjar
I know they fit, but I hear some people have problem with a buzzing, which I presume is the shift beep. Does the shift light & beep work if you put a 05 cluster into a 02 wrx? Thanks.
yea as soon as i plugged it in, the cluster started beeping, so i had to take the back part out and remove the buzzer, but the shift light works fine, and on the 05's the temp gauge will work also
o2sys is offline   Reply With Quote
Old 09-30-2005, 04:52 PM   #10
Okita Souji
Scooby Newbie
 
Member#: 41097
Join Date: Aug 2003
Chapter/Region: SCIC
Location: Riverside, CA
Vehicle:
2005 WRX
Aspen White

Default

Weird, i've never had any issue with the buzzer. It seems like a hit or miss thing with people.
Okita Souji is offline   Reply With Quote
Old 10-01-2005, 06:49 PM   #11
vwown3d
Scooby Specialist
 
Member#: 69991
Join Date: Sep 2004
Chapter/Region: South East
Location: USA
Vehicle:
Leh Keen
Approved

Default

Quote:
Originally Posted by aznguyjac
i wonder if the 05 sti cluster will fit plug n play in the 05RS as well.....
if so, i can put the cluster into my "wish list"

04 wrx and 05 rs have the same plugs. u can cut the plug or just get an 04 sti cluster. im running an 04 sti cluster in my 05 rs.
vwown3d is offline   Reply With Quote
Old 10-02-2005, 08:22 PM   #12
PR_WRX
Scooby Newbie
 
Member#: 45943
Join Date: Oct 2003
Location: Jacksonville, fl
Vehicle:
2007 wrx
black

Default

Thanks for all the good info guys. I know by looking at the plug I can make it fit by modifying it, just wanted to make sure the 2-3 extra pins are not for something important. Already took care of the beeping and like previously stated b28 is not an issue on the 04-05.
PR_WRX is offline   Reply With Quote
Old 10-02-2005, 08:24 PM   #13
o2sys
Scooby Guru
 
Member#: 43842
Join Date: Sep 2003
Chapter/Region: Tri-State
Location: NYC
Vehicle:
200? WRX STI
Aspen White

Default

yea i learned that the B28 wasnt important for the 04-05, no wonder the cruise light wont come on when activated!!! lol, well all fixed now!
o2sys is offline   Reply With Quote
Old 12-19-2005, 07:52 PM   #14
nixgame22
Scooby Specialist
 
Member#: 101219
Join Date: Nov 2005
Chapter/Region: RMIC
Location: Fort Collins CO
Vehicle:
2012 Mojo HD
Bandit 29

Default

any pics or info on removing the buzzer would help me tons!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! please and thank you.
nixgame22 is offline   Reply With Quote
Old 12-28-2006, 11:40 AM   #15
Chapel
Scooby Specialist
 
Member#: 3496
Join Date: Jan 2001
Chapter/Region: NESIC
Location: Salem, MA
Vehicle:
1995 Roadmaster
Beige

Default

also, has anyone had the blown fuse problem?
It blows the radio fuse when you plug it in
Chapel is offline   Reply With Quote
Old 09-24-2007, 04:49 PM   #16
siubaru
Scooby Newbie
 
Member#: 85081
Join Date: Apr 2005
Location: bay area, CA
Vehicle:
2004 wrx
aspen white

Default

I have the same beeping problem, but removed the beeper and fine now but, also have the ABS light on and the brake light on. anyone else have the same problem or know how to fix this. I have an 06 sti cluster into a 04 wrx. thanks.
siubaru is offline   Reply With Quote
Old 09-25-2007, 01:17 AM   #17
GDBF
Scooby Specialist
 
Member#: 108473
Join Date: Feb 2006
Chapter/Region: NWIC
Location: Lakeland Auburn, WA
Vehicle:
2006 WRX Blouch
340whp/363wtq

Default

How did you fix the buzzing sound?? You need to cut two wires. Did you cut it? The ABS light, there isn't a good solution yet. I'm on the search right now. About your brake light, not sure why it's on because they shouldn't be on all the time.
GDBF is offline   Reply With Quote
Old 09-28-2007, 09:07 PM   #18
siubaru
Scooby Newbie
 
Member#: 85081
Join Date: Apr 2005
Location: bay area, CA
Vehicle:
2004 wrx
aspen white

Default

I just removed the buzzer.
siubaru is offline   Reply With Quote
Old 12-20-2007, 03:42 PM   #19
shootinsoobie
Scooby Specialist
 
Member#: 71170
Join Date: Sep 2004
Chapter/Region: SCIC
Location: teh mullet maphia
Vehicle:
04 JBP
All Murdered Out

Default

why dont you just take out the bulbs?!?
shootinsoobie is offline   Reply With Quote
Old 12-21-2007, 09:53 AM   #20
Okita Souji
Scooby Newbie
 
Member#: 41097
Join Date: Aug 2003
Chapter/Region: SCIC
Location: Riverside, CA
Vehicle:
2005 WRX
Aspen White

Default

Quote:
Originally Posted by GDBF View Post
How did you fix the buzzing sound?? You need to cut two wires. Did you cut it? The ABS light, there isn't a good solution yet. I'm on the search right now. About your brake light, not sure why it's on because they shouldn't be on all the time.
ABS light is on because the ABS circuitry for both in the cluster and in the car was changed starting with the 05 model year. I have checked the wiring diagrams for both years and the redesign uses a reverse in the way the voltage reads when the light is on/off. I forget exactly what year has 12v on when the light is off vs. 12v on when the light is off. I'll go over my diagrams and report back later.

The change in the design causes the ABS light to work "backwards" if you don't use a cluster of the same years as your car.

Example: The ABS light usually works by coming on when you turn the key the the "on" position and then goes out after 2 seconds or so. If you use an 04 STi cluster in an 05 WRX, when the key is turned to the "on" position the light will initially be out and will come on after 2 seconds.

I have an 05 WRX and I used a USDM 04 STi cluster and have checked this firsthand. There is no way to make the light work correctly unless you use the following cluster configurations:

02-04MY RS/WRX --> Use 04MY STi cluster

05-07 RS/2.5i/WRX --> Use 05-07 STi cluster (must move certain pins to make the cruise lights, fuel indicator, and temp indicator function correctly).

If you are using a cluster not suited for you model year, the ABS system will still function normally. To get rid of the light I just put tape on the back of the cluster face.

As for the buzzing sound, I never had that problem and my shift alarm works normally. Not sure if this is the case with using JDM STi clusters.

Shootinscoobie: The 04+ STi cluster uses LEDs instead of bulbs.



NOTES: 05-07 STI CLUSTERS HAVE A DIFFERENT HARNESS PLUG ON THE LEFT SIDE COMPARED TO THE RS AND WRX MODELS. YOU WILL NEED TO MODIFY OR FIND A PLUG OUT OF AN STI IN ORDER TO PROPERLY WIRE UP THE CLUSTER.

USING AN 04 STI CLUSTER IN AN 05 RS/WRX WILL PLUG IN NO PROBLEM, BUT THE ABS LIGHT WILL NOT WORK RIGHT.

Last edited by Okita Souji; 12-21-2007 at 10:03 AM.
Okita Souji is offline   Reply With Quote
Old 05-08-2008, 04:28 PM   #21
singincanary
Will mod for Guinness
Moderator
 
Member#: 77921
Join Date: Dec 2004
Chapter/Region: Tri-State
Location: Orange County, New York
Vehicle:
'02 Foz
'07 'beca, '08 OBXT

Default

having the same problems with the abs light, and the e-brake light on my car. Haven't tried the cruise yet.
singincanary is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 STi Gauge Cluster in 04 WRX StealthfishWRX Interior & Exterior Modification 8 04-17-2009 01:08 PM
04-05 sti gauge cluster in bugeye? 98jdmlegacy Interior & Exterior Modification 7 02-12-2009 07:55 PM
WTT: 05 STI gauge cluster for 04 WRX cluster nixgame22 Interior/Dressup/Audio & Security 28 08-15-2007 03:49 AM
WTT: 05 STI gauge cluster, for 04 STI cluster Ctracer911 Interior/Dressup/Audio & Security 0 06-26-2007 01:26 AM
05 STI gauge cluster in 03 wrx, who can do it SICK03SONIK Southern California Impreza Club Forum -- SCIC 3 02-19-2007 08:47 PM


All times are GMT -4. The time now is 03:20 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.