Welcome to the North American Subaru Impreza Owners Club Tuesday July 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-03-2005, 12:55 AM   #1
west_minist
Scooby Specialist
 
Member#: 53451
Join Date: Jan 2004
Location: Caribbean
Vehicle:
2000 JDM Impreza SRX
w/ AVCS Silver

Default MY00 Alternator - Not up to the task???

I got my MY00 NA model back last year and from day one, I noticed that the tunining on the headlights, especially the fogs and my power windows, would cause my interior light to dim slightly, and my revs dropped a bit.

Or if my radiator fan kicks in, gthe revs would dropped a bit and come back up.

Could this be a problem with the alternator not being able to handle the load or going bad -which I doubt?

Is this normal at all?

What can I check?

The battery connectors are good and clean. Ground points seems good, clean and tight.

When driving my voltage is from 13.9-14.2v, which mean nothing if it cannot handle the load.

My battery starts the car very well. Starting is very very crisp.
* Registered users of the site do not see these ads.
west_minist is offline   Reply With Quote
Old 10-04-2005, 06:52 AM   #2
west_minist
Scooby Specialist
 
Member#: 53451
Join Date: Jan 2004
Location: Caribbean
Vehicle:
2000 JDM Impreza SRX
w/ AVCS Silver

Default

Bump!
west_minist is offline   Reply With Quote
Old 10-04-2005, 09:16 AM   #3
tooocool49723
Scooby Specialist
 
Member#: 67127
Join Date: Jul 2004
Chapter/Region: MWSOC
Location: Belleville, MI
Vehicle:
3.3 I <3/h8 my GF3
1.8-2.5-2.2-2.5-2.2-3.3

Default

Does the same thing as mine. It's done it since day one.

If your really worried about it, I hear a WRX alt. has a higher ouput, but i've never really done any research on this, so you might want to do some.
tooocool49723 is offline   Reply With Quote
Old 10-04-2005, 09:55 AM   #4
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Actually the WRX alternator has LESS output than the 2.5 NA alternator, 75A vs. 90A.
Aside from cleaning and tightening connections and grounds, and doing basic voltage checks, if you suspect the alternator may be weak have a shop check it out with proper diagnostic equipment. It is possible for the alternator to have one or more bad diodes which will reduce its output (and may also cause some strange electrical symptoms in the car), but you wouldn't see this on a voltmeter. It would only show up on a diagnostic scope.
Mulder is offline   Reply With Quote
Old 10-09-2005, 11:42 PM   #5
erice1984
Scooby Specialist
 
Member#: 11778
Join Date: Oct 2001
Chapter/Region: MWSOC
Location: Illinois
Vehicle:
1980 VWRabbit Diesel
w/AAZ Swap

Default

i second mulder's response. if you got an o-scope or something laying around hook that thing up to it and look for abnormal wave patterns.

do you experience sluggish performance, or hesistation, if so you can check the grounding points on the rest of the car and check for voltage drop.
erice1984 is offline   Reply With Quote
Old 10-09-2005, 11:49 PM   #6
west_minist
Scooby Specialist
 
Member#: 53451
Join Date: Jan 2004
Location: Caribbean
Vehicle:
2000 JDM Impreza SRX
w/ AVCS Silver

Default

I am suppose to get a the car check out soon bu the shop.

I have no scope around. I would have to ask my friend.

But all true.
west_minist is offline   Reply With Quote
Old 10-09-2005, 11:50 PM   #7
west_minist
Scooby Specialist
 
Member#: 53451
Join Date: Jan 2004
Location: Caribbean
Vehicle:
2000 JDM Impreza SRX
w/ AVCS Silver

Default

No hesitation, except bad performance up to 3K.

I will check it out soon when I visit the dealer.
west_minist is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DD service not up to par superhero Vancouver Impreza Club Forum -- VIC 9 02-02-2004 12:19 PM
Rattling trunk -> weld not up to spec -> fixed??? h2o Southern California Impreza Club Forum -- SCIC 16 11-05-2003 02:48 PM
MY00 will be flatbedded to the nearest dealer BROWNS!:eek: Rick G Tri-State Area Forum 2 12-23-2002 02:10 PM
I think I'm losing my mind! Car not up to par spshultz General Forum Archive 5 03-20-2001 12:04 AM


All times are GMT -4. The time now is 08:01 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.