Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Vancouver Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Vancouver Impreza Club Forum -- VIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-25-2001, 04:21 PM   #1
bender
Scooby Specialist
 
Member#: 1839
Join Date: Jul 2000
Chapter/Region: VIC
Location: at home
Default whiteline rear strut bar installed

just finish installing the strut tower bar at work. it took a little longer then I thought it would(45mins). most of the time was spent trying to do it without taking the rear seatbelt out. it looked like it would fit, but finally gave up and removed it. haven't had a chance to push the car hard to see if there is a difference in handling yet, but for some reason the clunking noise I use to get in the right rear side is now gone maybe the seat belt mechanism was loose. I'll let you guys know when I get a chance to do some hard cornering.

BTW got it from don, of course. great price,too


well I'm off on hoildays in alberta. see you guys after labour day
* Registered users of the site do not see these ads.

Last edited by bender; 08-25-2001 at 04:30 PM.
bender is offline   Reply With Quote
Old 08-25-2001, 11:43 PM   #2
Avenger
Scooby Specialist
 
Member#: 1234
Join Date: Apr 2000
Location: Vancouver, Canada
Vehicle:
2000

Default

I too have that strange sound from my right rear.. maybe the same thing?? I've been thinking it was something to do with the sunroof!
Avenger is offline   Reply With Quote
Old 08-26-2001, 05:11 AM   #3
5 Zigen
Scooby Guru
 
Member#: 769
Join Date: Jan 2000
Chapter/Region: VIC
Location: Burnaby, BC, Canada
Vehicle:
04 SoBaLo EsTea-ai
ZERO/SPORTS/99 GM6/05 BP6

Default

oh really?

used to have that when we had the Kg/mm installed...after we got the KYB and the Cusco rear strut bar is gone again....
5 Zigen is offline   Reply With Quote
Old 08-26-2001, 11:16 AM   #4
markus
Scooby Specialist
 
Member#: 438
Join Date: Oct 1999
Chapter/Region: W. Canada
Location: St. Albert, AB, Canada
Vehicle:
2004 STi
White on Gold

Default

The rear seat belt mechanisms are fiddly little contraptions that can easily be mis-mounted. I had a "clunking" noise after installing my AGX/Whiteline stuff which I originally thought may have been an incorrectly tightend strut shaft, but it was the seatbelt mechanism.

My 2 cents.
markus is offline   Reply With Quote
Old 09-01-2001, 03:54 AM   #5
Avenger
Scooby Specialist
 
Member#: 1234
Join Date: Apr 2000
Location: Vancouver, Canada
Vehicle:
2000

Default

Bender so you took your seat belt thing off and then put it back on and the sound is gone?? or you left the seat belt thing off? Thanks.. I'll be probably be installing it later today..

Thanks!
Avenger is offline   Reply With Quote
Old 09-01-2001, 04:53 AM   #6
Keiho
Sea to Sky - OWNED
Moderator
 
Member#: 610
Join Date: Dec 1999
Chapter/Region: VIC
Location: Vancouver, BC, Canada
Vehicle:
2003 Lexus IS300
Graphite Gray Pearl

Default

Anyone have pics?
Keiho is offline   Reply With Quote
Old 09-01-2001, 12:30 PM   #7
Avenger
Scooby Specialist
 
Member#: 1234
Join Date: Apr 2000
Location: Vancouver, Canada
Vehicle:
2000

Default

I'll take a pic of it later.. too lazy to get my digi cam right now.
Avenger is offline   Reply With Quote
Old 09-01-2001, 12:57 PM   #8
5 Zigen
Scooby Guru
 
Member#: 769
Join Date: Jan 2000
Chapter/Region: VIC
Location: Burnaby, BC, Canada
Vehicle:
04 SoBaLo EsTea-ai
ZERO/SPORTS/99 GM6/05 BP6

Default

Quote:
Originally posted by Avenger
I'll take a pic of it later.. too lazy to get my digi cam right now.
so u have that installed, huh? feels more solid??
5 Zigen is offline   Reply With Quote
Old 09-01-2001, 12:59 PM   #9
Avenger
Scooby Specialist
 
Member#: 1234
Join Date: Apr 2000
Location: Vancouver, Canada
Vehicle:
2000

Default

No I haven't installed it still sitting ontop of the box it came with. Too lazy and -S- want to see me install it, so maybe sometime in the after noon.

Avenger is offline   Reply With Quote
Old 09-01-2001, 01:15 PM   #10
5 Zigen
Scooby Guru
 
Member#: 769
Join Date: Jan 2000
Chapter/Region: VIC
Location: Burnaby, BC, Canada
Vehicle:
04 SoBaLo EsTea-ai
ZERO/SPORTS/99 GM6/05 BP6

Default

Quote:
Originally posted by Avenger
No I haven't installed it still sitting ontop of the box it came with. Too lazy and -S- want to see me install it, so maybe sometime in the after noon.
oh Sunny is back?

but i don't think 2002 is the same...they have easier access i think....

we have to take off the rear seats and two seat belts and 6 strut mount nuts....needs someone to slide the bar into place i think....that's it....
5 Zigen is offline   Reply With Quote
Old 09-01-2001, 01:52 PM   #11
-S-
Scooby Specialist
 
Member#: 6979
Join Date: May 2001
Location: Burnaby, B.C. Canada/Toronto, ON
Default

yeah, i got back on thursday. still dealing with some jet lag though.

looking at my trunk i sure hope i have better access to installing the strut bar... but that'll come later.
-S- is offline   Reply With Quote
Old 09-01-2001, 02:01 PM   #12
5 Zigen
Scooby Guru
 
Member#: 769
Join Date: Jan 2000
Chapter/Region: VIC
Location: Burnaby, BC, Canada
Vehicle:
04 SoBaLo EsTea-ai
ZERO/SPORTS/99 GM6/05 BP6

Default

how's the trip?
5 Zigen is offline   Reply With Quote
Old 09-01-2001, 05:23 PM   #13
-S-
Scooby Specialist
 
Member#: 6979
Join Date: May 2001
Location: Burnaby, B.C. Canada/Toronto, ON
Default

in general, crappy. i hate going back there, and i hate hot humid weather, and i hate scooters that zoom around you, i hate batel nut spitting people, i hate the pollution which turned my nose into a drain...

i think you get the idea

btw, i somehow got the feeling that avenger and i took apart too many things installing his strut bar. we took apart all his rear interior passenger side panels
-S- is offline   Reply With Quote
Old 09-02-2001, 12:15 AM   #14
5 Zigen
Scooby Guru
 
Member#: 769
Join Date: Jan 2000
Chapter/Region: VIC
Location: Burnaby, BC, Canada
Vehicle:
04 SoBaLo EsTea-ai
ZERO/SPORTS/99 GM6/05 BP6

Default

Quote:
Originally posted by -S-
in general, crappy. i hate going back there, and i hate hot humid weather, and i hate scooters that zoom around you, i hate batel nut spitting people, i hate the pollution which turned my nose into a drain...

i think you get the idea

btw, i somehow got the feeling that avenger and i took apart too many things installing his strut bar. we took apart all his rear interior passenger side panels
no kidding....
i think he is trying to locate the noise? hehe....

well....that's life in asia....HK is even worse....
5 Zigen is offline   Reply With Quote
Old 09-02-2001, 12:48 AM   #15
Avenger
Scooby Specialist
 
Member#: 1234
Join Date: Apr 2000
Location: Vancouver, Canada
Vehicle:
2000

Default

I still haven't gotten rid of that clicking sound!
Avenger is offline   Reply With Quote
Old 09-02-2001, 12:58 AM   #16
5 Zigen
Scooby Guru
 
Member#: 769
Join Date: Jan 2000
Chapter/Region: VIC
Location: Burnaby, BC, Canada
Vehicle:
04 SoBaLo EsTea-ai
ZERO/SPORTS/99 GM6/05 BP6

Default

Quote:
Originally posted by Avenger
I still haven't gotten rid of that clicking sound!
is that really loud or what?

plus did u try to tight the rear shocks?
5 Zigen is offline   Reply With Quote
Old 09-02-2001, 02:25 PM   #17
Avenger
Scooby Specialist
 
Member#: 1234
Join Date: Apr 2000
Location: Vancouver, Canada
Vehicle:
2000

Default

Not really loud. But it is just annoying when going over uneven road and I hear a click sometimes..

Quote:
plus did u try to tight the rear shocks?
You mean the top mount onto the vehicle or the nut on the shaft of the shock?
Avenger is offline   Reply With Quote
Old 09-02-2001, 02:32 PM   #18
5 Zigen
Scooby Guru
 
Member#: 769
Join Date: Jan 2000
Chapter/Region: VIC
Location: Burnaby, BC, Canada
Vehicle:
04 SoBaLo EsTea-ai
ZERO/SPORTS/99 GM6/05 BP6

Default

Quote:
Originally posted by Avenger
Not really loud. But it is just annoying when going over uneven road and I hear a click sometimes..


You mean the top mount onto the vehicle or the nut on the shaft of the shock?
both...since u have most of the stuff apart...i don't think u can get access to the shaft like that? so at least the strut mount and if u can both?

i have noise from my front coilovers too...especially when it rains, weird....no one can figure out what's wrong coz i took it apart once and found a broken bump stop (from TEIN!!!) so i put another one and the noise is still there....geez....
5 Zigen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTT:(Socal) Whiteline rear strut bar for gtspec rear strut bar (GC) bue car 1993 - 2001 Impreza Specific Parts 25 11-02-2011 02:27 PM
SoCAL: WRX Whiteline Rear Strut Bar, OEM 20mm Rear Sway Bar, OEM Boost Gauge, Joe MBC YinUCSD Private 'For Sale' Classifieds 18 03-16-2004 12:42 PM
Whiteline rear strut bar...will it fit? balrog Legacy Forum 4 03-29-2003 01:11 AM
FS: BRP Grill, Whiteline Rear Strut Bar, JC Sports Intake munkis Tri-State Area Forum 16 09-23-2002 02:38 PM
FS: Whiteline Rear Strut Bar for 2002 WRX Wagon rdebow Southern California Impreza Club Forum -- SCIC 2 09-15-2002 06:55 PM


All times are GMT -4. The time now is 11:55 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.