Welcome to the North American Subaru Impreza Owners Club Tuesday September 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-08-2005, 12:47 PM   #1
impr25rs
Scooby Specialist
 
Member#: 60162
Join Date: Apr 2004
Location: PDX, OR
Vehicle:
04 Aspen RS
The One Not Turbo'd, NA!!

Default 04 Headlight HELP

Okay i have a 04 RS with a small problem. The other night my driver side low beam went out. No big right. However, when I went to pull the bulb, I found that the buld i s fine, not burnt out. I was like So I tried replacing it with another bulb and it still did not work. I was using these white bulbs I found. So I thought that I would put the stock style ones back in. THe funny thing is that, when I changed them I didn't put the passenger side one all the way in and the drivers side low beam began to work and the passenger one was not. So I went and fixed the passenger side one and now the drive side low beam will not work. What the hell? I am stuck. I checked the fuses and they are fine. The bulbs are connected fine. The only thing that I can think of is that there is a grounding problem. I should mention that the black plastic around the connectors for the bulb is melted off. So other than that I am Help PLZ!!!
* Registered users of the site do not see these ads.
impr25rs is offline   Reply With Quote
Old 10-08-2005, 01:26 PM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Quote:
Originally Posted by impr25rs
I should mention that the black plastic around the connectors for the bulb is melted off. So other than that I am Help PLZ!!!
There's your problem. Those bulbs you "found" ran too hot and damaged the connectors and harness. The fix will be to replace the connectors and any damaged wiring, and only use the proper stock wattage bulbs from now on.
Mulder is offline   Reply With Quote
Old 10-10-2005, 03:28 PM   #3
impr25rs
Scooby Specialist
 
Member#: 60162
Join Date: Apr 2004
Location: PDX, OR
Vehicle:
04 Aspen RS
The One Not Turbo'd, NA!!

Default

Mulder, only the connector had the plastic melt off. So where can I replacements? From Subigal?
impr25rs is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Removing 04 2.5RS headlights?????? HELP!! ThreeSheets2116 Interior & Exterior Modification 14 10-22-2008 08:31 PM
wtb: 04-05 headlights. help! Matzo Balla Private 'Wanted' Classifieds 6 07-22-2006 10:27 PM
Help clearing 04 headlights? Flyn'Rex Texas Impreza Club Forum -- TXIC 10 07-12-2004 05:15 AM
Anyone want to help me do the 04 Headlight mod? svxr8dr North West Impreza Club Forum -- NWIC 0 01-02-2004 02:43 PM
HELP!HELP!HELP! How to put back a 04 headlight??? chopaholix Factory 2.0L Turbo Powertrain 8 10-12-2003 06:52 PM


All times are GMT -4. The time now is 11:38 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.