Welcome to the North American Subaru Impreza Owners Club Sunday January 25, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-18-2005, 11:50 AM   #1
CletusTheDwarf
Scooby Specialist
 
Member#: 27620
Join Date: Oct 2002
Chapter/Region: Tri-State
Location: Syracuse, NY
Vehicle:
2009 Subaru WRX
DGM

Default Heated seats stopped working

I have an 05 wrx, and a few days ago (first time used since summer) i noticed that my heated seats were no longer working. I tried the obvious and switched the heated seats 20A fuse with another 20A fuse, but it didn't do anything. Is there anything else I should try before bringing it in for some warranty work?

Also, I did a radar hardwire mod and hardwired my radar power line into the fusebox to turn on and off with the car. Would they give me a hard time about warranty work like this because of that mod?
* Registered users of the site do not see these ads.
CletusTheDwarf is offline   Reply With Quote
Old 10-18-2005, 02:22 PM   #2
rebos123
Scooby Newbie
 
Member#: 67669
Join Date: Aug 2004
Chapter/Region: MWSOC
Location: Vermilion, OH
Vehicle:
2005 2.5 Hybrid WRX
evoIII 16G

Default

Do the lights on the heated switches work?(the little yellow/orange bars on the rocker switch). Also, have you ever removed your seats from the vehicle? If so, did you reconnect the harnesses for the heaters?
rebos123 is offline   Reply With Quote
Old 10-18-2005, 04:18 PM   #3
CletusTheDwarf
Scooby Specialist
 
Member#: 27620
Join Date: Oct 2002
Chapter/Region: Tri-State
Location: Syracuse, NY
Vehicle:
2009 Subaru WRX
DGM

Default

no, the lights don't light for either seat. and i never took the seats out.
CletusTheDwarf is offline   Reply With Quote
Old 10-18-2005, 05:26 PM   #4
BrentS
NASIOC Supporter
 
Member#: 96601
Join Date: Sep 2005
Chapter/Region: MAIC
Location: Huntington, WV
Vehicle:
2004 WRX
PSM

Default

There is a plug under the switch. Could it have came un-plugged? Did you install a short throw shifter or anything that would cause you to remove the console? It is easy to check. Open the storage lid, pop up the console.
BrentS is offline   Reply With Quote
Old 10-18-2005, 06:40 PM   #5
armand1
Scooby Guru
 
Member#: 10309
Join Date: Sep 2001
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
'02 OBS 2-tone!
'95 Montego Miata

Default

Quote:
Originally Posted by CletusTheDwarf
...
Also, I did a radar hardwire mod and hardwired my radar power line into the fusebox to turn on and off with the car. Would they give me a hard time about warranty work like this because of that mod?
Only if it caused the problem with the seat-heater circuit.
armand1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Heated Seat Issue?!? maxpower_454 Interior & Exterior Modification 11 06-05-2010 09:05 AM
Both heat seats stopped working blah0r Interior & Exterior Modification 5 02-22-2010 10:56 PM
heat stopped working 3rdgearpinned Service & Maintenance 7 12-25-2008 06:05 PM
Passenger heated seat doesn't work...anyone? Mikeye Legacy Forum 6 03-11-2008 08:25 PM
heat stops working sometimes hondaeater69 Service & Maintenance 11 12-18-2005 11:26 PM


All times are GMT -4. The time now is 12:28 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.