Welcome to the North American Subaru Impreza Owners Club Wednesday October 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-21-2005, 11:50 PM   #1
keoni004
Scooby Newbie
 
Member#: 69652
Join Date: Sep 2004
Chapter/Region: South East
Location: North Carolina
Vehicle:
2011 BMW 335i
'05 WRX Wagon (RIP)

Unhappy Tried DRL disable...now CEL?!

Ok, tried to do the DRL disable today. I had read about it, and basically tried to do it by memory. Obviously I unplugged the wrong one, as I ended up with DRL's and a new CEL light. I started the car long enough to get the warning, then powered down. I plugged the cable back in, and the car seems as if it's running fine, but I still have the CEL. Any idea if it'll reset on its own?

Here's a pic I pilfered from saldunn83's DRL post, and I hope he doesn't mind. I unplugged the GREEN one next to the brown.
* Registered users of the site do not see these ads.
keoni004 is offline   Reply With Quote
Old 10-21-2005, 11:55 PM   #2
Casey
Scooby Newbie
 
Member#: 82371
Join Date: Mar 2005
Chapter/Region: NESIC
Location: Princeton, MA
Vehicle:
2002 IMPREZA
22 psi @ 2600rpm

Default

Unplug the neg terminal on your battery, wait a few min, then plug it back in

You'll be all set
Casey is offline   Reply With Quote
Old 10-22-2005, 12:14 AM   #3
keoni004
Scooby Newbie
 
Member#: 69652
Join Date: Sep 2004
Chapter/Region: South East
Location: North Carolina
Vehicle:
2011 BMW 335i
'05 WRX Wagon (RIP)

Default

( <--- newbie ) I'm not gonna get shocked to hell unscrewing the bolt connecting the cable to the negative terminal am I?
keoni004 is offline   Reply With Quote
Old 10-22-2005, 12:50 AM   #4
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

If you unplugged the green connector that is the fuel pump relay. The DRL module is a large rectangular unit with a white 10-pin connector, it is much larger than the relays in that pic.
Mulder is offline   Reply With Quote
Old 10-22-2005, 09:45 AM   #5
Casey
Scooby Newbie
 
Member#: 82371
Join Date: Mar 2005
Chapter/Region: NESIC
Location: Princeton, MA
Vehicle:
2002 IMPREZA
22 psi @ 2600rpm

Default

Quote:
Originally Posted by keoni004
( <--- newbie ) I'm not gonna get shocked to hell unscrewing the bolt connecting the cable to the negative terminal am I?
Not the negative terminal. If you unplug the positive and touch it to a ground you will.
Casey is offline   Reply With Quote
Old 10-22-2005, 10:43 AM   #6
armand1
Scooby Guru
 
Member#: 10309
Join Date: Sep 2001
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
'02 OBS 2-tone!
'95 Montego Miata

Default

The DRL module (says "DRL" on its side) is to the right/behind the one you removed. Take out your glove box for easier access, from the right side.
armand1 is offline   Reply With Quote
Old 10-23-2005, 09:42 AM   #7
RacEoHolic330
Scooby Newbie
 
Member#: 91581
Join Date: Jul 2005
Location: Allentown, PA
Vehicle:
2013 WRX Limited 5dr
ISM

Default

That connector you unplugged is for your cruise control. I'm gonna bet that your cruise no longer works. Thats why you're getting a CEL. The DRL connector is rectangular and it further up along side the glove box. I was able to get mine unplugged without taking out the glove box, but have small hands.
RacEoHolic330 is offline   Reply With Quote
Old 10-23-2005, 10:05 AM   #8
iguanamafia
Scooby Specialist
 
Member#: 23426
Join Date: Aug 2002
Chapter/Region: NESIC
Location: NH USA
Vehicle:
2010 Forester
Streetfighter

Default

if you use a big enough wrench you can hit the positive(+) terminal on the battery while working on the ground (-) and cause some nice fireworks.

Good Luck!!
iguanamafia is offline   Reply With Quote
Old 10-23-2005, 11:47 AM   #9
Fast_Wrx62
Scooby Specialist
 
Member#: 89139
Join Date: Jun 2005
Chapter/Region: MAIC
Location: NoVa
Vehicle:
2002 RIP Bugeye.
PSM

Default

lol......
Fast_Wrx62 is offline   Reply With Quote
Old 10-23-2005, 11:54 AM   #10
Fast_Wrx62
Scooby Specialist
 
Member#: 89139
Join Date: Jun 2005
Chapter/Region: MAIC
Location: NoVa
Vehicle:
2002 RIP Bugeye.
PSM

Default

Is this the right wire?
Fast_Wrx62 is offline   Reply With Quote
Old 10-23-2005, 12:09 PM   #11
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

This is what you need to disconnect (thanks Hank3)-

Mulder is offline   Reply With Quote
Old 10-23-2005, 12:42 PM   #12
Fast_Wrx62
Scooby Specialist
 
Member#: 89139
Join Date: Jun 2005
Chapter/Region: MAIC
Location: NoVa
Vehicle:
2002 RIP Bugeye.
PSM

Default

k let me go try it out....
Fast_Wrx62 is offline   Reply With Quote
Old 10-23-2005, 02:54 PM   #13
Fast_Wrx62
Scooby Specialist
 
Member#: 89139
Join Date: Jun 2005
Chapter/Region: MAIC
Location: NoVa
Vehicle:
2002 RIP Bugeye.
PSM

Default

It Works!
Fast_Wrx62 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY MODS: Intake Silencer Delete / Disable DRL / Disable Seatbelt Warning. User Banned Interior & Exterior Modification 126 10-20-2014 06:42 PM
'03 WRX DRL Disable JustDSM Electrical & Lighting 22 03-13-2003 07:20 PM
Help w/ DRL disable KillerRex Interior & Exterior Modification 9 05-22-2002 08:07 PM
Anyone worked out DRL disable yet? iceweazel Interior & Exterior Modification 0 06-06-2001 10:52 PM


All times are GMT -4. The time now is 08:13 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.