Welcome to the North American Subaru Impreza Owners Club Monday January 26, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-28-2005, 05:23 PM   #1
benetton
Scooby Newbie
 
Member#: 99404
Join Date: Oct 2005
Default Reverse circuit 2005 STI cluster

I'm in the process of installing a 2005 STI cluster into my 2004 WRX
I know some people have had problems with the buzzer going off of the time, but I figured that one out , the only problems I have is that the ABS light stays on(or actually works backwards), in the schematic it shows a reverse circuit, does anyone here know how to make a reverse circuit???

I have search the forum, but can't seam to find anything.

Thanks Brad

and if anyone else is doing the same install, just disconnect the wire in C9 to stop the buzzing
* Registered users of the site do not see these ads.
benetton is offline   Reply With Quote
Old 10-28-2005, 05:34 PM   #2
Okita Souji
Scooby Newbie
 
Member#: 41097
Join Date: Aug 2003
Chapter/Region: SCIC
Location: Riverside, CA
Vehicle:
2005 WRX
Aspen White

Default

Are you putting in a JDM cluster or a USDM cluster?

I'm just trying to figure out the buzzing thing cause mine didn't buzz when I installed it. Wiring schematics for that part of the cluster are the same between 2004 and 2005 which is odd.
Okita Souji is offline   Reply With Quote
Old 10-30-2005, 10:31 AM   #3
vwown3d
Scooby Specialist
 
Member#: 69991
Join Date: Sep 2004
Chapter/Region: South East
Location: USA
Vehicle:
Leh Keen
Approved

Default

only thing i can think of is using a tiny IC and telling it to reverse the on/off sequence. otherwise just slap a huge resistor on there and try to kill the voltage to the light
vwown3d is offline   Reply With Quote
Old 10-30-2005, 03:08 PM   #4
jdm_wrx
Scooby Newbie
 
Member#: 84977
Join Date: Apr 2005
Location: IN THE D
Vehicle:
2002 WRX
ASPEN WHITE

Default

how did you get the gas gauges to work?
jdm_wrx is offline   Reply With Quote
Old 10-31-2005, 08:50 PM   #5
benetton
Scooby Newbie
 
Member#: 99404
Join Date: Oct 2005
Default

I live in canada, the sti cluster is from a 2005 sti and I put them in a 2004 wrx, the buzzer stopped when I removed the terminal from C9 this is the dash lumination on a 2004 wrx, but casues the buzzing on the 2005 sti cluster, like I said the only problem now is the abs light is working backwards, if you look at the schematic it shows a reverse curcuit.
thats what i'm trying to find out how to make.
benetton is offline   Reply With Quote
Old 10-31-2005, 09:00 PM   #6
benetton
Scooby Newbie
 
Member#: 99404
Join Date: Oct 2005
Default

the gas gauge wiring actually go in the exact location, if you look at the connector, but there are different terminal cavity numbers, because the connector actually has two extra terminals

if you want to use the cavity numbers just follow this

sti wrx
a3 a2
a11 a9
a10 a8

this if for both the temp and fuel gauge
benetton is offline   Reply With Quote
Old 03-14-2006, 11:00 PM   #7
Bullitt 2496
Scooby Newbie
 
Member#: 53724
Join Date: Jan 2004
Location: middletown, CT
Vehicle:
2013 Subaru BRZ LS2

Default

has anyone figured out the "reverse circuit" yet?
Bullitt 2496 is offline   Reply With Quote
Old 05-04-2006, 08:21 PM   #8
benetton
Scooby Newbie
 
Member#: 99404
Join Date: Oct 2005
Default

no not yet, still looking
benetton is offline   Reply With Quote
Old 12-28-2006, 12:36 PM   #9
Chapel
Scooby Specialist
 
Member#: 3496
Join Date: Jan 2001
Chapter/Region: NESIC
Location: Salem, MA
Vehicle:
1995 Roadmaster
Beige

Default

what about the blown fuse
what wire causes that?
Chapel is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: PDX Oregon - 2005 STI cluster, 06 sti front/rear seats austinramage Interior/Dressup/Audio & Security 1 07-01-2009 07:58 AM
2005 sti cluster into 2002 wrx ThisizBrian Interior & Exterior Modification 8 12-27-2006 10:59 PM
WTB: 2005 STI cluster Trigun001 Private 'Wanted' Classifieds 1 10-18-2006 12:20 AM
2005 STI cluster in a 2002 WRX- HELP!! SPOOLDU Electrical & Lighting 1 07-31-2006 08:55 AM
F/S 2005 STi cluster with ~ 365 miles 1688 Private 'For Sale' Classifieds 4 09-19-2005 05:02 PM


All times are GMT -4. The time now is 09:37 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.