Welcome to the North American Subaru Impreza Owners Club Thursday October 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-01-2005, 04:19 PM   #1
2.5 Blue Roo
Scooby Specialist
 
Member#: 45727
Join Date: Oct 2003
Chapter/Region: MAIC
Location: MD
Vehicle:
1981 Audi Rally Ur
Quattro

Default Where did you mount your Emanage?

im looking for a spot to mount mine, any suggestions?
* Registered users of the site do not see these ads.
2.5 Blue Roo is offline   Reply With Quote
Old 11-01-2005, 04:20 PM   #2
Hitokiri
Scooby Specialist
 
Member#: 2604
Join Date: Oct 2000
Chapter/Region: NESIC
Location: CA
Vehicle:
1999 2.5RSt
RBP

Default

glove box
Hitokiri is offline   Reply With Quote
Old 11-01-2005, 05:41 PM   #3
Joncas
Scooby Specialist
 
Member#: 5349
Join Date: Mar 2001
Location: Central New York
Default

same here
Joncas is offline   Reply With Quote
Old 11-01-2005, 07:17 PM   #4
darioc
Scooby Specialist
 
Member#: 35695
Join Date: Apr 2003
Chapter/Region: NESIC
Location: 06281
Vehicle:
02 RST
98 Outback 92 Wrangler

Default

im going to tidy mine up and secure between the pass seat and the center thing near the e-brake, so you cant see it.
darioc is offline   Reply With Quote
Old 11-01-2005, 07:31 PM   #5
ai42
Scooby Specialist
 
Member#: 71348
Join Date: Sep 2004
Chapter/Region: TXIC
Location: Frisco, TX
Vehicle:
1999 EJ207 RS.TI
VW Golf TDI 40mpg baby!

Default

I zip tied mine under the passanger seat.
ai42 is offline   Reply With Quote
Old 11-01-2005, 10:08 PM   #6
Derk1127
Scooby Newbie
 
Member#: 9134
Join Date: Aug 2001
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2000 Impreza RS-T
BRP w/Hydra+EJ257

Default

glove box as well
Derk1127 is offline   Reply With Quote
Old 11-02-2005, 04:53 AM   #7
redwagon
Scooby Specialist
 
Member#: 2181
Join Date: Aug 2000
Chapter/Region: SCIC
Location: So Cal
Vehicle:
2008 SpecB
DGM

Default

Under the passenger seat, on my amp rack. Passenger side door sill has that plastic cover to stash the wiring under for protection.
redwagon is offline   Reply With Quote
Old 11-02-2005, 10:16 AM   #8
ExecNav
Scooby Specialist
 
Member#: 30554
Join Date: Nov 2002
Chapter/Region: South East
Location: Ellijay, GA
Vehicle:
08 LGT Spec.B
01 Impreza RS-T

Default

I ran the wiring under the carpet and under the passenger seat. There's a hole there where the vents are under the seat. I just popped the harness plugs out that hole and plugged the emanage in.

-Brett
ExecNav is offline   Reply With Quote
Old 11-02-2005, 01:19 PM   #9
Kawikid20o2
Scooby Specialist
 
Member#: 86291
Join Date: May 2005
Chapter/Region: NESIC
Location: New Fairfield, CT
Vehicle:
'97 LegaSTi-2.5XTR
'96 BrightonCoupeWRX-SR30

Default

glove box but it sucks in the summer if you leave the car in the sun, the emanage gets pissed off and the car wont run right. it wont process the MAF signal at all.
Kawikid20o2 is offline   Reply With Quote
Old 11-02-2005, 02:08 PM   #10
GotTurbo
Scooby Newbie
 
Member#: 64186
Join Date: Jun 2004
Chapter/Region: Tri-State
Location: Glendale, Queens NY
Vehicle:
1998 A MONSTER
SOON BMW STEEL GREY

Default

im voting for the glove box all the way

GotTurbo is offline   Reply With Quote
Old 11-02-2005, 04:29 PM   #11
GregBolby
Scooby Specialist
 
Member#: 498
Join Date: Nov 1999
Chapter/Region: South East
Location: Charleston, SC
Vehicle:
1981 jdm swapped gc
sniklfritz

Default

can you spot it? hmmm
GregBolby is offline   Reply With Quote
Old 11-03-2005, 03:03 AM   #12
tony_subaru
Scooby Specialist
 
Member#: 22742
Join Date: Aug 2002
Chapter/Region: VIC
Location: Kelowna, BC
Default

My friend did his under the passanger seat. Bolted it down. Only thing is it's a pain in the butt to plug the laptop into it to tune and such.
tony_subaru is offline   Reply With Quote
Old 11-03-2005, 08:40 AM   #13
lotusTT
Scooby Specialist
 
Member#: 23359
Join Date: Aug 2002
Chapter/Region: NESIC
Location: San Francisco
Vehicle:
2002 BMW M Coupe
Steel Gray

Default

velcro'd to the carpet under the passenger seat, wires run underneath the carpet.
lotusTT is offline   Reply With Quote
Old 11-03-2005, 08:01 PM   #14
v_dubs37
Scooby Newbie
 
Member#: 73288
Join Date: Oct 2004
Location: Wisconsin
Vehicle:
2002 2.5 RS
Dark Blue

Default

hows the tuning been with the e-manage? I heard they are pretty over rated.
v_dubs37 is offline   Reply With Quote
Old 11-03-2005, 09:23 PM   #15
subachad
Scooby Specialist
 
Member#: 8488
Join Date: Jul 2001
Location: Sin City
Vehicle:
1993 Impreza GCStyle
Teal

Default

Quote:
Originally Posted by v_dubs37
hows the tuning been with the e-manage? I heard they are pretty over rated.
Love it. I'm able to max out my airflow meter at 4.8V with 14psi (2.0 block and 2.2 heads) the thing has smooth air/fuel numbers too. 15.2 idle. 14 cruising, gets down to 10.8 when I get into it.

I have ran it for almost 2 years now.

Chad
subachad is offline   Reply With Quote
Old 11-04-2005, 11:01 AM   #16
BOY
NASIOC Supporter
 
Member#: 232
Join Date: Sep 1999
Chapter/Region: MWSOC
Location: Ft Wayne, IN
Vehicle:
99 RS-T RIP
02 Forster-S

Default

I've got mine under the passenger seat too.
BOY is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Where did you mount your tweets?? Stevins Car Audio, Video & Security 11 04-08-2003 04:36 PM
Where did you mount your HID ballasts? buymeasti Electrical & Lighting 11 03-15-2003 10:24 PM
where did you mount your scramble boost switch? wrxtuner02 Factory 2.0L Turbo Powertrain 1 11-12-2002 09:39 PM
Poll: Where did YOU mount your crossovers? stimpy Car Audio, Video & Security 8 10-23-2000 02:27 PM
S-AFC Where did you mount yours tmaler13 Technical Forum Archive 1 09-02-2000 10:54 AM


All times are GMT -4. The time now is 02:11 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.