Welcome to the North American Subaru Impreza Owners Club Tuesday May 26, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-02-2005, 03:41 AM   #1
chimp82x
Scooby Newbie
 
Member#: 70908
Join Date: Sep 2004
Chapter/Region: E. Canada
Location: Ajax, Ontario
Vehicle:
1998 RBP 2.5RS
EJ20 + Hydra

Question The Bloody Antenna

I'm in the process of removing my antenna to clean up some rust that's beginning to grow around it. Only problem is, I can't seem to get the thing off. I've taken out the two screws and can pull the antenna housing away from the body a bit until it snags on the antenna wire. I can't figure out how to get the antenna wire out of of the car. Anyone know how to do this? I'm gonna completely remove the antenna (and wire) no matter what, and fill in the hole, so cutting the wire to get the housing off as a last resort isn't gonna bother me too much.

Nigel
'98 2.5RS
* Registered users of the site do not see these ads.
chimp82x is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-02-2005, 07:15 AM   #2
DrD
Scooby Guru
 
Member#: 22412
Join Date: Aug 2002
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2012 Legacy 2.5GT
Ice Silver Metallic

Default

you can usually get at the wire from the inside of the car if you pull the trim panel over the a-pillar

did you disconnect the wire from the radio? it could also be snagging on something under the dash... I wouldn't cut it unless you can pull the remaining wire out from inside the car under the dash - otherwise it will be rattling around in there.
DrD is offline   Reply With Quote
Old 11-02-2005, 01:17 PM   #3
chimp82x
Scooby Newbie
 
Member#: 70908
Join Date: Sep 2004
Chapter/Region: E. Canada
Location: Ajax, Ontario
Vehicle:
1998 RBP 2.5RS
EJ20 + Hydra

Default

I took the plastic A-pillar piece off but still couldn't get access to the wire. It's still behind the metal. Disconnecting it from the stereo doesn't help either. Is it clipped on somewhere around the firewall? I can't figure out where it's stuck.
chimp82x is offline   Reply With Quote
Old 11-02-2005, 03:48 PM   #4
STirocket
Scooby Specialist
 
Member#: 84006
Join Date: Mar 2005
Chapter/Region: NWIC
Location: Auburn, WA
Vehicle:
2005 Impreza WRX STi
WRB with Goldies

Default

Oh, jeaz I'm glad that's what your problem is. From the title I thought you'd beat someone to death with your antenna.
STirocket is offline   Reply With Quote
Old 11-02-2005, 07:26 PM   #5
DrD
Scooby Guru
 
Member#: 22412
Join Date: Aug 2002
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2012 Legacy 2.5GT
Ice Silver Metallic

Default

can you follow the wire under the dash over towards base of the the a-pillar - maybe you can pull it down from there (or at least find where it's hung up)
DrD is offline   Reply With Quote
Old 11-02-2005, 08:46 PM   #6
garie
Scooby Specialist
 
Member#: 26607
Join Date: Oct 2002
Location: socal
Vehicle:
2002 wrx wagon

Default

I am going to be doing this sooon.

post when you figure it out!!
garie is offline   Reply With Quote
Old 11-02-2005, 09:12 PM   #7
HappyIdiot
Scooby Newbie
 
Member#: 83494
Join Date: Mar 2005
Chapter/Region: RMIC
Location: Westminster, CO
Vehicle:
2004 WRX Wagon
Red

Default

Quote:
Originally Posted by EDM
I am sure glad my 05 has an in-glass antenna.
So does the 04

Last edited by HappyIdiot; 11-02-2005 at 10:13 PM.
HappyIdiot is offline   Reply With Quote
Old 11-02-2005, 09:49 PM   #8
EDM
Scooby Specialist
 
Member#: 82078
Join Date: Feb 2005
Chapter/Region: SCIC
Location: The 562
Vehicle:
2005 WRX Wagon
PSM

Default

I am sure glad my 05 has an in-glass antenna.
EDM is offline   Reply With Quote
Old 11-03-2005, 05:06 PM   #9
chimp82x
Scooby Newbie
 
Member#: 70908
Join Date: Sep 2004
Chapter/Region: E. Canada
Location: Ajax, Ontario
Vehicle:
1998 RBP 2.5RS
EJ20 + Hydra

Default

Its pretty much impossible to trace through the A-pillar. there are only a few holes in the metal and only one spot where I can actually see the line.
chimp82x is offline   Reply With Quote
Old 01-30-2006, 11:12 AM   #10
craig429
Scooby Newbie
 
Member#: 41767
Join Date: Aug 2003
Location: Bend, OR
Default

I am getting ready to paint and would like to remove the antenna. I have removed the two bolts and can only get the antennia to move about a 1/4". How does the wire get routed? I have removed the A-pillar trim and just can't see how it goes to the stereo. Does it go out of the pillar to under the dash? Or does it go to the fender and then back in? Is there a plug that will prevent the antenna from being pulled out more than a 1/4'?
craig429 is offline   Reply With Quote
Old 01-30-2006, 11:57 AM   #11
chimp82x
Scooby Newbie
 
Member#: 70908
Join Date: Sep 2004
Chapter/Region: E. Canada
Location: Ajax, Ontario
Vehicle:
1998 RBP 2.5RS
EJ20 + Hydra

Default

I still haven't taken mine out for the same reason. I assume it's clipped on somewhere inside the pillar or behind the dash.
chimp82x is offline   Reply With Quote
Old 02-01-2006, 11:21 AM   #12
craig429
Scooby Newbie
 
Member#: 41767
Join Date: Aug 2003
Location: Bend, OR
Default

I found out that the antenna runs straight down from the stereo and runs underneath the drivers carpet and then up to the pillar. There is tape that holds the wire down and the carpet is stuck to the floor that prevents the wire from moving. You will have to remove the drivers kick panel and sill plate to lift the carpet. You should be able to see the wire.
craig429 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New Slogan from Australian Government: "Where the bloody hell are you?" snvin Off-Topic 13 03-14-2006 10:59 PM
HELP!! mahle piston circlips, what tool to hold the bloody things? quadesl57 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 02-13-2006 04:15 AM
Where's the bloody ECU? Al_Smokemcrack Engine Management & Tuning 2 03-24-2005 01:05 AM
what the bloody?!? soundwave Off-Topic 17 09-11-2004 01:45 PM


All times are GMT -4. The time now is 06:34 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.