Welcome to the North American Subaru Impreza Owners Club Tuesday July 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-04-2005, 08:21 AM   #1
MIKENICE456
Scooby Newbie
 
Member#: 98332
Join Date: Oct 2005
Location: derrty jersey
Vehicle:
2005 wrx-cobb stg 2
BLACK

Default i need help electrical burning.

i did my downpipe last night and today there was a smell of something electrical burning and smoke coming in from one of the vents. what is this???!!! please help
* Registered users of the site do not see these ads.
MIKENICE456 is offline   Reply With Quote
Old 11-04-2005, 09:49 AM   #2
MIKENICE456
Scooby Newbie
 
Member#: 98332
Join Date: Oct 2005
Location: derrty jersey
Vehicle:
2005 wrx-cobb stg 2
BLACK

Default

bump...any think they know what it might be?????
MIKENICE456 is offline   Reply With Quote
Old 11-04-2005, 10:57 AM   #3
wrxdrvr
Scooby Specialist
 
Member#: 79222
Join Date: Jan 2005
Chapter/Region: W. Canada
Location: Canada BC
Vehicle:
'09 STi 297.5 WHP
Blue

Default

AC drain hose that comes out of fire wall just above the downpipe is touching downpipe?
wrxdrvr is offline   Reply With Quote
Old 11-04-2005, 11:02 AM   #4
o2sys
Scooby Guru
 
Member#: 43842
Join Date: Sep 2003
Chapter/Region: Tri-State
Location: NYC
Vehicle:
200? WRX STI
Aspen White

Default

Quote:
Originally Posted by wrxdrvr
AC drain hose that comes out of fire wall just above the downpipe is touching downpipe?
most likely
o2sys is offline   Reply With Quote
Old 11-04-2005, 11:44 AM   #5
MIKENICE456
Scooby Newbie
 
Member#: 98332
Join Date: Oct 2005
Location: derrty jersey
Vehicle:
2005 wrx-cobb stg 2
BLACK

Default

thank you i pray that is what it is...if anyone else has any ideas i am open for suggestions. thanks again
MIKENICE456 is offline   Reply With Quote
Old 11-04-2005, 12:04 PM   #6
BlueBoxer
Scooby Newbie
 
Member#: 80753
Join Date: Feb 2005
Location: Indiana
Vehicle:
1995 L

Default

Either the hose is burning (unlikely, never saw mine burn but it did start to crack and deform slightly) or that is steam, not smoke, coming back through the ac system. Once I noticed that the hose was touching my shiny new helix dp, I (like an idiot) cut off the hose closer to the firewall. While driving up the interstate on my way to IL at about 80mph or so, evidently the speed and conditions were just right for the steam to start funneling back up into the vent hose and through my AC/vent system. Gave me a good scare since I had thought I heard detonation while passing a line of cars shortly before the steam started. Pulled onto an offramp and was able to figure it out though. Run your AC for awhile then pop the hood, see if the condensation is dripping on the dp.
BlueBoxer is offline   Reply With Quote
Old 11-04-2005, 02:40 PM   #7
MIKENICE456
Scooby Newbie
 
Member#: 98332
Join Date: Oct 2005
Location: derrty jersey
Vehicle:
2005 wrx-cobb stg 2
BLACK

Default

it burned the hose real good i was bugging out and thiught it smelled electrical but it was just the hose i unclipped and moved it aside. gave me a good scare i thought i had fried my ecu.
MIKENICE456 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help- clutch burn smell nstysti Transmission (AT/MT) & Driveline 1 09-17-2007 01:09 PM
Need help electric people! Dave6265 Tri-State Area Forum 10 05-08-2006 08:21 PM
need help - Electric Boost Gauge install shotoyan Electrical & Lighting 4 01-02-2006 08:40 AM
Need Help! Electrical problem eclone Subaru Conversions 4 01-02-2005 12:43 PM
Need help to burn a EEPROM!! twlai New England Impreza Club Forum -- NESIC 4 02-26-2004 04:38 PM


All times are GMT -4. The time now is 07:36 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.