Welcome to the North American Subaru Impreza Owners Club Monday November 30, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 11-12-2005, 04:01 AM   #1
Scooby Newbie
Member#: 90810
Join Date: Jul 2005
Question Check Engine Light leads to different error codes each time

I have an 01 legacy that keeps having the check engine light come on. The error code readout reads missfire valve 1, then i reset it. Like almost a week later the light came on again. This time the code was missfire valve 4, i reset it and went on my way. Well then like 4 days ago the light came on again and the code was valve 1. Do u have any idea what may be going on with my car?
* Registered users of the site do not see these ads.
whiteryce87 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-12-2005, 10:04 AM   #2
Uncle Scotty
*** Banned ***
Member#: 16200
Join Date: Mar 2002
OK buy Nates beans


...post the codes.....as in '"Pxxxx"....seems like ya got a random issue with the passengers side of the engine.
Uncle Scotty is offline   Reply With Quote
Old 11-13-2005, 01:47 PM   #3
Scooby Specialist
Member#: 33868
Join Date: Mar 2003
Location: Chesterfield, MO
2003 wrx


Is this a wasted spark ignition where there is one coil for two plugs? Are cylinder #1 and #4 on the same coil?

Hope it's the coil, wires or broken plug and not the ECU
rick-l is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine light, AP says no cel codes kingypoo AccessPort 12 07-09-2011 04:12 AM
Check Engine light is on but no code wtf nikiSTI Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 17 01-04-2010 01:16 AM
Check engine light on.... car throws two codes. Why!!!! subie_nation Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 12 02-18-2009 04:11 AM
Check engine light 150 miles after having water pump/timing belt replaced Dural Service & Maintenance 1 06-29-2008 06:21 PM
how eliminat the check engine light due to a high flow exhaust or a catless exhaust minisiu Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 09-13-2002 04:28 AM

All times are GMT -4. The time now is 08:28 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.