Welcome to the North American Subaru Impreza Owners Club Thursday October 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-12-2005, 11:50 AM   #1
the_legacy
Scooby Newbie
 
Member#: 100544
Join Date: Nov 2005
Question 1990 Legacy wagon with a loud, obnoxious rear end

I've got a '90 Subaru Legacy wagon. I can't believe the thing still runs, but it has been getting me around, and it's surprisingly enjoyable too.

But it's got it's problems, as you'd expect from a 15 year old car. First off, the rear end it LOUD. When I start driving the rear axle is just makin' noise. And it is worse or better depending on the speed. For example I think 50mph is usually the loudest, whereas 65 isn't so bad. I have checked out my brakes and the bearings seem ok too. When I turn the wheels with the car off the ground it isn't grinding or anything.... but maybe I'm just not turning them fast enough.

Also, my awd doesn't work, and it never has since I've owned it. I've made sure that the fwd fuse was not in but that doesn't seem to make a difference... And no, the car has not always been loud like this, it only started somewhat recently whereas the awd has never worked for me in the 4-5 years I've owned the car.

Anyone got any ideas?
* Registered users of the site do not see these ads.
the_legacy is offline   Reply With Quote
Old 11-12-2005, 02:39 PM   #2
Plays_With_toys
Scooby Specialist
 
Member#: 82556
Join Date: Mar 2005
Location: Parker, Colorado
Vehicle:
1996 Legacy L wagon

Default

Maybe you can just yank your rear diff and axles. Free up weight, and maybe get rid of the noise maker. You haven't AWD so far, so why spend all the money to possibly fix a problem that is coming out of the RWD portion of the system? Unless others here know that that all has to stay in place for some reason.

Other than that I don't really know how to diagnose the sound. Have you tried rotating the tires front to back?
Plays_With_toys is offline   Reply With Quote
Old 11-13-2005, 07:30 AM   #3
LegacyJones
Scooby Specialist
 
Member#: 48791
Join Date: Nov 2003
Chapter/Region: NESIC
Location: MA
Vehicle:
02 bugeye
wagon

Default

Where ru located?
LegacyJones is offline   Reply With Quote
Old 11-14-2005, 01:51 AM   #4
the_legacy
Scooby Newbie
 
Member#: 100544
Join Date: Nov 2005
Default

Hmm, thanks toys that sounds like a pretty sensible idea. I'm gonna look into that.

And yeah I am in central New York.... the car is in rough shape because we get nasty winters. It's seen a LOT of action.... hell it used to be my grandfather's winter car and he lived up in the mountains and gets absurd amounts of snow. The car is very rusty... it's not pretty.
the_legacy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Took my 1990 Legacy wagon to 14.9 finally, 10 psi reddevil Proven Power Bragging 12 08-14-2006 12:53 AM
Parts, parts, Parting out 1990 Legacy wagon. soslow Private 'For Sale' Classifieds 6 03-16-2006 11:16 PM
Thinking of 1990 Legacy Wagon PETC Legacy Forum 14 06-16-2005 10:43 PM
Parting out 1990 Legacy wagon Legacy777 Private 'For Sale' Classifieds 2 09-07-2004 08:45 AM
Comments on a 1990 Legacy wagon Wheeldog Legacy Forum 25 09-18-2003 08:52 PM


All times are GMT -4. The time now is 09:03 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.