Welcome to the North American Subaru Impreza Owners Club Wednesday August 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > UTEC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-19-2005, 02:24 PM   #251
cdvma
Scooby Specialist
 
Member#: 21980
Join Date: Jul 2002
Chapter/Region: NESIC
Location: Central MA
Vehicle:
2002 PSM WRX (Sold)
2009 BMW X5

Default

It was mentioned/discussed earlier in this thread and if he releases it and you use it be very aware of its limitations. I never released this type of technology because IMHO its too dangerous to release. I don't like to release stuff that can produce false results, fail to operate, ect ect and even big-name supported autotune solutions aren't 100% and require user interaction. People will assume that its a set-and-forget and break stuff.

Jeff, I know I've mentioned it before but if you release this I'd really consider limiting its functionality to suggestive changes and not actually making changes for people. That way they know whats being changed and can make decisions and it will also keep people off your back when they break stuff. Its for their own good.
* Registered users of the site do not see these ads.
cdvma is offline   Reply With Quote
Old 12-19-2005, 02:33 PM   #252
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

Well in the end its always up to the user to actually upload the maps. User input is required for the program to actually generate a new map and I'd make it a little more fool-proof before releasing it.


Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 12-19-2005, 03:04 PM   #253
rainmanjam
Scooby Newbie
 
Member#: 64581
Join Date: Jun 2004
Chapter/Region: NWIC
Location: Lake Oswego, Or
Vehicle:
2004 STI
Black

Default

Ill try out the map editor ed. Wish me luck
rainmanjam is offline   Reply With Quote
Old 12-19-2005, 03:05 PM   #254
Crazykev
Scooby Specialist
 
Member#: 93667
Join Date: Aug 2005
Chapter/Region: MWSOC
Location: Cincinnati,Oh
Vehicle:
'03 Build'n a 2.12L
331whp/331wtq

Default

Sounds pretty cool! I 100% understand that a program cannot totally take care of the tuning. I am waiting for my Tuner Pro which I should have next week and would be really interested in trying it out! I have done my own tuninh, but nothing very aggressive as of yet. Going to swap to an 18G in a couple weeks and will be retuning everything.

Kevin
Crazykev is offline   Reply With Quote
Old 12-19-2005, 06:03 PM   #255
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

Ok well I have found some serious problems with 1.9 versions. A whole bunch of modules arnt working and I have not figured it out yet...i just tested it myself and I am confident I can find it quickly. I guess 1.9D is due tonight.

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 12-19-2005, 06:41 PM   #256
AaronWRX
Scooby Specialist
 
Member#: 7194
Join Date: Jun 2001
Chapter/Region: MAIC
Location: NoVa
Vehicle:
2011 997.2 Turbo
Black

Default

i just tried 1.9C on the way home.

Logger-1 did no update AFR's. It remained static on 14.7.

Dashboard worked though.
AaronWRX is offline   Reply With Quote
Old 12-19-2005, 06:52 PM   #257
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

Yea im hashing through the code and finding some well-hidden bugs. Im going to release 1.9D tomorrow, hopefully all the issues will be worked out. Sorry for the bugs! Every now and then a version comes out that has something really wrong. It is almost always after I add a new feature that hasnt been tested extensively. I am going to test it plenty tomorrow morning to verify its correct operation first.

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 12-19-2005, 08:07 PM   #258
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

Ahh I found where the AFR was being eaten up. It was caused by a small oversight when duplicating code. That is fixed now so you can sleep easy, 1.9D is going to be SOLID!

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 12-20-2005, 02:22 AM   #259
fatray
Scooby Specialist
 
Member#: 18150
Join Date: Apr 2002
Chapter/Region: MAIC
Location: Baltimore MD
Vehicle:
2002 WRX Wagon EJ207
Velocity Red, Liberal kit

Default

Post a link to the self tuning map editor. I'll give it a try, what the hell.
fatray is offline   Reply With Quote
Old 12-20-2005, 05:43 AM   #260
kingston
Scooby Specialist
 
Member#: 25079
Join Date: Sep 2002
Chapter/Region: SCIC
Location: Rowland Heights
Vehicle:
1987 Subaru GL
rust blue

Default

i'll give it a shot...waiver signed.
kingston is offline   Reply With Quote
Old 12-20-2005, 08:17 AM   #261
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

Update: 1.9D is out! All major bugs have been fixed. THis version has been tested and should work perfectly.

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 12-20-2005, 08:57 AM   #262
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

Update: UTI-Map Editor is out. Check it out at the same site as UTI, the link is right below the normal link, its small so look hard!

Read the readme before using. If not you will be wondering why you cant get it to work.

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 12-20-2005, 10:14 AM   #263
rainmanjam
Scooby Newbie
 
Member#: 64581
Join Date: Jun 2004
Chapter/Region: NWIC
Location: Lake Oswego, Or
Vehicle:
2004 STI
Black

Default

Got it working. Under logging 1, the AFR is locked at 15.0 but it works fine under dashboard.
rainmanjam is offline   Reply With Quote
Old 12-20-2005, 01:54 PM   #264
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

hahah I found another typo in the exact same spot that was causing a similar error. The place where i duplicated some code...well I forgot that the variable "s" needed to be replaced with "Data" in 2 places. I corrected one of the two spots last time and didnt even notice that it appears a second time in the very next line of code. OOPs! In replay mode, each line being played back is temporarily stored into the variable "s" when it is evaluated for individual items. Well in actual UTEC interaction, that same line of log is stored in a variable called "Data". I copied and pasted the code that checks for the wb02 at the end and forgot to change "s" to "Data' in both the places where it appears in that section of code.

Ok, well 1.9E will be out later, dang thats a high letter. I dont want to hit 2.0 until I add some new features that im brewing up. Also, I want to get telemetry working somewhat.

Jeff

Last edited by NavyBlueSubaru; 12-20-2005 at 02:35 PM.
NavyBlueSubaru is offline   Reply With Quote
Old 12-20-2005, 02:46 PM   #265
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

I am testing it first then I will release it in about an hour. By 4pm EST at the latest.

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 12-20-2005, 03:57 PM   #266
rainmanjam
Scooby Newbie
 
Member#: 64581
Join Date: Jun 2004
Chapter/Region: NWIC
Location: Lake Oswego, Or
Vehicle:
2004 STI
Black

Default

Also your STuME (Self Tuning Map Editor) doesn't work fully for STI's. Is the format of the csv file different between the STI and the WRX?
rainmanjam is offline   Reply With Quote
Old 12-20-2005, 04:07 PM   #267
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

Well UTI was almost done then at the last minute out of nowhere dashboard mode started screwing up, despite the fact that i never even touched it. Back to the drawing boards, no release until I find the problem. Other than that, everything works great.

UTI-ME is only designed for wrx's. I dont have an sti so i can really do much about it for now. sorry dude

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 12-20-2005, 06:06 PM   #268
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

Update: Version 1.9E is out. This really is what 1.9 should have been from the start. I honestly think it is bug-free, as i've tried it extensively in my own vehicle with 2 different computers.

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 12-20-2005, 06:44 PM   #269
AaronWRX
Scooby Specialist
 
Member#: 7194
Join Date: Jun 2001
Chapter/Region: MAIC
Location: NoVa
Vehicle:
2011 997.2 Turbo
Black

Default

Quote:
Originally Posted by NavyBlueSubaru
UTI-ME is only designed for wrx's. I dont have an sti so i can really do much about it for now. sorry dude

Jeff

i'm pretty sure it will work. I use Utecedit and it doesnt differentiate between a WRX/STI and the maps ive made with that have worked. I will test it tonight and report back.
AaronWRX is offline   Reply With Quote
Old 12-20-2005, 06:58 PM   #270
rainmanjam
Scooby Newbie
 
Member#: 64581
Join Date: Jun 2004
Chapter/Region: NWIC
Location: Lake Oswego, Or
Vehicle:
2004 STI
Black

Default

There is a formatting difference in the persistence logs between WRX and STI (I believe). Logically it should work formula wise.
rainmanjam is offline   Reply With Quote
Old 12-20-2005, 07:39 PM   #271
AaronWRX
Scooby Specialist
 
Member#: 7194
Join Date: Jun 2001
Chapter/Region: MAIC
Location: NoVa
Vehicle:
2011 997.2 Turbo
Black

Default

update. I used the 1.9E tonight on the way home with logger-1 and everything seemed to work great. It did not save any of my table data though. One feature request I think would be cool is if UTI detected a period of inactivity.. (like at a traffic light) that it quickly switches to dashboard mode then back to logger-1 so it can periodicaly update CEL, MODE, SWITCH, Coolant, etc...

Also the map editor seems to work fine for sti utec maps. (as expected) one nice thing for the "New Fuel Map" tab would be to mark the cells it changed. That way the user could choose to smooth out fuel transitions in surrounding cells if they wanted to.
AaronWRX is offline   Reply With Quote
Old 12-20-2005, 10:41 PM   #272
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

In UTI my persistant tables are saving fine when closing the program. They re-open fine as well. Is that what you are having problems with?

Jeff

Last edited by NavyBlueSubaru; 12-20-2005 at 10:53 PM.
NavyBlueSubaru is offline   Reply With Quote
Old 12-20-2005, 11:52 PM   #273
mick_the_ginge
Citizen Mick
 
Member#: 27646
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Portland, Oregon
Vehicle:
2003 Sleeved 2.5
Oil Dry Sump Goodness

Default

Ignore me....
mick_the_ginge is offline   Reply With Quote
Old 12-21-2005, 08:04 AM   #274
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

How is everybody doing this fine morning?

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 12-21-2005, 09:20 AM   #275
2phless
Scooby Specialist
 
Member#: 69343
Join Date: Aug 2004
Chapter/Region: South East
Location: 'tween Lewisville&Clemmons NC
Vehicle:
1998 TransAm cnvrtbl
Black

Default

Hung over.... But I'm about to load up the latest version and see what's what.
2phless is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Enhanced UTEC Interface ...? ScreaminFast Engine Management & Tuning 4 09-20-2003 11:23 PM
UTEC interface enhancement (Long) LiquidForce Engine Management & Tuning 51 06-09-2003 04:10 PM
UTEC Interface Enhancement LiquidForce Factory 2.0L Turbo Powertrain 6 05-29-2003 11:42 AM
UTEC software or interface nekard Engine Management & Tuning 5 10-22-2002 04:16 PM
UTEC interface program question? davidm_sh Engine Management & Tuning 3 10-09-2002 11:07 AM


All times are GMT -4. The time now is 10:34 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.