Welcome to the North American Subaru Impreza Owners Club Wednesday May 6, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > UTEC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-29-2005, 05:26 PM   #101
fatray
Scooby Specialist
 
Member#: 18150
Join Date: Apr 2002
Chapter/Region: MAIC
Location: Baltimore MD
Vehicle:
2002 WRX Wagon EJ207
Velocity Red, Liberal kit

Default

I just started it on my laptop not hooked to UTEC right now and the speach is playing non stop, ALL OF THEM at the same time. Can't stop it.


EDIT
Ok it stopped. Quiting and restarting fixed it.
* Registered users of the site do not see these ads.
fatray is offline   Reply With Quote
Old 11-29-2005, 05:29 PM   #102
rainmanjam
Scooby Newbie
 
Member#: 64581
Join Date: Jun 2004
Chapter/Region: NWIC
Location: Lake Oswego, Or
Vehicle:
2004 STI
Black

Default

Quote:
Originally Posted by TypeC
And that depends on how you're scaling (or not scaling) your maf. Jus to reiterate, this can be extremely dangerous. And you know there is always someone who doesn't rtfm and blows their stuff up.
Oh I know.. Thats why I got a UTEC.. Read and ye shall know...
rainmanjam is offline   Reply With Quote
Old 11-29-2005, 06:16 PM   #103
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

fatray - It does the same thing on my laptop if I disable the "UTI Launched" sound. On my desktop it doesnt do it though...weird.

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 11-29-2005, 06:29 PM   #104
antrey
Scooby Newbie
 
Member#: 87454
Join Date: May 2005
Location: El Paso, Texas
Vehicle:
2005 SAAB 9-2X Aero
Silver

Default

Quote:
Originally Posted by 2phless
Just used your software to fix my x-over hesitation in one felled swoop. It wasn't bad before but I lost the slightest bit of power whenever the utec took over. Watching it happen live let me target the issue. Made it easier to wrap my head around than perusing a log and trying to remember the circumstances. Big number that transition smoothly is key.

I stopped in a parking lot, made what I though would be good corrections. And they were. Smooth sailing now. Very nice.

One idea. You have those substitutions of AIT and Water temp for a timing value. Can you add an option to have it just repeatedly place the map number there? I like to set a few similar maps up in different locations, then run some loops around town and try different ones on the fly. Then I get home and forget the order. Having the number on the map would help a lot on those occasions.

If that isn't hard, other things like the aux solenoid output, and all that dash stuff you can't get from hyperterminal very easily. They'd almost all be useful on occasion.

Otherwise it's working great. Thanks!
Can you give us more detail about what you did to fix your hesitation? Was it a timing issue as most suggest/believe or something else the interface let you see clearly?

****
9-2x project car web page: http://9-2x.dynamic-dyno.com

Last edited by antrey; 11-29-2005 at 06:37 PM.
antrey is offline   Reply With Quote
Old 11-29-2005, 06:31 PM   #105
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

The map tuning thing is just a thing that will show you what the program suggest you tune your map to. It wont actually re-do your map and upload it or anything like that.

What I am going to add is something that shows you your overall tune, based off of how far off you are from your target afr, add all the cells up(absolute value for each) then divide by how many cells are populated. This will give you the average amount that you are off by, then score you based on that number. This way you can do some runs, see your tune quality, then adjust your map accordingly, do more pulls and check your new tune quality and see how much you improved. How cool is that?

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 11-29-2005, 06:33 PM   #106
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

Quote:
Originally Posted by rainmanjam
No hot chick for the audio....damn....but the improvements are AWSOME.. Thanks...
Expect to see a choice of voices in the near future...including a woman

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 11-29-2005, 06:37 PM   #107
antrey
Scooby Newbie
 
Member#: 87454
Join Date: May 2005
Location: El Paso, Texas
Vehicle:
2005 SAAB 9-2X Aero
Silver

Default

Quote:
Originally Posted by TypeC
I would hesitate about going there if I were you. The logic for that isn't exact (x percent maf vs x percent fuel vs load), not to mention all the variables and the liability.

I for one wouldn't want it editing my maps. Now, if it showed suggestions, that would be great. Kinda like if asking for a favor vs pushing your gf's head in your lap; results could be devastating!
I agree with TypeC. Suggested map changes would be much safer for all involved although not nearly as cool as auto-tuning. With all the good work you've done I'd hate for you to lose interest in the UTEC/WRX community due to a lawsuit.

****
9-2x project car web page: http://9-2x.dynamic-dyno.com
antrey is offline   Reply With Quote
Old 11-29-2005, 07:04 PM   #108
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

There is no way to actually do real-time tuning with the UTEC. I can only make suggestions to your map.

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 11-29-2005, 07:24 PM   #109
antrey
Scooby Newbie
 
Member#: 87454
Join Date: May 2005
Location: El Paso, Texas
Vehicle:
2005 SAAB 9-2X Aero
Silver

Default

The version of "auto-tuning" I was picturing was not really real time but automated inputing of new values into the fuel map based on a log file. The fuel map would be changed and saved once without the user keying in the new values manually. A new log file would then be acquired and used to make a further "singular" adjustment to the map cells. This would still be dangerous territory to tread in. Suggestions, as you plan, without directly adjusting the maps sound great to me.

****
9-2x project car web page: http://9-2x.dynamic-dyno.com
antrey is offline   Reply With Quote
Old 11-29-2005, 08:47 PM   #110
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

Update: I just added a nice feature that I was talking about earlier. It analyzes your afr difference and in a nutshell it gives you a Tune Quality for your entire Table, not just the current logger-1 line. It sums up everything except the 0% column and gives you a final score, in real-time. This is very handy for logging pulls and getting a score, then re-tuning and doing more pulls then seeing if your score improved. I thought of this feature today because I wanted a way to tell if I made any real progress in my tuning efforts. I am going to try it out tomorrow when I test out the new map I made which was based on my programs table afr difference results.

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 11-29-2005, 10:16 PM   #111
TypeC
Scooby Guru
 
Member#: 9794
Join Date: Aug 2001
Chapter/Region: TXIC
Location: Texas
Vehicle:
02 2.5LWRX-Retired
335i w/twins

Default

Good work Jeff, hopefully I'll have a chance to test it out tomorrow.
TypeC is offline   Reply With Quote
Old 11-30-2005, 05:27 AM   #112
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

Of course a cold front would come through town today. It is going to throw off my afr by a bit so as to make it difficult for me to make a solid comparison of before/after with my new map. Anyhow Im sure to figure something out. I'll post up a revision this afternoon.

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 11-30-2005, 10:44 AM   #113
2phless
Scooby Specialist
 
Member#: 69343
Join Date: Aug 2004
Chapter/Region: South East
Location: 'tween Lewisville&Clemmons NC
Vehicle:
1998 TransAm cnvrtbl
Black

Default

So far so good. Everything is smooth, fast. The resolution on the setup screen got bigger, which is fine... don't know if that was on purpose. I only use that sitting still, so the smaller setup screen was fine too. Just my take on it though.

Thanks for the map number option. Perfect. Working on making an AFR reference table for my setup. I like it a bit richer. I'll post it up here once I get it smoothed out.

The voices are nifty. Problem is it plays through my stereo (along with the knock sensor audio also through the PC) so XM usually wins out over the drone of the detcan.

+1 for adding the sexy (female) voice, and a rap version . Japanese warnings would be extra jDm-TitE!1!

Although the current colors are very good and very easy to read at a glance.... maybe some skins options? I have my desktop set to kinda match my interior. (Lots of red and black and blue) (no pink!)
2phless is offline   Reply With Quote
Old 11-30-2005, 10:48 AM   #114
fatray
Scooby Specialist
 
Member#: 18150
Join Date: Apr 2002
Chapter/Region: MAIC
Location: Baltimore MD
Vehicle:
2002 WRX Wagon EJ207
Velocity Red, Liberal kit

Default

How long did you have it hooked up to the UTEC when you were driving NavyBlueSubaru? Happened to me 2 times yesterday. After about 10 minutes UTI froze then it was like I was right clicking the mouse on various parts of the screen really really fast over and over again. Then the computer just shut off. This also happened in an older build of UTI. Rebooting and plugging in my USB to Serial adapter caused the PC to shut down again. Only after removing the cord altogether from the TUNER and rebooting did it work again for my 10 minute drive home.
This never happened using Hyper-terminal, or Auto-Logger.
fatray is offline   Reply With Quote
Old 11-30-2005, 10:58 AM   #115
TheMadScientist
Scooby Guru
 
Member#: 23717
Join Date: Aug 2002
Chapter/Region: NESIC
Location: Beverly, MA
Vehicle:
2005 Big red

Default

I just downloaded UTI.
I opened it up on my desktop and I can't see a full window like the screen shot you posted.
Is this because I don't have a Utec hooked up? Is there a way to resize the window?

TMS
TheMadScientist is offline   Reply With Quote
Old 11-30-2005, 10:59 AM   #116
AaronWRX
Scooby Specialist
 
Member#: 7194
Join Date: Jun 2001
Chapter/Region: MAIC
Location: NoVa
Vehicle:
2011 997.2 Turbo
Black

Default

when i launch this new version the audio goes into an very annoying garbled loop.
AaronWRX is offline   Reply With Quote
Old 11-30-2005, 11:28 AM   #117
fatray
Scooby Specialist
 
Member#: 18150
Join Date: Apr 2002
Chapter/Region: MAIC
Location: Baltimore MD
Vehicle:
2002 WRX Wagon EJ207
Velocity Red, Liberal kit

Default

................
fatray is offline   Reply With Quote
Old 11-30-2005, 11:58 AM   #118
rainmanjam
Scooby Newbie
 
Member#: 64581
Join Date: Jun 2004
Chapter/Region: NWIC
Location: Lake Oswego, Or
Vehicle:
2004 STI
Black

Default

.....

Last edited by rainmanjam; 11-30-2005 at 12:04 PM.
rainmanjam is offline   Reply With Quote
Old 11-30-2005, 12:34 PM   #119
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

AaronWRX - My laptop does the same thing if you dont have it set to play the "UTI Launched" sound. It doesnt do it on my desktop so I havnt figured it out yet. I slightly rewrote how sounds are played so that might have fixed it.

TheMadScientist - You must click on "Info" for it to bring up the information like rpm, boost, etc.

fatray - I have had it running for longer than that and I havnt had it crash on me yet. If I have data going into my usb/serial converter before windows boots up then it will crash when it closes the port, so what I do is have it plugged into the computer first, then when UTI launches, I plug in the serial plug and it will almost instantly synchronize. Try it in that order and see if you can get it to crash again.

2phless - I re-did the settings so that it was able to hold more stuff and to be bigger and easier for those with carputers to read.

The main form can be made to be skinnable, however its not like that now. It could come to the point where people actually are making skins for this, which would be pretty cool. I'll see if I can get that in the next version later today.

When I get home today I'll let everyone in on how its going and when to expect a new revision.

BTW, after using my program to better tune my fuel map, I tested it today to work and to where I am at now(eating lunch) and the car pulls much harder than before, it is definitely noticable. My co-worker commented on how the car was pulling considerably harder.

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 11-30-2005, 03:40 PM   #120
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

Tuning Update: After analyzing my pulls, I came up with a tuning quality of 83.4%, up from 80% as of yesterday. This is just after 1 round of map adjustments. It is going to take 2 or 3 round of this to get it fully dialed in, but it was definitely pulling harder and throttle response was great. I am using the new feature I added last night that scores your tune in real-time, and also using my afr difference to make fueling changes in my utec map. Im working on getting some of your requests into the program right now and it will probably be available online around 4:30 or so.

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 11-30-2005, 03:48 PM   #121
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

Future Updates:

*Realtime readout of horsepower, torque, and Thrust (G's)
- This feature is going to be kinda tricky but im laying it out in my mind just how it is going to work.

*Higher quality sounds for overboost/temp/rev warnings.

*Calculation of boost increase, given in psi/sec, to represent how fast you are building boost

*Peak boost hold/display. Possible that program will read out to you your peak boost after a pull(audible).

Many many more..those are just the ones I can remember for now.

Enjoy!

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 11-30-2005, 05:14 PM   #122
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

Update: Version 1.7B is out. Please check over your settings before you use it!

Check the site for update information.

Let me know how it goes!

Jeff
NavyBlueSubaru is offline   Reply With Quote
Old 11-30-2005, 05:49 PM   #123
TheMadScientist
Scooby Guru
 
Member#: 23717
Join Date: Aug 2002
Chapter/Region: NESIC
Location: Beverly, MA
Vehicle:
2005 Big red

Default

I have the sound thing hapening with and without the "UTI Launched" checked.
Ver1.7B On my laptop.

TMS
TheMadScientist is offline   Reply With Quote
Old 11-30-2005, 05:52 PM   #124
TheMadScientist
Scooby Guru
 
Member#: 23717
Join Date: Aug 2002
Chapter/Region: NESIC
Location: Beverly, MA
Vehicle:
2005 Big red

Default

Ver1.7
With the "UTI Launched" checked it is fine. Unchecked it plays all of the sounds. Again on the laptop.

TMS
TheMadScientist is offline   Reply With Quote
Old 11-30-2005, 05:53 PM   #125
NavyBlueSubaru
Scooby Specialist
 
Member#: 22127
Join Date: Jul 2002
Chapter/Region: South East
Location: Oviedo, FL
Vehicle:
2013 BMW 335i Sedan
Estoril Blue

Default

My laptop goes screwy again, yet my desktop doesnt. It is hard for me to fix something like that when it is only on one computer! I'll keep Looking though.

Jeff
NavyBlueSubaru is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Enhanced UTEC Interface ...? ScreaminFast Engine Management & Tuning 4 09-20-2003 11:23 PM
UTEC interface enhancement (Long) LiquidForce Engine Management & Tuning 51 06-09-2003 04:10 PM
UTEC Interface Enhancement LiquidForce Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 05-29-2003 11:42 AM
UTEC software or interface nekard Engine Management & Tuning 5 10-22-2002 04:16 PM
UTEC interface program question? davidm_sh Engine Management & Tuning 3 10-09-2002 11:07 AM


All times are GMT -4. The time now is 11:54 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.