Welcome to the North American Subaru Impreza Owners Club Saturday September 24, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-02-2009, 03:34 PM   #1
STi scene
Scooby Newbie
 
Member#: 183949
Join Date: Jul 2008
Chapter/Region: Tri-State
Location: Selkirk, NY
Vehicle:
05 STi
Black and Gold

Default maybe another blown turbo?

i was on a 3 hour trip to vermont from new york with my 05 sti, cruising at like 75-80 mph, when all of a sudden i got a CEL, it almost seemed like i hit a dog, the car like studdard and it sounded like a dog wimpering(like a loud sqeak type noise) and then i couldnt really build boost. then it started like humming, popping, rattling, grinding all at the same time. the motor runs fine at an idle or when going down a hill at no throtle. i only had 2 somewhat short exits to go so i didnt pull over on the highway. i get off the exit, stop at the stop sign, try to take off and it wanted no part, any rise in boost(still in vacuum) the car fell on its face and i left the biggest cloud of white smoke from the exhaust. i pulled over and started looking at the motor, everything looked fine, my oil was a little low(fine when i left, white smoke=oil, i know) so after about 20 min of sitting there, i was going to try to make it to the garage about a mile or so down the road but couldnt make it there cause i was smoking ssoo much, i couldnt even see behind me at all. there was no noises at all when i started driving again, just the smoke. there was oil dripping out of the tip of the exhaust. like i said, the car runs fine at idle, with oil in it of corse. its just any spool of the turbo.

what do i look for now, does it sound like it is the turbo?
might as well upgrade if it is, what sould i get?
what do i do about all the oil in the exhaust?


sorry if some of this doesnt make sence, i am a horible writer, i was just trying to mention all of the things i could think of
* Registered users of the site do not see these ads.
STi scene is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-02-2009, 04:46 PM   #2
nhat
Scooby Guru
 
Member#: 140163
Join Date: Feb 2007
Chapter/Region: MAIC
Location: 3MI Racing
Vehicle:
03 STi
hellaflunctional

Default

have you had the CEL read?
nhat is offline   Reply With Quote
Old 03-02-2009, 04:54 PM   #3
tekfoc
Scooby Specialist
 
Member#: 21392
Join Date: Jul 2002
Chapter/Region: Tri-State
Location: NEW YORK CITY
Vehicle:
2014 45 AMG MB
WHITE /MB C300 4MATIC

Default

turbo
tekfoc is offline   Reply With Quote
Old 03-02-2009, 04:55 PM   #4
STi scene
Scooby Newbie
 
Member#: 183949
Join Date: Jul 2008
Chapter/Region: Tri-State
Location: Selkirk, NY
Vehicle:
05 STi
Black and Gold

Default

no, not yet. I don't know anyone with a reader and its not like I can drive it anywhere.
STi scene is offline   Reply With Quote
Old 03-03-2009, 01:10 AM   #5
sch3838
Scooby Specialist
 
Member#: 154636
Join Date: Jul 2007
Chapter/Region: Tri-State
Default

white/sweet smell=coolant
black smoke=oil
get OBDII reader, and check for that CEL
sch3838 is offline   Reply With Quote
Old 03-03-2009, 02:27 AM   #6
06-wrx-tr
Scooby Specialist
 
Member#: 185106
Join Date: Jul 2008
Chapter/Region: RMIC
Location: UT
Vehicle:
2006 Subaru WRX WRB
Mazda protege'

Default

sounds like turbo. time for a 20g 0r a fp green!!
06-wrx-tr is offline   Reply With Quote
Old 03-29-2009, 03:58 PM   #7
STi scene
Scooby Newbie
 
Member#: 183949
Join Date: Jul 2008
Chapter/Region: Tri-State
Location: Selkirk, NY
Vehicle:
05 STi
Black and Gold

Default

well, it was the turbo. the piston blew apart and took out the fins of the turbo. so not only do i need a new turbo, i need a block too
STi scene is offline   Reply With Quote
Old 03-29-2009, 06:08 PM   #8
seanathanq83
Scooby Guru
 
Member#: 173241
Join Date: Feb 2008
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
2002 s256 twinscroll
now with one more gear

Default

ouch that stinks
seanathanq83 is offline   Reply With Quote
Old 03-29-2009, 07:13 PM   #9
Fierysun
Scooby Guru
 
Member#: 82745
Join Date: Mar 2005
Chapter/Region: SCIC
Location: So Cal
Vehicle:
2005 Subaru STI
2003 EJ207 S204 Wagon

Default

If you want to get a new factory turbo...you can't lose for $755.

http://www.importimageracing.com/mm5...ategory_Code=5
Fierysun is offline   Reply With Quote
Old 03-29-2009, 08:01 PM   #10
nhat
Scooby Guru
 
Member#: 140163
Join Date: Feb 2007
Chapter/Region: MAIC
Location: 3MI Racing
Vehicle:
03 STi
hellaflunctional

Default

why buy a new one when used vf39/43s go for $300-400 max? or better yet, find a takeoff vf48 for less than that.
nhat is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
another problem... blown turbo?? Hatchbox Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 05-16-2010 09:33 AM
WTB: STi wheels or maybe another set of 17"'s if they look cool FromEvoToRS37 Private 'Wanted' Classifieds 2 07-04-2006 01:11 PM
Maybe a blown fuse? please help sjs0433 Interior & Exterior Modification 3 04-17-2006 02:34 PM
Gold SDR's or maybe another gold rim... -Kevlar- Private 'Wanted' Classifieds 3 03-24-2006 04:28 PM
MORE VENTING#$!@#!@# Seymour Mt. Run = ANOTHER BLOWN MAF Orbiter Vancouver Impreza Club Forum -- VIC 7 08-05-2000 12:47 AM

All times are GMT -4. The time now is 11:34 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.