Welcome to the North American Subaru Impreza Owners Club Tuesday September 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-19-2005, 09:39 PM   #1
idkew
Scooby Newbie
 
Member#: 99980
Join Date: Nov 2005
Chapter/Region: MWSOC
Default Installed DP

So, I just finished installing a Crucial Racing downpipe. It was an install from hell, taking 5+ hours.

On of the bolts on the turbo/downpipe was siezed. It is the one furthest over to the passenger side. So, I had to hack saw it off, then dremel off the remaining. What a PITA.
* Registered users of the site do not see these ads.

Last edited by idkew; 03-12-2007 at 11:04 AM.
idkew is offline   Reply With Quote
Old 11-20-2005, 12:28 AM   #2
Driving_Miss_Daisy
Scooby Specialist
 
Member#: 82311
Join Date: Mar 2005
Chapter/Region: SCIC
Location: Nooooooorth L.A., Cali
Vehicle:
2006 Evolution IX
Electric Blue

Default

Try uninstall the AP and see how it works? That way you can narrow it down between the Ap and the downpipe.
Driving_Miss_Daisy is offline   Reply With Quote
Old 11-20-2005, 02:52 AM   #3
idkew
Scooby Newbie
 
Member#: 99980
Join Date: Nov 2005
Chapter/Region: MWSOC
Default

12345

Last edited by idkew; 12-11-2005 at 10:41 AM.
idkew is offline   Reply With Quote
Old 11-20-2005, 11:46 AM   #4
idkew
Scooby Newbie
 
Member#: 99980
Join Date: Nov 2005
Chapter/Region: MWSOC
Default

well, i think I found the problem, or more like i did find it.

Last edited by idkew; 12-11-2005 at 10:42 AM.
idkew is offline   Reply With Quote
Old 11-20-2005, 11:49 AM   #5
Timmy Burns
Scooby Newbie
 
Member#: 99348
Join Date: Oct 2005
Chapter/Region: South East
Location: Atlanta
Vehicle:
If I could only
get you oceanside.

Default

edit:
get rid of the BOV. you do not need it at all. not at all. its not helping. its hurting your car. get rid of it. now!
Timmy Burns is offline   Reply With Quote
Old 11-20-2005, 04:48 PM   #6
idkew
Scooby Newbie
 
Member#: 99980
Join Date: Nov 2005
Chapter/Region: MWSOC
Default

Sorry, meant BPV, not BOV. It is stock. I did not add a BOV. I know better.


Anyway, I got the stud out, and used a bolt in its place. everything is working now.


Thanks all for helping me work through it.
idkew is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
AP stage 2 with no gauges? jbscooby AccessPort 1 06-26-2006 03:38 PM
AP, Stage 2, Back Pressure, Boost Question? Snoop Factory 2.0L Turbo Powertrain 7 08-30-2005 12:53 AM
AP, Stage 2, Back Pressure, Boost Question? Snoop Engine Management & Tuning 0 08-29-2005 07:40 PM
Cobb stage 2 and no cats, do I still install o2 sensor? breathinez Factory 2.0L Turbo Powertrain 5 05-13-2005 11:31 PM
Installed TXS Stage IV and no boost? MrSwede Factory 2.0L Turbo Powertrain 5 06-08-2003 01:44 AM


All times are GMT -4. The time now is 06:41 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.