Welcome to the North American Subaru Impreza Owners Club Thursday October 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-21-2005, 06:24 PM   #1
GregBolby
Scooby Specialist
 
Member#: 498
Join Date: Nov 1999
Chapter/Region: South East
Location: Charleston, SC
Vehicle:
1981 jdm swapped gc
sniklfritz

Default problems after injector install////

ok now that the wrx inj are in, i had a fuel leak, going into throttle the car will buck a bit once turbo spools up the car seems alot better, also i had a bad fuel leak fixed it and now the car runs better, but after driving sometimes the idle will suck kinda bounce up and down about 300 rpm, seems like power dims lights etc, i was reading about hwo the car might be running super rich, im leaning out about -40% at idle with emanage, and going into light throttle where it hesitates about -30 then goes a little richer -20 then up what gives? could air be getting into the manifold under vacuum?> then once boost hits its ok? so basically not leaking at the fuel rail but leaking at the base of the inj?
???

anyinfo will help

thanks

Greg
* Registered users of the site do not see these ads.
GregBolby is offline   Reply With Quote
Old 11-21-2005, 07:01 PM   #2
darioc
Scooby Specialist
 
Member#: 35695
Join Date: Apr 2003
Chapter/Region: NESIC
Location: 06281
Vehicle:
02 RST
98 Outback 92 Wrangler

Default

i would check to make sure that you dont have an air leak. i had a crappy idle when two of mine had air leaks. double and triple check all of them. you lubed them good right?
darioc is offline   Reply With Quote
Old 11-21-2005, 07:05 PM   #3
GregBolby
Scooby Specialist
 
Member#: 498
Join Date: Nov 1999
Chapter/Region: South East
Location: Charleston, SC
Vehicle:
1981 jdm swapped gc
sniklfritz

Default

at the base of the inj??? did it stumble off idle? liek before turbo spools, once spooled it smooths out
GregBolby is offline   Reply With Quote
Old 11-21-2005, 07:18 PM   #4
darioc
Scooby Specialist
 
Member#: 35695
Join Date: Apr 2003
Chapter/Region: NESIC
Location: 06281
Vehicle:
02 RST
98 Outback 92 Wrangler

Default

well it could be that, or like you said, it could be too rich. it would make sense that it would be too rich and get better when the turbo spits all that air in there. whats your complete setup?
darioc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem after injector and fuel pump install boob8282 Newbies & FAQs 6 03-04-2010 10:29 AM
Rough initial idle and hard start problem after injector install Tronner Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 5 07-23-2009 09:32 AM
Problems after injector mod VegasWRX03 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 11 07-11-2008 05:08 PM
Problems after injector install. BW-REX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 07-20-2006 01:21 PM
Help!!! AC relay fails after injectors install!! Elliot Normally Aspirated with bolt-on Forced Induction Powertrain 2 05-22-2003 03:02 PM


All times are GMT -4. The time now is 05:52 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.