Welcome to the North American Subaru Impreza Owners Club Thursday December 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-22-2005, 06:28 AM   #1
litlechina
Scooby Specialist
 
Member#: 64690
Join Date: Jun 2004
Vehicle:
2005 WRX

Default Need Help! Clutch problem/slipping?

hey I was having a little fun and and ran my friends g35. I took him off the line and slipped the clutch around 4-5,000 rpms as i usually do....but this time something happened....it went up to 6,000 rpm's and stayed there....i shifted into 2nd and then into 3rd....the whole time the rpms stood at 6,000 rpm's.....finally when i got into 4th...the rpm's finally went down a bit and then started building up again....i think the clutch was slipping the whole time...and by the time i knew wut was going on...yes i kno stupid of me...i smelled burned clutch....now call me a noob...wutever...this is my first manual car...althought i kno how to drive...i dotn kno everything there is to it....when i go into 1st and 2nd....when the clutch is engaging i kind of get this slight thumping vibration in my clutch that wasnt there before....isnt just my mind being paranoid after the incident or is my clutch slipping? thanks in advance!....need some advice...oh yah i have cobb stage 2 with 17,500 miles on the car with stock clutch
* Registered users of the site do not see these ads.
litlechina is offline   Reply With Quote
Old 11-22-2005, 11:54 AM   #2
Storm
Scooby Guru
 
Member#: 5218
Join Date: Mar 2001
Chapter/Region: MWSOC
Location: SAUL'S Motorsports
Vehicle:
96L Most Over-
Developed Beater

Default

Just like with spinning wheels...if your clutch is slipping too much, you HAVE TO BACK OFF to let the thing try and grab. If you keep your foot in it...you will only slip more until you get going fast enough for the clutch to grab. Anything you're feeling now is probably a result of hotspots, glazing, or excess material transfer onto the flywheel.

Live with it until it wears away or your next clutch install.

Jay Storm
Storm is offline   Reply With Quote
Old 11-22-2005, 12:16 PM   #3
2fas4u
Scooby Specialist
 
Member#: 90691
Join Date: Jul 2005
Chapter/Region: MAIC
Location: Manchester, Maryland
Vehicle:
2005 STI / 2009 STI
Blue

Default

yep by slipping it that way you did a number on it. These are not drag cars and the clutches are designed for it.....
2fas4u is offline   Reply With Quote
Old 11-22-2005, 03:36 PM   #4
litlechina
Scooby Specialist
 
Member#: 64690
Join Date: Jun 2004
Vehicle:
2005 WRX

Default

you guys are telling me....stoopid mistake made by me....i used to launch it quite fine...but after my cobb stage II i guess i wasnt too used to the power i had....anyways....the glazing you are talking about...does it wear away?....a lot of the times i do not get the symptom anymore and sometimes i do....sometimes after normal driving I still smell burnt clutch....is it wearing off? or will i most likely need a new clutch now...
litlechina is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
clutch problems slipping ?? Javi_LGT Transmission (AT/MT) & Driveline 0 09-26-2008 01:49 PM
Need help- clutch burn smell nstysti Transmission (AT/MT) & Driveline 1 09-17-2007 02:09 PM
Help clutch problems jlegan Transmission (AT/MT) & Driveline 7 07-06-2007 06:47 PM
Need help - Clutch problem; weird noise and feeling elmo3 Transmission (AT/MT) & Driveline 1 06-10-2006 04:48 PM
Help, Clutch problem Derk1127 Transmission (AT/MT) & Driveline 0 09-09-2003 06:23 AM


All times are GMT -4. The time now is 01:54 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.