Welcome to the North American Subaru Impreza Owners Club Thursday October 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-24-2005, 07:33 PM   #1
V8killah91
Scooby Newbie
 
Member#: 101299
Join Date: Nov 2005
Vehicle:
2004 Subaru STi
Silver

Default UTEC Check Engine Light

Hi everyone,

I'm in the process of purchasing a 2004 STI with the all of the modifications required for the UTEC on the car to be set at stage 2. When I was taken for a drive in it, he explained that the check engine light comes on when the UTEC is enabled, but when reverted to the stock ECU configuration, it turns off. I've searched the internet and haven't found anyone else with this problem. I've seen some articles stating that the check engine light will blink when the UTEC detects knock, but nothing like my situation. Anyone know what may be causing this?

Mod list on the car:

UTEC Stage 2
TurboXS Turboback Exhaust
TurboXS Blow Off Valve
TurboXS Manual Boost Controller
Injen CAI

Thanks,
Scott
* Registered users of the site do not see these ads.
V8killah91 is offline   Reply With Quote
Old 11-24-2005, 08:14 PM   #2
BigBoosting
Scooby Newbie
 
Member#: 48553
Join Date: Nov 2003
Chapter/Region: South East
Location: Savannah
Default

your car has thrown a code

utec does not turn on the check engine light

the onl thing utec does with the light is blink it when it detects knock

get the codes pulled from the ecua nd see what they say
BigBoosting is offline   Reply With Quote
Old 11-24-2005, 08:20 PM   #3
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Quote:
Originally Posted by BigBoosting
your car has thrown a code

utec does not turn on the check engine light

the onl thing utec does with the light is blink it when it detects knock

get the codes pulled from the ecua nd see what they say

OBDII scanner and see what's what.......post the code....as in "Pxxxx" and that will tell us what to tell you
Uncle Scotty is offline   Reply With Quote
Old 11-24-2005, 09:02 PM   #4
V8killah91
Scooby Newbie
 
Member#: 101299
Join Date: Nov 2005
Vehicle:
2004 Subaru STi
Silver

Default

Hi,

Thanks for the replies. The thing I don't understand though is that the check light is off when the stock ECU is connected. If the "check engine" light were on the time then I would attribute it to the car throwing a code. Any other ideas?

Thanks,
Scott
V8killah91 is offline   Reply With Quote
Old 11-24-2005, 09:33 PM   #5
testes1010
Scooby Specialist
 
Member#: 47145
Join Date: Nov 2003
Chapter/Region: MWSOC
Location: Henderson, KY
Vehicle:
2012 Gas Saver

Default

are the dip swithes in the correct position?
testes1010 is offline   Reply With Quote
Old 11-24-2005, 09:36 PM   #6
V8killah91
Scooby Newbie
 
Member#: 101299
Join Date: Nov 2005
Vehicle:
2004 Subaru STi
Silver

Default

To tell you the truth, I don't even know what those are. Based on what he said, he had it tuned by a local Subaru tuning shop. So I at least know it was "probably" tuned correctly. I guess I'll just have to give him a call and see what he says.

thanks,
Scott
V8killah91 is offline   Reply With Quote
Old 11-26-2005, 09:42 PM   #7
DISCOPOPE
Scooby Specialist
 
Member#: 43339
Join Date: Sep 2003
Location: mpls, mn
Vehicle:
2oo4 STi
URgt35r w/t3hM3finj3cki0n

Default

the utec can disable the cel light. so if he just drives and ignores the cruise light, that could be what he was talking about.
either you misunderstood him or he is trying to feed you a line of nonsense.

go get the codes pulled, report back.
also, if the cel is off, and the car idles like crap, ask him why he reset the ecu.
DISCOPOPE is offline   Reply With Quote
Old 11-27-2005, 06:19 PM   #8
V8killah91
Scooby Newbie
 
Member#: 101299
Join Date: Nov 2005
Vehicle:
2004 Subaru STi
Silver

Default

Hi,

Thanks for the reply.

I'll probably be picking the car up this week. To clarify, when he took me for a test drive, the light was off when he had the UTEC turned off. As soon as he turned it on, the CEL light turned solid, at which point he explained to me what was going on. The car idled fine and was fast as hell If this sheds light on anything, I'd appreciate any input. I'm getting kind of scared that there may be something wrong, but so far there doesn't seem to be anything other than the light. After I get it, I guess I can go get a diagnostic done at Autozone.

Thanks,
Scott
V8killah91 is offline   Reply With Quote
Old 11-27-2005, 06:28 PM   #9
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Quote:
Originally Posted by V8killah91
Hi,

Thanks for the reply.

I'll probably be picking the car up this week. To clarify, when he took me for a test drive, the light was off when he had the UTEC turned off. As soon as he turned it on, the CEL light turned solid, at which point he explained to me what was going on. The car idled fine and was fast as hell If this sheds light on anything, I'd appreciate any input. I'm getting kind of scared that there may be something wrong, but so far there doesn't seem to be anything other than the light. After I get it, I guess I can go get a diagnostic done at Autozone.

Thanks,
Scott

...something is WRONG with that.....shouldn't DO that.
Uncle Scotty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light, VDC light is on, and cruise control light is flashing grimace09 Normally Aspirated Powertrain 7 08-09-2012 03:42 PM
check engine light comes on and i have utec family wRXagon Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 02-28-2009 01:38 AM
UTEC Check Engine Light Paintballguy Mid Atlantic Impreza Club -- MAIC 6 06-22-2005 12:32 PM
does utec block check engine lights gsteclipse33 Engine Management & Tuning 5 01-12-2005 12:18 PM
wierd utec prob.. check engine light on when i disabled it topgrinder Engine Management & Tuning 2 03-14-2003 04:51 AM


All times are GMT -4. The time now is 01:52 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.