Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-26-2005, 06:25 PM   #1
hermit
Scooby Newbie
 
Member#: 26886
Join Date: Oct 2002
Location: Gardner, MA
Vehicle:
2004 WRX
Platinum Silver Metallic

Default few cel codes

I just got some cel codes(pulled them with accessport) then googled them.

P1091 Tumble generator valve #1 (RH) malfunction (stuck close)
P1092 Tumble generator valve #2 (LH) malfunction (stuck open)
P1095 Tumble generator valve circuit #1 (over current)

I was just wondering what exactly's wrong and how serious it is...can i just reset the ecu and see what happens?

04 wrx...just stage 1 AP

thanks
* Registered users of the site do not see these ads.
hermit is offline   Reply With Quote
Old 11-27-2005, 08:53 AM   #2
04URABUS
Scooby Newbie
 
Member#: 100566
Join Date: Nov 2005
Chapter/Region: NESIC
Location: N.H.
Vehicle:
05 STi
WRB/Silver

Default

I had a long battle with TGV codes. After quite some time, i determined that
all of my problems were related to the installation of my up pipe. There is
the tgv angle sensor right behind the turbo, that i guess i smacked with my up
pipe. I would suggest taking a good look at that sensor and make sure it doesn't
have even the smallest scrape. If it does replace it. It will be the exact same
part number as your TPS.
04URABUS is offline   Reply With Quote
Old 11-28-2005, 12:18 PM   #3
hermit
Scooby Newbie
 
Member#: 26886
Join Date: Oct 2002
Location: Gardner, MA
Vehicle:
2004 WRX
Platinum Silver Metallic

Default

the cel's went off by themselves...should i still take the car to get looked at?

thanks for the reply

edit: the car seems fine...it seemed fine when the cel was on...doesn't sound/smell/perform any different
hermit is offline   Reply With Quote
Old 11-28-2005, 01:34 PM   #4
phantom338
Scooby Newbie
 
Member#: 57277
Join Date: Mar 2004
Default

i had p1095 a few days ago. Car ran terribly. Couldnt accelerate, but it went away a few restarts later, and everytihng was back to normal. Strange.
phantom338 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Had CEL code P0021, a few questions about it Teksi Factory 2.5L Turbo Powertrain 3 06-24-2013 05:31 PM
STG2: Flashing CEL but no CEL code mvitic AccessPort 1 08-10-2006 09:43 PM
HELP: where can I borrow a CEL code reader or get the code pulled for free? anonymous_wolf Vancouver Impreza Club Forum -- VIC 5 08-11-2005 01:40 AM
ECU needs to be re-programmed- a few questions about my CEL codes Slvrblt New England Impreza Club Forum -- NESIC 6 04-26-2003 03:12 AM


All times are GMT -4. The time now is 11:16 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.