Welcome to the North American Subaru Impreza Owners Club Friday February 12, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-29-2016, 12:50 PM   #1
XanderTheGoober
Scooby Newbie
 
Member#: 403167
Join Date: Oct 2014
Location: Minnesota
Vehicle:
2008 Impreza 2.5i
blue

Default New clutch, less feedback

So the clutch on my 08 impreza 2.5i just went out last weekend at 115K
I was on my way to the mechanic to drop off my girlfriend 05 impreza to look at a different issue and a half mile away from the shop my clutch gets really loose and goes all the way down to the floor before disengaging.
If it weren't for the burning smell I would have thought slave cylinder but we figured out it was actually the throw out bearing that went bad. the bearing literally burned up and melted.
Fortunately for me that means no flywheel machining was needed as the friction plate itself was still good, worn but still good so no damage was done.

After I get the car back the clutch feels much better as far as where it engages and disengages but there was much less feedback, not as stiff as it was.
Any ideas on why that might be?
The mechanic said the bearing was a different design, assumed to just be updated from the factory design.

Any one else experience this? Do I just need to do a proper break in and it should provide more feedback? I can get used to the lighter feeling clutch if need be but it just feels so foreign right now... I have been driving the car since Monday night when the repair was finished. Any feedback appreciated. thanks!
* Registered users of the site do not see these ads.
XanderTheGoober is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-30-2016, 08:05 PM   #2
XanderTheGoober
Scooby Newbie
 
Member#: 403167
Join Date: Oct 2014
Location: Minnesota
Vehicle:
2008 Impreza 2.5i
blue

Default

anyone have any ideas?
XanderTheGoober is offline   Reply With Quote
Old Yesterday, 11:46 PM   #3
CP911
Scooby Newbie
 
Member#: 437617
Join Date: Jan 2016
Default

I say drive it for a thousand miles and report back. I recently went through the same thing going from a Porsche 997.1 to my '16 WRX. Clutch pedal on the 911 was much stiffer and when I started driving the WRX it was so light that I could hardly tell what was going on. Had no "feel" as you say. After 2500 miles I now am totally adjusted to it and can feather it perfectly even with the radio blasting (at first I needed to hear what was going on with the revs). I can't imagine going back to a stiffer clutch that tires the lower leg that much faster. I just needed to get used to the softer clutch feel and less pronounced bite. I suspect you do too.
CP911 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:01 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.