Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-07-2005, 10:18 AM   #1
Steven Romero
Scooby Newbie
 
Member#: 77537
Join Date: Dec 2004
Location: Houston, TX - Spring Branch
Vehicle:
2002 Impreza WRX
WR Pearl Blue

Default Alternator belt - replaced and squeaking

Hello everyone.

I recently replaced a frayed alternator belt with one I bought at O'Reilly (GAT Multi-V groove belt part #K050350). I think I got the wrong belt though as it is squeaking in 1st and 2nd gear when speeding up. This is very annoying.

I can't say for sure, but I think I was given the wrong part. The belt was very easy to replace, but when I went to tighten it up I pulled the alternator all the way "up" until it wouldn't go "up" in the slider anymore, and the belt was still "loose" in my opinion.

Are there some other adjustments I'm missing here besides the tensioner bolt that keeps the slider in place and the brass bolt that holds the alternator opposite the tensioner?

Like I said maybe I have the wrong belt, or perhaps the O'Reilly belt isn't the proper specification. I was going to go to the dealership this weekend, and pick up a Subaru belt.

Can anyone contribute?

Thanks.

./s
* Registered users of the site do not see these ads.
Steven Romero is offline   Reply With Quote
Old 12-07-2005, 11:24 AM   #2
2fas4u
Scooby Specialist
 
Member#: 90691
Join Date: Jul 2005
Chapter/Region: MAIC
Location: Manchester, Maryland
Vehicle:
2005 STI / 2009 STI
Blue

Default

Sounds like you have it. The belt sounds like it is too long and it is too loose to run properly....
2fas4u is offline   Reply With Quote
Old 12-07-2005, 01:03 PM   #3
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

FWIW aftermarket belts are ususally crap. they have high concentrations of metals in them to make them cheap. I always get OEM belts for cars.
HndaTch627 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB: Stock Alternator belt shroud and Red rubber boot for alt wire Spec R Private 'Wanted' Classifieds 4 01-29-2010 02:55 PM
Replacing power steering/alternator belt...anything else i should do? IIdiceII Brakes, Steering & Suspension 6 12-12-2006 11:13 PM
Threw alternator belt, replaced, now major vibration??? imprezive Service & Maintenance 13 05-31-2006 10:22 PM
Clue me in: AC & Alternator belts replaced, now squeaking during warmup DanZ Factory 2.0L Turbo Powertrain 1 10-30-2005 01:14 AM
Squeaky squeak.....V-belt replaced..but still the same noise!! WRXtreme78 Factory 2.0L Turbo Powertrain 0 10-02-2003 08:09 PM


All times are GMT -4. The time now is 10:06 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.