Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-10-2005, 02:31 AM   #1
P-TownWRX
Scooby Specialist
 
Member#: 90903
Join Date: Jul 2005
Chapter/Region: NWIC
Location: Happy Valley
Default Terrible Gas mileage, help!

Mods are, Hyperflow TMIC and PP EM, not very much done yet.
I havn't been driving very much but lately i have been noticing my needle dropping really fast. I went in to fill up and got 23mpg, not to bad considering I had been driving hard, but I had already gone through a 1/4 tank plus some and only gone 62 miles. I normally do at least 80 before getting there. Yesterday I drove home(120 miles) and then around town and when i filled up(at 180 miles on the tank) I had gotten only 18.7 on the freeway??? I used to get 28-30 on the freeway. What could possibly be causing this so suddenly, it all went from normal to 10MPG less in only 2 weeks.

-Travis
* Registered users of the site do not see these ads.
P-TownWRX is offline   Reply With Quote
Old 12-10-2005, 03:15 AM   #2
SubNoob
Scooby Newbie
 
Member#: 99790
Join Date: Nov 2005
Chapter/Region: MWSOC
Location: Stl, MO
Vehicle:
02 WRX Aspen White
OT Ninja

Default

Must be that time bomb i took out of my car and put in yours
SubNoob is offline   Reply With Quote
Old 12-10-2005, 10:12 AM   #3
HappyIdiot
Scooby Newbie
 
Member#: 83494
Join Date: Mar 2005
Chapter/Region: MAIC
Location: Springfield, VA
Vehicle:
2004 WRX Wagon
Red

Default

If you are driving with the defroster on, then the a/c automatically comes on so that will dock you a few mpg. If you go to scooby mods, they can show you how to change that. Then if you letting your car idle for a little bit before you drive, than that might be a few more. Plus with winter gas, I have heard, will result in a 1-2 mpg decrease. But not enough to account for 10 mpg drop.
HappyIdiot is offline   Reply With Quote
Old 12-10-2005, 10:15 AM   #4
Wheeler Bement
Scooby Specialist
 
Member#: 15652
Join Date: Feb 2002
Chapter/Region: TXIC
Location: sugar land, katy
Vehicle:
2002 2.5L WRX Wag.
160K club

Default

plugs? air filter? fuel filter? etc
Wheeler Bement is offline   Reply With Quote
Old 12-10-2005, 11:56 AM   #5
REX8
*** Banned ***
 
Member#: 24038
Join Date: Sep 2002
Chapter/Region: South East
Location: Godspeed Cale...
Default

Winter gas will kill your mileage significantly. I went from 300 a tank to 260 a tank...
REX8 is offline   Reply With Quote
Old 12-10-2005, 11:58 AM   #6
Danny Boy
Scooby Specialist
 
Member#: 94938
Join Date: Aug 2005
Chapter/Region: NESIC
Vehicle:
'99 Hybrid RS Coupe
don't-pull-me-over Silver

Default

Did you reset your ecu anytime in the recent past?
Danny Boy is offline   Reply With Quote
Old 12-10-2005, 05:08 PM   #7
subenerd
Scooby Specialist
 
Member#: 72630
Join Date: Oct 2004
Location: CA
Vehicle:
2004 STi

Default

With my mods; catless uppipe, IC hoses, TBE w/highflow cat and ecutek I got 253 miles on 12.75 gallons...what is that 253/12.75 = 19.84 mpg? And that was TRYING to stay off boost, haha that sucks
subenerd is offline   Reply With Quote
Old 12-10-2005, 06:17 PM   #8
HappyIdiot
Scooby Newbie
 
Member#: 83494
Join Date: Mar 2005
Chapter/Region: MAIC
Location: Springfield, VA
Vehicle:
2004 WRX Wagon
Red

Default

Quote:
Originally Posted by subenerd
With my mods; catless uppipe, IC hoses, TBE w/highflow cat and ecutek I got 253 miles on 12.75 gallons...what is that 253/12.75 = 19.84 mpg? And that was TRYING to stay off boost, haha that sucks
I assume it was stop and go city driving?
HappyIdiot is offline   Reply With Quote
Old 12-10-2005, 06:34 PM   #9
REDI-wgn
Scooby Specialist
 
Member#: 38068
Join Date: Jun 2003
Chapter/Region: South East
Location: Miami FL
Vehicle:
03 WRX Wagon

Default

keep you foot off the gas....lol.

i have uppipe, tbe, top mount w/hoses, utec(tuned by me which i know i am disgustingly rich), intake and squeezing 300+ each tank with the occasional spirited drive. i dont deal with winter gas tho....
REDI-wgn is offline   Reply With Quote
Old 12-10-2005, 07:07 PM   #10
P-TownWRX
Scooby Specialist
 
Member#: 90903
Join Date: Jul 2005
Chapter/Region: NWIC
Location: Happy Valley
Default

Well I just filled up on thursday night and am at 50 miles(plus i got dyno tuned today so 10 hard pulls, plus a few on the way home) And I think i am back on track, 60 miles and not even to the 1/4 tank mark, it must have just been a really bad tank of gas or something. Maybe they accidently spilled milk, or water or peed in the gas at that station(it was a chevron premium). But it looks like problems solved, it was just a one time thing. But it is about time for filters and plugs within the next 2K miles.
P-TownWRX is offline   Reply With Quote
Old 12-10-2005, 08:34 PM   #11
subenerd
Scooby Specialist
 
Member#: 72630
Join Date: Oct 2004
Location: CA
Vehicle:
2004 STi

Default

Quote:
Originally Posted by HappyIdiot
I assume it was stop and go city driving?
Probably 60/40 highway and street

Quote:
Originally Posted by REDI-wgn
keep you foot off the gas....lol.

i have uppipe, tbe, top mount w/hoses, utec(tuned by me which i know i am disgustingly rich), intake and squeezing 300+ each tank with the occasional spirited drive. i dont deal with winter gas tho....
I still had a few gallons in the tank so I could have gotten around 280 I think...its REALLY hard for me to stay off boost. When I was stock I could do 300+ miles but whats the fun in that ?
subenerd is offline   Reply With Quote
Old 12-10-2005, 09:30 PM   #12
rpdwrx
Scooby Specialist
 
Member#: 92904
Join Date: Aug 2005
Chapter/Region: MWSOC
Location: Land of Oppression
Vehicle:
2002 PSM WRX
1998 RBP WRSX

Default

My 02 WRX was stock until I changed my transmission and rear differential oil, samco intercooler hoses and a lightened crank pulley. I usually got about 280 miles per tank and right after the mods I am only getting about 210 per tank. *** happened?
rpdwrx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Terrible gas mileage? Gr3en Normally Aspirated Powertrain 6 04-22-2008 01:09 PM
Terrible Gas Mileage! Help persianpunisher General Community 46 03-08-2005 08:42 PM
Weird engine noise and terrible gas mileage... K Rock Impreza Normally Aspirated Powertrain 11 11-17-2004 07:38 PM
Horrible, Terrible Gas Mileage Devilprobably Texas Impreza Club Forum -- TXIC 42 06-23-2004 11:53 PM
terrible gas mileage with MY00 Keirik Technical Forum Archive 23 07-23-2000 10:51 AM


All times are GMT -4. The time now is 07:39 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.