Welcome to the North American Subaru Impreza Owners Club Monday January 26, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-12-2005, 12:02 AM   #1
jahwarrior007
Scooby Newbie
 
Member#: 102690
Join Date: Dec 2005
Location: Sunny NE Arizona
Vehicle:
1995 impreza outback
red w/grey

Exclamation overheating (again)

Hi to you all from sunny NE AZ, right now it's about 15 degrees outside...anyway
I am new, but enjoy the site and thought I'd better join the family...I have a '95
impreza outback sport, started getting hot last summer, took out the guts of the thermostat and ran it until it got a little too chilly...bought an AutoZone thermostat, that didn't work, finally bought a Subaru thermostat, still got hot, bought a new radiator cap, just finished taking a 15 mile test drive, got hot, I got down and checked and found the bottom hose cold...I know that I did install the thermostat with the small "squiggily" thing toward the bypass hose. ...I did put the same coolant back in...also saw something about the headgaskets...I took of the cap and let it idle, did see some bubbles, but not too sure what kind I am supposed to see...these were, like big air pockets coming up every 15 seconds or so ...This is most likely an easy one for you Subaru vets, but I am not much of a mechanic, but do keep the oil, the rest of the maintenance up.
Thanks for your time.
* Registered users of the site do not see these ads.
jahwarrior007 is offline   Reply With Quote
Old 12-12-2005, 12:28 AM   #2
Mike Wevrick
RIP 1/19/64 - 7/23/11
Scooby Guru
 
Member#: 24654
Join Date: Sep 2002
Chapter/Region: NESIC
Location: saraseager.com
Vehicle:
1957 Taggart Comet
atlasshruggedpart1.com

Default

Sounds like air trapped in the system. Just keep topping it up (slowly) until no more air comes out. It's also possible your system is blocked somewhere and you might need a new radiator.
Mike Wevrick is offline   Reply With Quote
Old 12-12-2005, 08:56 PM   #3
sube-trex
Scooby Specialist
 
Member#: 97577
Join Date: Oct 2005
Chapter/Region: BAIC
Location: OR->WA->TX->OR->CA
Vehicle:
Bug In Your
Eye

Default

i replaced the radiator with a $390 Koyo one and new thermo. told the dealer what i did...they gave me a quote for service less than $100 and bam when i pick up not even 100, they said it was air trapped in system.... i sure felt stupid.
sube-trex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My STI is overheating when the AC is on and the AC fan doesnt work, why overheating? nicksamba_18 Off-Topic 9 08-21-2009 08:37 PM
My STI is overheating when the AC is on and the AC fan doesnt work, why overheating? nicksamba_18 Service & Maintenance 0 08-21-2009 08:21 PM
Wheels (yes, once again) Section 8 Legacy Forum 4 06-09-2002 05:35 PM
Test and Tune on Saturday 23rd(lets try this again) dannyboy7 North West Impreza Club Forum -- NWIC 19 03-23-2002 11:34 PM
Borla headers (yes again) spshultz General Forum Archive 8 08-21-2000 03:38 AM


All times are GMT -4. The time now is 02:37 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.