Welcome to the North American Subaru Impreza Owners Club Monday July 14, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-08-2001, 10:12 PM   #1
speedracer47
Scooby Newbie
 
Member#: 2765
Join Date: Oct 2000
Location: Lynnwood, WA
Vehicle:
2000 Impreza RS
'85 Toyota 4x4

Question Need help regarding XT6 idle problem

I just got an '89 XT6 yesterday. It ran fine when I bought it. Today I revved it up in neutral and it stalled when the revs dropped. Now it won't idle unless the throttle is part open. Otherwise it runs fine. It will pull hard to redline in every gear but will always stall when in neutral.

Is this an O2 sensor problem or throttle position sensor possible?

Anyone have any suggestions?

thanks,

Dan
* Registered users of the site do not see these ads.
speedracer47 is offline   Reply With Quote
Old 09-08-2001, 10:30 PM   #2
8Complex

Moderator
 
Member#: 922
Join Date: Feb 2000
Chapter/Region: MWSOC
Location: Schaumburg, IL
Vehicle:
04 FXT
Red

Default

Idle control solenoid maybe?
8Complex is offline   Reply With Quote
Old 09-09-2001, 12:18 AM   #3
speedracer47
Scooby Newbie
 
Member#: 2765
Join Date: Oct 2000
Location: Lynnwood, WA
Vehicle:
2000 Impreza RS
'85 Toyota 4x4

Default

thanks 8complex, i'll check that.

anyone else? i know there's some xt guys on here.
speedracer47 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help regarding a ticket. Dont need lawyer!! selvar05WRX North West Impreza Club Forum -- NWIC 32 05-07-2009 12:11 PM
Need help regarding exhaust sys irfanuq Southern California Impreza Club Forum -- SCIC 1 02-20-2003 11:04 AM
urgent, need help regarding custom alignment maomaonsx Bay Area Impreza Club Forum -- BAIC 4 03-01-2001 08:23 PM
Need help regarding stupid ass tickets 604 Keiho Vancouver Impreza Club Forum -- VIC 22 07-23-2000 03:54 PM


All times are GMT -4. The time now is 03:37 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.