Welcome to the North American Subaru Impreza Owners Club Thursday September 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-15-2005, 07:44 PM   #1
vt3fan4evr
Scooby Newbie
 
Member#: 103048
Join Date: Dec 2005
Location: Vermont
Question Thermostat and no flow 94 Legacy

Hi all I was asked to replace the thermostat on a freinds 94 Legacy. When I pulled the housing it didnt even have one. Heres the dumb question since it is under the motor instead of on top what direction do i install it (spring up or down). I have tried installing it in both directions to get the coolant flowing through the heater core but there is no flow at all. Last thing I want to do is put a pump in it. Bleeding the system has not worked so I am not sure what needs to be done.
* Registered users of the site do not see these ads.
vt3fan4evr is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rebuild/5mt swap on 94 Legacy Turbo, Now no spark? 97.impreza.ob.sprt Electrical & Lighting 1 04-28-2010 12:37 PM
94 legacy, no start, new timing belt??? help!!! bry593 Legacy Forum 6 10-15-2007 07:31 PM
WTB:92-94 legacy headlight and pass quater panel simpreza2 Private 'Wanted' Classifieds 0 05-15-2004 06:29 PM
Wanted: Any and all info about 94 Legacy Touring Wagon ort5 Legacy Forum 0 01-29-2001 04:06 PM


All times are GMT -4. The time now is 06:29 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.