Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-20-2005, 02:58 PM   #1
ThrottleBender
Scooby Newbie
 
Member#: 103329
Join Date: Dec 2005
Default Help, snow drive, damage pics

I posted over at "another" wrx site, and they're useless. It seems more friendly here. I had a snow encounter into a curb and I'm working on the RR. My first stupid question is: can I just use jackstands on the rear or should I do front and back so the load on the car isn't funny? I'm going to have her up for a few days. I'm looking into getting the latteral links and control arm replaced, strut seems like it could have been bent, and the wheel is toast.

I hope I can get some people willing to help me repair the susp. from here. I have good skills but haven't worked on the WRX before. So first question just jackstand the rear okay?
* Registered users of the site do not see these ads.

Last edited by ThrottleBender; 12-20-2005 at 04:13 PM.
ThrottleBender is offline   Reply With Quote
Old 12-20-2005, 03:11 PM   #2
ThrottleBender
Scooby Newbie
 
Member#: 103329
Join Date: Dec 2005
Default

I've got her up in the air. Tires off... It's going to be hard to tell if anything is bent. I submit my newbie self to the alter of subie wrenchers. I think I'll try and figure out how to post some photo's.
ThrottleBender is offline   Reply With Quote
Old 12-20-2005, 03:54 PM   #3
ThrottleBender
Scooby Newbie
 
Member#: 103329
Join Date: Dec 2005
Default

Not so hard to tell...pic comming.
ThrottleBender is offline   Reply With Quote
Old 12-20-2005, 04:11 PM   #4
ThrottleBender
Scooby Newbie
 
Member#: 103329
Join Date: Dec 2005
Default

And here is how my day is shaping up.

(Jack under diff up around 2 inches)
Drivers Rear

Nice and straight, looks just fine.

Passenger Rear (same height)

Not looking so good.

Little bit of a camber problem there. Trailing arm must be bent. Strut bent? Lateral links?I'm now also thinking the wheel bearing should get replaced if the impact bent the arms like that.

Its cold in my garage, send be back with some help!
ThrottleBender is offline   Reply With Quote
Old 12-20-2005, 04:12 PM   #5
poison
NASIOC Supporter
 
Member#: 37678
Join Date: May 2003
Chapter/Region: SCIC
Default

Hey, glad we could help!
poison is online now   Reply With Quote
Old 12-20-2005, 04:41 PM   #6
armand1
Scooby Guru
 
Member#: 10309
Join Date: Sep 2001
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
'02 OBS 2-tone!
'95 Montego Miata

Default

TB - I'd use jackstands for the front, too, for 2 reasons. 1) You can't lock the front wheels with the emergency brake, so unless you chock the fronts really well, the whole car could start rolling forward/backward on the front wheels and pull over the jackstands on the back. 2) Because of the angle with only the rear elevated, it's more likely that the car can slide off the rear jackstands or knock them over (this is usually not such a big risk).
Just be careful!
armand1 is offline   Reply With Quote
Old 12-20-2005, 10:21 PM   #7
ThrottleBender
Scooby Newbie
 
Member#: 103329
Join Date: Dec 2005
Default

Thanks guys I got another set of stands to do it right. I am hoping for some imput on the suspension parts. Judging from the angle of the wheel all the arms and the strut are gone, anyone have a thought about the cross member? Is it a joke to remove? I'm ordering up the control arms and both rear struts tomorrow. Thanks armand1
ThrottleBender is offline   Reply With Quote
Old 12-20-2005, 10:50 PM   #8
scobaru
Scooby Guru
 
Member#: 31345
Join Date: Dec 2002
Chapter/Region: MWSOC
Location: Wisconsin
Vehicle:
05 LGT, GC8, NA
blue, white, blue

Default

if you want some help your going to need some better pictures.... you have a picture posted of the wheel but none of the damaged parts...This would also be better posted in the suspention section, not so much maintance. theres really isn't a good way of knowing if the strut is bad if you dont show a picture of some part of it. your lateral links are ment to bend in a accident so it doesn't damage anything more expensive such as the rear crossmemeber
scobaru is offline   Reply With Quote
Old 12-21-2005, 11:10 AM   #9
eclone
Scooby Specialist
 
Member#: 31567
Join Date: Jan 2003
Default

Same thing happened to me. If nothing appears to be bent, It's probably just the hub (hopefully) I replaced it and checked, but didn't even need an alignment
eclone is offline   Reply With Quote
Old 12-21-2005, 02:37 PM   #10
ThrottleBender
Scooby Newbie
 
Member#: 103329
Join Date: Dec 2005
Default

So I should look to see if the hub is square? (Could get a fairly good idea with just a straight edge) I think the latt links must be bent. You didn't replace any suspension arms and the hub was the only thing bent??
ThrottleBender is offline   Reply With Quote
Old 12-21-2005, 09:39 PM   #11
eclone
Scooby Specialist
 
Member#: 31567
Join Date: Jan 2003
Default

Yeah I brought it to Planet Motorsports. One look (not even on the hoist) and Iain knew it was the hub. I got a new wheel from the junkyard, he replaced the hub and all is good. Everything else was fine.
eclone is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
You guys are going to love this... Vostok 7 Off-Topic 55 02-02-2010 01:49 PM
How many of you guys are going to Vegas with your gov't rebate check? skimmilk68 Off-Topic 6 02-21-2008 12:40 AM
Look what I got today! (you guys are going to be jealous) incorporeal Off-Topic 37 06-26-2006 02:03 PM
You guys are going to love this incorporeal Off-Topic 33 02-04-2005 07:52 PM
You guys are invited to... Mischief Mid Atlantic Impreza Club -- MAIC 21 11-03-2002 04:19 PM


All times are GMT -4. The time now is 06:52 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.