Welcome to the North American Subaru Impreza Owners Club Tuesday May 26, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Water/Methanol Injection, Nitrous & Intercooler Cooling

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-26-2005, 12:53 AM   #1
trite
Scooby Newbie
 
Member#: 81658
Join Date: Feb 2005
Chapter/Region: MWSOC
Location: DeKalb IL
Vehicle:
2007 STI

Default SMC alcohol injection failure???

Has anyone had an SMC alcohol injection system fail causing motor failure in their wrx?
* Registered users of the site do not see these ads.
trite is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-28-2009, 09:34 PM   #2
robwrx19720
Scooby Scammer- Do Not Buy From User
 
Member#: 180582
Join Date: May 2008
Default

nnooo
robwrx19720 is offline   Reply With Quote
Old 06-03-2009, 02:32 PM   #3
Cards2323
Scooby Specialist
 
Member#: 142868
Join Date: Mar 2007
Chapter/Region: Tri-State
Location: Queens NY
Vehicle:
2014 BRZ LIMITED
Satin White Pearl

Default

Mine works great
Cards2323 is offline   Reply With Quote
Old 06-03-2009, 07:03 PM   #4
SurfWagon
Scooby Specialist
 
Member#: 156861
Join Date: Aug 2007
Location: Miami, FL
Vehicle:
2002 Wagon
mbp, evo3/e85

Default

Steve has great customer support. SMC system working for 3 yrs.
SurfWagon is offline   Reply With Quote
Old 06-11-2009, 11:39 AM   #5
lcesardo
Scooby Newbie
 
Member#: 158841
Join Date: Sep 2007
Vehicle:
2002 WRX
Silver

Default

I`ve recently noticed that my smc controller has the yellow light on permanently.
That light is only supposed to be ON when alcohol is being injected, but in my case
it`s on as soon as I start up the car, both lights, green and yellow, anyone has had
this issue and solved it?
lcesardo is offline   Reply With Quote
Old 06-15-2009, 05:18 PM   #6
lcesardo
Scooby Newbie
 
Member#: 158841
Join Date: Sep 2007
Vehicle:
2002 WRX
Silver

Default

anyone?
lcesardo is offline   Reply With Quote
Old 06-15-2009, 05:21 PM   #7
krambte79
Scooby Specialist
 
Member#: 97452
Join Date: Oct 2005
Chapter/Region: South East
Location: Broussard, LA
Vehicle:
05 STi, 02 STi
& 09Ltd Tribeca

Default

check your boost settings on the controller
is your pump actually pumping or is it just the light
check wiring

call smc
krambte79 is offline   Reply With Quote
Old 06-15-2009, 05:23 PM   #8
VWGrk1
Scooby Specialist
 
Member#: 57882
Join Date: Mar 2004
Chapter/Region: MWSOC
Location: Chicago
Vehicle:
2004 WRX
WRB

Default

Quote:
Originally Posted by lcesardo View Post
I`ve recently noticed that my smc controller has the yellow light on permanently.
That light is only supposed to be ON when alcohol is being injected, but in my case
it`s on as soon as I start up the car, both lights, green and yellow, anyone has had
this issue and solved it?
Check your ground. The light stays on if it is not grounded.
VWGrk1 is offline   Reply With Quote
Old 06-16-2009, 06:36 PM   #9
ownnij
Scooby Specialist
 
Member#: 70459
Join Date: Sep 2004
Chapter/Region: TXIC
Location: Las colinas, TX
Vehicle:
2002 AW Bugeye ej257
6spd, GT3076R, Alky & EWG

Default

i recently had a issue with my spray light flickering and not coming on when in boost. i pressed the test button and it sprayed without the light coming on... weird.

i called steve and he told me to do a pump pressure test which turned out great. so i replaced the vaccum line for the boost source and ever since didnt have this issue. weird.
ownnij is offline   Reply With Quote
Old 07-22-2009, 12:14 PM   #10
lcesardo
Scooby Newbie
 
Member#: 158841
Join Date: Sep 2007
Vehicle:
2002 WRX
Silver

Default

you were correct, it was a ground problem... my mechanic forgot to
ground it... so I solved that problem right away, but now I started
to notice that the spray light turn on randomnly, not at the desired
boost setting, but at idle or even when no boost was on...
Im gonna try with the vaccum line...
lcesardo is offline   Reply With Quote
Old 08-11-2009, 10:03 PM   #11
Dak Jones
Scooby Newbie
 
Member#: 220149
Join Date: Aug 2009
Chapter/Region: South East
Location: Huntington, WV
Vehicle:
2004 Subaru WRX STI
WRC Blue

Default

Please help. I have a SMC methanol injection system installed on my 2004 sti. Everything has always worked fine untill i took it to a mechanic to have a new ACT 6 puck clutch kit and new light weight flywhee installed. The garge i went to was recomended by a guy i know that has multiple high performance, highly modified cars.

I went for a ride after the install to break in the new clutch and found that the car felt under powered compaired to usual. The car makes 454 whp spraying meth. I noticed that the indicator light on the dash control module that let you know that the system is armed was lit as it should be but at 10 PSI the system should spray but does not. No spray at all. The mechanic said that all he did with the electrical system was pull the batery. I checked the ground wires for the meth pump, they were fine. I am really upset about this. I worked fine when i took it to this guy. I just noticed it today and the mechanics shop is closed so i havent had a chance to bring the car back to the shop. I reset my map with my access port to the 26 psi + meth map because the ECU had reset after they pulled the battary. Can anyone help me? I tried the spray test and nothing happend.
Dak Jones is offline   Reply With Quote
Old 08-11-2009, 10:07 PM   #12
ownnij
Scooby Specialist
 
Member#: 70459
Join Date: Sep 2004
Chapter/Region: TXIC
Location: Las colinas, TX
Vehicle:
2002 AW Bugeye ej257
6spd, GT3076R, Alky & EWG

Default

you should call smc. is the green light on? your pump might have failed because it triggers the spray light.
ownnij is offline   Reply With Quote
Old 08-11-2009, 10:08 PM   #13
Dak Jones
Scooby Newbie
 
Member#: 220149
Join Date: Aug 2009
Chapter/Region: South East
Location: Huntington, WV
Vehicle:
2004 Subaru WRX STI
WRC Blue

Default

This sounds like the other guys problem but my spray light will not come on and the test did not spray. I think its grounded. Should the ground wire be attached to the bolt on the right of the meth bottle?
Dak Jones is offline   Reply With Quote
Old 08-11-2009, 10:10 PM   #14
Dak Jones
Scooby Newbie
 
Member#: 220149
Join Date: Aug 2009
Chapter/Region: South East
Location: Huntington, WV
Vehicle:
2004 Subaru WRX STI
WRC Blue

Default

the green light is on but it is definatly not spraying. I noticed a huge lose in power.
Dak Jones is offline   Reply With Quote
Old 08-11-2009, 10:12 PM   #15
Dak Jones
Scooby Newbie
 
Member#: 220149
Join Date: Aug 2009
Chapter/Region: South East
Location: Huntington, WV
Vehicle:
2004 Subaru WRX STI
WRC Blue

Default

do you think SMC will be able to help. I am affraid that the mechanic that installed the clutch will tell me that he did nothing but pull the battery.
Dak Jones is offline   Reply With Quote
Old 08-12-2009, 02:47 AM   #16
sleeperrex
Scooby Newbie
 
Member#: 19466
Join Date: May 2002
Location: san diego
Vehicle:
2002 wrx/hybrid
silver

Default

My green light does not turn on but it does spray.
sleeperrex is offline   Reply With Quote
Old 08-12-2009, 09:07 AM   #17
ownnij
Scooby Specialist
 
Member#: 70459
Join Date: Sep 2004
Chapter/Region: TXIC
Location: Las colinas, TX
Vehicle:
2002 AW Bugeye ej257
6spd, GT3076R, Alky & EWG

Default

^^^ seems like a common issue with smc kits but as long as it sprays then it's good. i think what happens is that the led has gone bad.
ownnij is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Which top mount intercoolers work with the SMC alcohol injection system? aprazma Water/Methanol Injection, Nitrous & Intercooler Cooling 58 01-26-2007 04:29 AM
Anyone running smc alcohol injection? trite Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 51 11-05-2005 12:47 AM
SMC Alcohol Injection Kit AK*WRX*2004 Private 'For Sale' Classifieds 7 10-13-2005 08:55 PM
SMC alcohol injection for WRX MisterX Private 'For Sale' Classifieds 5 07-22-2005 06:43 PM
SMC alcohol injection kit: run 91 octane+ kit= same as 100 octane in the tank gnx7 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 09-25-2002 03:57 PM


All times are GMT -4. The time now is 12:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.