Welcome to the North American Subaru Impreza Owners Club Saturday August 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-04-2000, 09:26 AM   #1
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
QuickSilver Metallic

Post Exhaust leak fixed, no more VW sound!!

Got my new Y-pipe installed under warranty yesterday. Man, I hadn't realized just how loud that old one had gotten!

I wanted to keep the old one for possible modification, but because it was a warranty repair they have to send it back to Subaru. I didn't even get to see where the leak was - I got to look at the old Y-pipe, but all the heat shielding was still on it (the new pipe came with all the shielding, which kind of surprised me). Oh well. I know the leak was somewhere on the driver's side arm of the Y, under the heat shielding, which seems kinda weird. I would have thought that if the pipe was going to pop a leak anywhere it would be at one of the flange welds.

OK, so now the exhaust is back to sounding like normal, not it's time for a new muffler and intermediate pipe. Which brings me to an unrelated question - does anybody know why our Legacy has an extra cat on the intermediate pipe? I mean, it's the same engine, same drivetrain, same exhaust (essentially) except for that extra cat. It can't possibly be there for emissions, or the 2.5RS would have it too. I don't get it.

Pat Olsen
'99 Legacy 2.5GT 5speed sedan
* Registered users of the site do not see these ads.
Patrick Olsen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
exhaust leak fix scoobnoobn Factory 2.0L Turbo Powertrain 2 04-18-2010 01:18 PM
Exhaust leak fixed, please god, no more pain. Tgui Factory 2.5L Turbo Powertrain 6 11-12-2009 10:44 PM
no more "psssh" sound from bpv. YANG_STI Factory 2.5L Turbo Powertrain 13 09-09-2008 03:54 AM
No more whoosh sound when removing the gas cap?? 32rulz Factory 2.5L Turbo Powertrain 6 03-02-2008 06:25 PM
Strange problem. No more BOV sound and only 12psi boost. Bunuel Factory 2.0L Turbo Powertrain 6 02-25-2003 04:53 PM


All times are GMT -4. The time now is 10:07 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.