Welcome to the North American Subaru Impreza Owners Club Wednesday August 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-16-2006, 03:59 PM   #1
jared nelson
Scooby Specialist
 
Member#: 35075
Join Date: Apr 2003
Chapter/Region: RMIC
Location: 02 MBP debadged spoilerless
Vehicle:
for Trade with U!
PM me to trade.

Default 4EAT to 5MT swap problems, please help!!!

Hello everyone, I am looking for some help.

I am doing a 4EAT (auto) to 5MT (manual) swap in my 02 WRX. Literally everything for the whole swap is done, but from what I understand, the car just wont start. I had my mechanic do the swap, because the price was so low, I just couldn't refrain. Anyways, from what I understand, He is done. The car is 100% back together, but the car wont start. The new trans is in,with the new rear diff, and all the linkage, the clutch cyl, manual trans brake cyl, all the linkage ect. The problem is that the car just wont start!!!

I am assuming that the neutral safety switch, or the clutch switch, or something else in the wiring harness needs to be wired in or something, in order to allow the car to start. Can you please help me with some info on how to make it start?

Here are some questions that I have.

Is the wiring harness different from auto to manual?

If not, is there a sub harness that goes from the harness to the transmissions varios sensors ect?

Do I need to disconnect the TCU?

Is the clutch switch going to work the way I want? I am thinking that the cruise control will either not work at all, or just not have a clutch cruise off switch. Also, I am assuming the car will just start all the time, whether the clutch is in or out. Is that correct?

Can you guys please give me some help? Thanks!!!

PS I know bunot has already done this swap, and I have just sent him a PM and an email. Hoping to hear back from him soon. Thanks again!!!
* Registered users of the site do not see these ads.
jared nelson is offline   Reply With Quote
Old 01-16-2006, 05:04 PM   #2
jared nelson
Scooby Specialist
 
Member#: 35075
Join Date: Apr 2003
Chapter/Region: RMIC
Location: 02 MBP debadged spoilerless
Vehicle:
for Trade with U!
PM me to trade.

Default

Okay, so it tunrs out that Ron with Axis power racing is the ****. I just called him and got the answer. I have a 2.4 liter motor built by him, and I call him every time I have any sort of a problem with my car. Infact, I really think I should have a yearly paid subscription to his advice and help. He seriously has answers for me within 10 seconds of my calling him. Hell stop me in the middle of asking my question, and answer me right away.

There is a harness connector that connects to the under side of the automatic transmission shifter. There are a bunch of pins on that connector. 2 of the pins are for sending and recieving volts when the car is in either neutral or park. All I have to do is run a wire from one of the pins to the other one. That will make it to where I always can start the car, no matter if its in gear, or the clutch is out or whatever. Then If I would like to, I can wire the clutch switch into those pins, and have an actual clutch swith. I dont think I will even do that though, because I really like to be able to start the car any time I want. Then If there are any problems, I can still drive the car and get it started.

Now, all I have to do is wire in the other things that are on the trans, like the speed sensor, and the other 1 or 2 sensors on the trans.
jared nelson is offline   Reply With Quote
Old 01-16-2006, 10:06 PM   #3
Legacy777
Scooby Guru
 
Member#: 4800
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
1990 Legacy & 97 OBS
AWD 6MT EJ22T AWIC Swap

Default

There are other electrical issues you will need to take care of. Do NOT just wire the clutch switch to the two pins on the trans connector. You must use a relay because those two pins that used to be connected to the inhibitor switch carry ignition amperage which goes to the starter.

Read my write up on the electrical stuff I had to deal with.
http://www.surrealmirage.com/subaru/...lectrical.html
Legacy777 is offline   Reply With Quote
Old 01-16-2006, 10:20 PM   #4
jared nelson
Scooby Specialist
 
Member#: 35075
Join Date: Apr 2003
Chapter/Region: RMIC
Location: 02 MBP debadged spoilerless
Vehicle:
for Trade with U!
PM me to trade.

Default

Quote:
Originally Posted by Legacy777
There are other electrical issues you will need to take care of. Do NOT just wire the clutch switch to the two pins on the trans connector. You must use a relay because those two pins that used to be connected to the inhibitor switch carry ignition amperage which goes to the starter.

Read my write up on the electrical stuff I had to deal with.
http://www.surrealmirage.com/subaru/...lectrical.html
your write up is for a completely different car. I know some of it applies, and I have already read about 20% of it. (the things I think I should know)...but for the most part, alot of those thigns are not the same as my car.

WTS I dont know what my guy is doing. I called him today with the little bit of info I got, and he basically put me in my place. Turns out he is a rocket propulsion engineer for his day job. And he has done some insane ECU harness marrying, and much much wiring and other fabrication.

So basically he got it all running, except for the lack of speed sensor on the trans. So I need to grab the one I have at my house, and take it to him tmorrow. then the car will run. Ill let you know. Maybe hell let me post what he did for the swap. Should know tomorrow.
jared nelson is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
02 wrx 4eat to 5mt swap wiring scOOtNsOOby Transmission (AT/MT) & Driveline 2 10-11-2009 07:45 PM
4eat to 5mt - cruise problem morrocco88 Subaru Conversions 23 08-23-2007 01:11 AM
4eat to 5mt - cruise problem morrocco88 Transmission (AT/MT) & Driveline 1 04-30-2007 10:55 AM
Suspension swap problem.. please help! merauder69 Brakes, Steering & Suspension 8 10-08-2004 08:08 PM
4EAT to 5MT swap? erice1984 Subaru Conversions 6 05-06-2004 09:42 PM


All times are GMT -4. The time now is 09:37 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.