Welcome to the North American Subaru Impreza Owners Club Friday January 30, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-29-2006, 04:44 PM   #1
BrandonWRX
Scooby Newbie
 
Member#: 42177
Join Date: Aug 2003
Location: Sharon, PA
Vehicle:
2005 STi
WRB

Default 21B0 CEL code?

I read a 21B0 CEL code with my AP after I got a cel with the cruise control flashing.
I have since put a wideband where the stock rear O2 sensor is and cancelled the P0037 code with streettuner. Supposedly 21B0 doesnt exist?
* Registered users of the site do not see these ads.
BrandonWRX is offline   Reply With Quote
Old 01-29-2006, 04:48 PM   #2
hondaeater69
Scooby Guru
 
Member#: 60324
Join Date: Apr 2004
Location: a pillow.
Default

21b0? that's a new one for me.
hondaeater69 is offline   Reply With Quote
Old 01-29-2006, 11:31 PM   #3
Jon [in CT]
*** Banned ***
 
Member#: 2992
Join Date: Nov 2000
Chapter/Region: NESIC
Location: Connecticut, USA
Vehicle:
02 WRX Sedan
Silver

Default

Quote:
Originally Posted by BrandonWRX
I read a 21B0 CEL code with my AP after I got a cel with the cruise control flashing.
I have since put a wideband where the stock rear O2 sensor is and cancelled the P0037 code with streettuner. Supposedly 21B0 doesnt exist?
21B0 is how an AccessPort mistakenly reports a P0137. The AccessPort sucks at pulling trouble codes. You need to find someone with a real OBD scan tool.
Jon [in CT] is offline   Reply With Quote
Old 01-30-2006, 02:57 AM   #4
wrxdaddy
Scooby Specialist
 
Member#: 14164
Join Date: Jan 2002
Chapter/Region: TXIC
Location: 32.9765N 96.8867W
Vehicle:
02 Impreza Wgn
95 L Project in progress

Default

I think it might be an 02 sensor issue >>> http://legacygt.com/forums/showthrea...oto=nextoldest
wrxdaddy is offline   Reply With Quote
Old 01-30-2006, 03:27 PM   #5
BrandonWRX
Scooby Newbie
 
Member#: 42177
Join Date: Aug 2003
Location: Sharon, PA
Vehicle:
2005 STi
WRB

Default

I have read that the rear O2 isnt needed, which is why I used the bung for my wideband..and just disconnected the stock one from the car. Am I correct in the fact that I read how the rear 02 is only for cat efficiency and not for fuel?
BrandonWRX is offline   Reply With Quote
Old 01-30-2006, 06:52 PM   #6
hondaeater69
Scooby Guru
 
Member#: 60324
Join Date: Apr 2004
Location: a pillow.
Default

Quote:
Originally Posted by BrandonWRX
I have read that the rear O2 isnt needed, which is why I used the bung for my wideband..and just disconnected the stock one from the car. Am I correct in the fact that I read how the rear 02 is only for cat efficiency and not for fuel?

you are correct. I have the same setup, no CEL light though. in ST, the DTC's that are NOT checked are defeated, you do know that right?
hondaeater69 is offline   Reply With Quote
Old 01-31-2006, 12:36 AM   #7
BrandonWRX
Scooby Newbie
 
Member#: 42177
Join Date: Aug 2003
Location: Sharon, PA
Vehicle:
2005 STi
WRB

Default

Yes I know that haha. I just have yet to defeat the P0137 CEL that is triggering the 21B0 code...since I couldnt find out what it was.
BrandonWRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CEL code 21B0 ?????? powbmps Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 3 12-16-2008 08:32 PM
STG2: Flashing CEL but no CEL code mvitic AccessPort 1 08-10-2006 10:43 PM
HELP: where can I borrow a CEL code reader or get the code pulled for free? anonymous_wolf Vancouver Impreza Club Forum -- VIC 5 08-11-2005 02:40 AM
P1904 CEL code rwroth Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 10-02-2001 02:00 PM


All times are GMT -4. The time now is 04:19 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.