Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-30-2006, 01:03 AM   #1
FNR32
Scooby Specialist
 
Member#: 84147
Join Date: Mar 2005
Chapter/Region: South East
Vehicle:
03 WRX
Black

Default Unichip question...

Is it just me or is the Unichip extremely inconsistent? One day my car feels decently strong, the next day it feels almost stock. I did a search but wasnít able to come up with any thing about the unichip other than some say that itís obsolete now. I guess im going to go ahead and AP my car. My question is, is it normal for the unichip to be this inconsistent? Or is my unit just blown. I was going to sell this chip to a board member, lucky for me it didnít work out, id have hated to sold someone something that ended up not to work correctly.
* Registered users of the site do not see these ads.
FNR32 is offline   Reply With Quote
Old 01-30-2006, 01:14 AM   #2
Dark Industries
Vendor
 
Member#: 67946
Join Date: Aug 2004
Chapter/Region: SCIC
Location: Lost Angeles-The Beach
Vehicle:
2002 WRX
WR Blue Sedan

Default

Ditched my unichip and added a Ecutek
Tuned it made 14 Whp More on my AWD Dyno!!
Car runs 1 million times better!!!!
Dark Industries is offline   Reply With Quote
Old 01-30-2006, 01:24 AM   #3
FNR32
Scooby Specialist
 
Member#: 84147
Join Date: Mar 2005
Chapter/Region: South East
Vehicle:
03 WRX
Black

Default

That's basically all I want. I just want the car to run better, and not be so jerky. I like the AP because of the ease of use, and the cost of course. I don't know much about Ecutek or the Utec either, Iíll really have to do more research on them. I have a friend with around the same performance mods that i have, with an AP and his car runs so much smoother than mine. Id like to be able to use whatever method of EM i decided to use when i upgrade the turbo with in the next couple of months. AP just seems like the easiest way to go.
FNR32 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
TurboXS Stage 1 Unichip question andygold Factory 2.0L Turbo Powertrain 2 11-08-2001 03:52 PM
Stage 1, TurboXS Unichip question SGOSWRX Factory 2.0L Turbo Powertrain 7 11-02-2001 07:29 PM
Unichip Questions APSBLUEREX Factory 2.0L Turbo Powertrain 6 09-08-2001 04:27 PM
Anyone thought of this? Turbo XS unichip questions WRXThis Factory 2.0L Turbo Powertrain 11 08-09-2001 11:17 AM
Unichip question? mid9s Factory 2.0L Turbo Powertrain 1 07-28-2001 09:23 PM


All times are GMT -4. The time now is 02:57 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.