Welcome to the North American Subaru Impreza Owners Club Sunday December 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-31-2006, 11:29 PM   #1
suBooneru
Scooby Newbie
 
Member#: 104901
Join Date: Jan 2006
Chapter/Region: BAIC
Location: Sebastopol, Ca.
Vehicle:
2014 Forester XT
White

Default 06 WRX Clutch Pedal Squeaking

It's pretty annoying. Anyone else have this problem and know how to get rid of it?
* Registered users of the site do not see these ads.
suBooneru is offline   Reply With Quote
Old 02-01-2006, 12:17 AM   #2
MattDell
Scooby Guru
 
Member#: 16803
Join Date: Mar 2002
Chapter/Region: International
Location: London, England
Default

I have it in my 04. You get used to it and sometimes it will intermittently go away.
MattDell is offline   Reply With Quote
Old 02-01-2006, 12:51 AM   #3
fusionlude
Scooby Newbie
 
Member#: 98168
Join Date: Oct 2005
Chapter/Region: W. Canada
Location: Winterpeg, CANADA
Vehicle:
2007 Impreza WRX
Satin White Pearl

Default

tha **** always happens when it cold
fusionlude is offline   Reply With Quote
Old 02-01-2006, 09:06 AM   #4
nu2thisSTI
Scooby Newbie
 
Member#: 84157
Join Date: Mar 2005
Location: ORLANDO
Vehicle:
2004 STi
Aspen

Default

Quote:
Originally Posted by MattDell
I have it in my 04. You get used to it and sometimes it will intermittently go away.
Me too....04 STi
nu2thisSTI is offline   Reply With Quote
Old 02-08-2006, 09:56 AM   #5
Hank3
Scooby Guru
 
Member#: 16157
Join Date: Mar 2002
Chapter/Region: South East
Location: Tallahassee, FL
Vehicle:
'03 Mazda P5 <><
'02 WRX & '08 MS3 SOLD!!!

Default

Hank3 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 WRX Clutch Pedal Vibration and Rotational Squeaking Sound Subirex09 Transmission (AT/MT) & Driveline 126 12-26-2014 12:38 AM
06 WRX clutch pedal position for full disengaged chimchimm5 Transmission (AT/MT) & Driveline 1 09-13-2006 12:47 AM
Annoying Clutch Pedal Squeak balrog Transmission (AT/MT) & Driveline 8 02-17-2003 11:55 AM
How do you get rid of clutch pedal squeak FatCatTurbo Transmission (AT/MT) & Driveline 6 12-11-2001 11:45 AM
Clutch pedal squeak Texas25RS Texas Impreza Club Forum -- TXIC 2 08-14-2001 11:30 AM


All times are GMT -4. The time now is 09:26 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.