Welcome to the North American Subaru Impreza Owners Club Tuesday July 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Reviews > Vendor Reviews

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-20-2001, 01:18 AM   #1
blkwag
Scooby Specialist
Member Sales Rating: (0)
 
Member#: 4838
Join Date: Mar 2001
Location: Windy City Chicago
Vehicle:
2002 WRX Wagon
Black in Recovery...

Thumbs down Bad experience with Eurosport in NY, NY...

I'm pretty sure Eurosport doesn't do much business on this board. I think they are more a hardcore rally prep shop.

Well,
anyways I bought a used TecII engine management system from them a few months ago. He told me that it was complete and had the latest software. After receiving it, I found that it didn't have the latest software, which I had to purchase separately for $200. I also found that he gave me a generic crank trigger wheel. This was suppose to have been off his Subaru but I'm pretty sure he sent a different crank trigger wheel.

They told me to send them a pulley, crank trigger wheel, magnetic pickup, and the mount and they would fabricate the rest and send it back. Well, this was over 3 months ago and I can't get a hold of them now. They told me it was shipped out the last 6 times I called.

I'm not sure if they're in business anymore with the whole WTC disaster.

Looks like I have to shell out more money for the missing parts.

The whole point of buying used was to save money but so far, I've spent more money and lost a lot of time to boot.

It's safe to say I'm not happy with Eurosport and would caution others that deal with them.
* Registered users of the site do not see these ads.
blkwag is offline   Reply With Quote
Old 09-20-2001, 12:04 PM   #2
filobot_wrx
Scooby Newbie
Member Sales Rating: (0)
 
Member#: 8274
Join Date: Jul 2001
Location: Chicago, Il
Vehicle:
2002 WRX Sedan
some sorta black,muddy...

Default

Dave man,

Sounds like a bummer. Sorry to hear about that. If they are in NY there might be some trouble due to the WTC disaster, but it sounds like they have been shafting you for a looong time. Can you call the Better Business Bureau and try to recoop your loss?
filobot_wrx is offline   Reply With Quote
Old 09-20-2001, 03:58 PM   #3
stimpy
Homicidal Maniac
Moderator
Member Sales Rating: (3)
 
Member#: 1612
Join Date: Jun 2000
Location: Austin, TX
Vehicle:
2008 STI

Default

The WinTec software was recently updated a couple months ago. Chances are they had the up-to-date software when you purchased it and were unaware of the recent WinTec 2.0 version.

I realize you are not looking to spend even more money, but talk to Shiv ( www.vishnuperformance.com ) and he should be able to set you up with the crank trigger wheel, pickup, etc.

Good luck,
-Jon
www.nothingserious.net
stimpy is offline   Reply With Quote
Old 09-24-2001, 04:00 AM   #4
Dave_Clark
Scooby Specialist
Member Sales Rating: (2)
 
Member#: 1015
Join Date: Mar 2000
Location: Seattle, WA, USA
Default

Well don't get too upset with them. Eurosport's shop is only 4 or 5 blocks from the hole in the ground that was the WTC. That might have something to do with it.
If you have any questions about the unit don't hesitate to contact Electromotive, they're very helpful.
Dave_Clark is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad experience with Shannon Autobody in Gaithersburg 24 Mid Atlantic Impreza Club -- MAIC 31 07-27-2007 03:41 PM
My bad experience with Ultimate Performance in Dulles/Brian Dean was a total Jerk T-WREXXX Mid Atlantic Impreza Club -- MAIC 93 12-22-2005 03:59 PM
Bad experiance with Automotive One in Longwood. WRXtreme02 South East Region Forum 12 06-24-2002 01:12 AM
Anyone who has had a bad experience with Stevens Creek Subaru PLEASE READ!!! ScoobieSnacks Bay Area Impreza Club Forum -- BAIC 8 02-17-2002 02:27 PM
Has Anyone Had Good/Bad Experiences with Audiobahn and MA Audio Products? MY99 2.5GT Car Audio, Video & Security 6 04-28-2001 01:11 AM


All times are GMT -4. The time now is 03:58 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.