Welcome to the North American Subaru Impreza Owners Club Tuesday July 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-08-2006, 09:06 PM   #1
RBelcher00
Scooby Specialist
 
Member#: 100829
Join Date: Nov 2005
Chapter/Region: SCIC
Location: Corona, CA
Vehicle:
2006 WRX R.I.P. =(
'07 CBR600RR =)

Default '06 WRX foglights added but dont turn on

Alright guys, I recently got into an accident and the whole front end was basically replaced on my car at the body shop. My car did not have foglights on it when I bought it, but the guy at the body shop ordered the front end complete with the fog lights.

They installed them and said they wired them up properly, and did not know why they weren't working. The body shop guy insisted there would be a foglight switch on the car to turn them on, but I told him that my car didn't have one. I didn't want to tell him my car never had fogs earlier because, hey, free foglights. But now, they don't work.

Anyway, I went to the dealership to get my first oil change (they overfilled, by the way) and I asked them if there was any way they could just take a look while it was getting "serviced" and they wanted $98 just to look at it. So I told them to forget it. But now I want them to work.

Soooo, I thought that they would just automatically be on with my low beams (that's how I wanted it) but they're not. Now, do I need to have Subaru install the foglight switch, or is there something I can do myself to just get them to turn on with the low beams???

Any help is greatly, greatly appreciated.
* Registered users of the site do not see these ads.
RBelcher00 is offline   Reply With Quote
Old 02-08-2006, 09:21 PM   #2
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

...ya need the relay/switch kit....it is seperate from the lights and housings.

pm subiegal and she can hook ya right up

...and yer dealers shop is full of spit
Uncle Scotty is offline   Reply With Quote
Old 02-08-2006, 09:45 PM   #3
Handsdown
Scooby Guru
 
Member#: 29355
Join Date: Nov 2002
Chapter/Region: NWIC
Location: seattle
Vehicle:
2003 GD6 Hate chall
but i'mma maintain

Default

they're not free to your insurance...


but yeah, you need the switch and relay.
Handsdown is offline   Reply With Quote
Old 02-08-2006, 10:18 PM   #4
RBelcher00
Scooby Specialist
 
Member#: 100829
Join Date: Nov 2005
Chapter/Region: SCIC
Location: Corona, CA
Vehicle:
2006 WRX R.I.P. =(
'07 CBR600RR =)

Default

Quote:
Originally Posted by Handsdown
they're not free to your insurance...


but yeah, you need the switch and relay.

They're free to me when I have a $1,000 deductible and a $5,000 claim.
RBelcher00 is offline   Reply With Quote
Old 02-08-2006, 10:20 PM   #5
Handsdown
Scooby Guru
 
Member#: 29355
Join Date: Nov 2002
Chapter/Region: NWIC
Location: seattle
Vehicle:
2003 GD6 Hate chall
but i'mma maintain

Default

damn. those are some super expensive foglights

anyway i'd look for some used ones, i was able to buy my switch and relay used for like 30 bucks shipped, which is what the dealer wants for just the relay.
Handsdown is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Reverse lights dont turn on MJBrowny21 Transmission (AT/MT) & Driveline 6 03-22-2010 05:25 PM
cruise control lights dont turn on. scoobynoobEMT Electrical & Lighting 4 02-04-2010 10:58 AM
Help: Installed HID on 06 fogs and dont turn on! al3xgonz Electrical & Lighting 6 04-11-2007 12:32 AM
Reverse Lights Dont Turn On - Help michyous Legacy Forum 5 04-16-2005 10:54 PM
this post sucks... but dont die on me!! maybe? mmmprza Off-Topic 15 01-23-2004 12:27 PM


All times are GMT -4. The time now is 03:31 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.