Welcome to the North American Subaru Impreza Owners Club Wednesday September 3, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-18-2006, 01:34 PM   #1
Zora
Scooby Newbie
 
Member#: 74712
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Sterling, VA
Vehicle:
2006 Saab 92x Aero
Obsidian Black Pearl

Default EJ20G wiring predicament...

Never thought I'd get here, but I'm finally in wiring wonderland - yeah! My friend got an '96 EJ20G with a complete harness. There seems to be a discrepancy between the JDM wiring diagrams that I found and the actual harness. Specifically, the wires in the B116 connector that hook up to the ECU are different from what a table in the diagram shows. For example, according to the diagram, the wire that goes to terminal 25 is the tach signal and is colored Blue-Green. Here's where terminal 25 is:
B116
Here's the picture of the actual connector with the wire going to terminal 25 indicated:
B116 actual connector
The wire is Green-Red instead of Blue-Green. There is no Blue-Green wire. There are other discrepancies as well.
So, there are only two explanations: either the harness is not from a EJ20G or the diagram is for a different engine. Could anyone please shed some light on this. Just for reference, here's the ecu that came with the engine:
ECU label
ECU pinout
Everything is from a '96 JDM WRX wagon w/AT.

Thanks in advance!!!
* Registered users of the site do not see these ads.

Last edited by Zora; 02-20-2006 at 05:17 PM.
Zora is offline   Reply With Quote
Old 02-18-2006, 02:02 PM   #2
Zora
Scooby Newbie
 
Member#: 74712
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Sterling, VA
Vehicle:
2006 Saab 92x Aero
Obsidian Black Pearl

Default

pictures fixed...
Zora is offline   Reply With Quote
Old 02-19-2006, 08:26 PM   #3
imprezin04
Scooby Specialist
 
Member#: 39482
Join Date: Jul 2003
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2000 Impreza RS
SRP

Default

hey lenny, i the pictures arent working for me. anyone have any thoughts or maybe the right diagram? or is my engine something else? i posted pictures and people said it was from a late model 96 or early 97. i was told that it came out of a 96, GF8D58P is what i have on the plate it came with and engine type: EJ20GDX6NE. lenny and i are working on my wiring now and we will do his but we have run into problems....already...any help would be great. thanks guys
imprezin04 is offline   Reply With Quote
Old 02-19-2006, 08:50 PM   #4
suberdave
NASIOC Supporter
 
Member#: 101865
Join Date: Nov 2005
Chapter/Region: NWIC
Location: Covington, WA
Vehicle:
88 GL-10 STi
silver

Default

pics arnt working for me, but maybe this will help. here are the diagrams i used when doing my 96 JDM EJ20G swap. everything went awesome,

you may have a diagram from UK not Japan.

here are both

www.suberdave.com/subaru/glwrxt/Wiring/JDMandUKWiringDiag.pdf

-=Suberdave=-
www.suberdave.com
suberdave is online now   Reply With Quote
Old 02-20-2006, 05:19 PM   #5
Zora
Scooby Newbie
 
Member#: 74712
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Sterling, VA
Vehicle:
2006 Saab 92x Aero
Obsidian Black Pearl

Default

Sorry, pics fixed yet again. Dave, this is precisely the diagram that we were using... So, possible a wrong wiring harness thrown in with the engine?
Zora is offline   Reply With Quote
Old 02-20-2006, 08:55 PM   #6
rob
n00b Moderator
Moderator
 
Member#: 811
Join Date: Jan 2000
Location: WA
Vehicle:
2000 RS-Ej20G
It tastes like burning

Default

Very starange, yours is pinned differently than my '95 WRX sedan (which matches the wiring manual).

-Rob
rob is offline   Reply With Quote
Old 02-20-2006, 10:25 PM   #7
imprezin04
Scooby Specialist
 
Member#: 39482
Join Date: Jul 2003
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2000 Impreza RS
SRP

Default

it is an auto...would that make it any different? we notcied on the diagram that there were different pins for the auto and manual but i didnt know alot of the colors wouldnt match up
imprezin04 is offline   Reply With Quote
Old 02-21-2006, 07:33 AM   #8
accord94dx
Scooby Newbie
 
Member#: 50244
Join Date: Dec 2003
Chapter/Region: International
Location: River of garbage, Tokyo
Vehicle:
2004 Spec-C/iQ GRMN
White with Sprinkles

Default

yeah, the auto's vehicle speed sensor would probably use a different colored wire setup than the 5mt.
accord94dx is offline   Reply With Quote
Old 02-21-2006, 02:07 PM   #9
rob
n00b Moderator
Moderator
 
Member#: 811
Join Date: Jan 2000
Location: WA
Vehicle:
2000 RS-Ej20G
It tastes like burning

Default

Yeah, but I don't mean just wire color I mean the pinning is different.

Here are some close-ups of mine;
http://home.comcast.net/~r.files/WRX/B96_top.jpg
http://home.comcast.net/~r.files/WRX/B96_bottom.jpg

If I could figure out an easy way to post Excel sheets, I will list the functions for these wires as well.

Just FYI, the UK book has this connector labled as B96.

-Rob
rob is offline   Reply With Quote
Old 02-21-2006, 06:24 PM   #10
Zora
Scooby Newbie
 
Member#: 74712
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Sterling, VA
Vehicle:
2006 Saab 92x Aero
Obsidian Black Pearl

Default

I don't think there should be many differences b/w manual and auto. Rob, nice close ups - your B96 is totally different though, which is weird. All leads me to think that we have a harness from another engine. Can anyone help identify which harness it might be? Also, anyone recognize the ECU? Thanks.
Zora is offline   Reply With Quote
Old 02-23-2006, 12:27 AM   #11
imprezin04
Scooby Specialist
 
Member#: 39482
Join Date: Jul 2003
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2000 Impreza RS
SRP

Default

i know some people could probably recognize the numbers on the ecu, does it really belong to an ej20g from a 96 gf8? it seemed that all the wires connectors fit the engine and the place i got it from i think strips the cars when it gets to their warehouse. anyone have any experience with auto ej20 swaps? blah i knew i shoudlve just swapped to manual too....i regret it more and more everyday...
imprezin04 is offline   Reply With Quote
Old 02-24-2006, 06:26 PM   #12
Zora
Scooby Newbie
 
Member#: 74712
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Sterling, VA
Vehicle:
2006 Saab 92x Aero
Obsidian Black Pearl

Default

No one recognize the ECU? Nothing?
Zora is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
hook me up on 94 JDM WRX EJ20G wiring diagram? supermoose Subaru Conversions 6 03-26-2012 01:28 PM
EJ20G wiring questions and problems Puckaveli Subaru Conversions 14 08-25-2005 12:36 AM
Ej20g Wiring ? phunkeeHomosapien Subaru Conversions 4 02-15-2005 06:37 PM
EJ20G wiring is pissing me off. Puckaveli Subaru Conversions 2 01-11-2004 03:28 PM
hook me up on 93L + 94 ej20g wiring plug pinouts :) supermoose Subaru Conversions 3 12-22-2003 03:07 PM


All times are GMT -4. The time now is 12:00 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.