Welcome to the North American Subaru Impreza Owners Club Tuesday September 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 02-27-2006, 05:50 PM   #1
STIGuy116
Scooby Newbie
 
Member#: 87257
Join Date: May 2005
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2005 STI
OBP

Default 2005 STi check engine light question

I have a 2005 STi with a full turbo back exhaust on it. Nothing much else as far as mods go. I do get boost creep but only when i get on it on the parkway. The other night i wasn't even getting on it and the check engine light came on. Now i do have the CEL fix from helix tide up under the car and it hasn't been a problem for the five month's it's been on. What could have caused the light to come on now? Could the really cold weather have anything to do with it?
* Registered users of the site do not see these ads.
STIGuy116 is offline  
Old 02-27-2006, 05:56 PM   #2
_sti_05
Scooby Specialist
 
Member#: 72313
Join Date: Oct 2004
Chapter/Region: TXIC
Location: Brownsville, Tx
Vehicle:
2005 STi
Black

Default

Is the CEL blinking?
_sti_05 is offline  
Old 02-27-2006, 06:41 PM   #3
Davenow
Scooby Guru
 
Member#: 23676
Join Date: Aug 2002
Chapter/Region: NESIC
Location: de_dust and Orgrimar
Vehicle:
.

Default

It can still be a catalyst code. My buddy gets it on his STI every once in a while even with the mechanical fix.


It could also be something completely unrelated. A bad sensor somewhere, maybe a TGV took a dump, maybe your IAC is on the fritz, hell man there are THOUSANDS of things that can cause codes. Asking here is really not going to get you any closer to knowing. Just go get it read and tell us what the code is.
Davenow is offline  
Old 02-27-2006, 07:35 PM   #4
Jon [in CT]
*** Banned ***
 
Member#: 2992
Join Date: Nov 2000
Chapter/Region: NESIC
Location: Connecticut, USA
Vehicle:
02 WRX Sedan
Silver

Default

Gee, maybe the original poster should pull his trouble code and report it here. It's a fool's errand (which, it seems, some bozo here is willing to run) to offer advice without knowing the precise diagnostic trouble code.

Go to Autozone or Pep Boys and see whether they'll scan your trouble code for free.
Jon [in CT] is offline  
Old 02-27-2006, 07:40 PM   #5
Unabomber
Big Ron
Moderator
 
Member#: 18062
Join Date: Apr 2002
Chapter/Region: MAIC
Location: I can save you a ton of cash
Vehicle:
on car parts so PM
me b4 j00 buy

Default

Unabomber is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light question jlam86 Vancouver Impreza Club Forum -- VIC 7 11-28-2006 06:06 PM
check engine light question - 05 STi STIGuy116 Factory 2.5L Turbo Powertrain 4 06-16-2006 10:25 PM
Check engine light question.... just one blunt Factory 2.0L Turbo Powertrain 6 09-26-2004 08:04 PM
[B]Check Engine Light question regarding uppipe/downpipe[/B] Moshpit552 Factory 2.0L Turbo Powertrain 2 08-21-2004 02:36 AM
Check engine Light Question P1443 speedrkj Tri-State Area Forum 8 02-26-2003 07:39 PM


All times are GMT -4. The time now is 11:27 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.