Welcome to the North American Subaru Impreza Owners Club Thursday August 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-01-2006, 12:40 AM   #1
Assassin4457
Scooby Specialist
 
Member#: 96773
Join Date: Sep 2005
Chapter/Region: E. Canada
Location: GTA, Ontario Canada.
Vehicle:
04 WRX, RIP GC8
Black

Default Could a CEL be activated by driving with little fuel?

Heres my story. Ive been having a CEL occasionally when I fill up my car for $10, meaning a few liters in there, but I notice It only comes on if i tank up for this amount a few times. Then, when I go to tank up for $20 + , the CEL goes off after a few km. Im wondering if anyone knows anything about it?

BTW, im not sure if this really matters but I have an exhaust leak. Its coming right from the flange that connects the cat back section to the second cat. I havent had a chance to get a good look yet, but Its not horrible, and it looks like the gasket may have failed, if this even happens.

I thought the CEL was due to that exhaust leak, but then I noticed the gas trend.

Any info is appreciated.
* Registered users of the site do not see these ads.
Assassin4457 is offline   Reply With Quote
Old 03-01-2006, 12:42 AM   #2
Assassin4457
Scooby Specialist
 
Member#: 96773
Join Date: Sep 2005
Chapter/Region: E. Canada
Location: GTA, Ontario Canada.
Vehicle:
04 WRX, RIP GC8
Black

Default

BTW, im going to bring the car into a dealership for a complete inspection and diagnosis, but Im still posting to get an idea of what it could be still, and to learn something new.
Assassin4457 is offline   Reply With Quote
Old 03-01-2006, 12:55 AM   #3
awesome2.5rs
Scooby Newbie
 
Member#: 96154
Join Date: Sep 2005
Chapter/Region: MWSOC
Location: Beecher, IL
Vehicle:
98 2.5RS
Red

Default

I am not sure what this could be, maybe possibly emmisions related?....such as the evaporative emissions system? I will try and look into it a bit, but not sure though, sorry dude.
awesome2.5rs is offline   Reply With Quote
Old 03-01-2006, 03:05 AM   #4
flanders
Scooby Specialist
 
Member#: 76382
Join Date: Dec 2004
Chapter/Region: BAIC
Location: Bay Area
Vehicle:
2000 BH
BP Wannabe

Default

You really need to get the code pulled.

*I'm no expert on these things* but apparently it is common to get a CEL if you don't click the gas cap enough times. Not sure of the issue but maybe it is related. FIll it up all the way!
flanders is offline   Reply With Quote
Old 03-01-2006, 07:17 PM   #5
Assassin4457
Scooby Specialist
 
Member#: 96773
Join Date: Sep 2005
Chapter/Region: E. Canada
Location: GTA, Ontario Canada.
Vehicle:
04 WRX, RIP GC8
Black

Default

yeah im going to take her in saturday morning and I'll know for sure. I knew about the gas cap issue aswell, and I always make sure its sealed. Thanks for checking anyway guys.
Assassin4457 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
installed aftermarket DP w/ mech cel fix, bad to drive with CEL? jojotherider Factory 2.0L Turbo Powertrain 9 08-21-2006 03:18 PM
Could Transmission Warranty be voided by a Kartboy ShortShifter? WRXinEffect Warranty Issues & SOA Problems 58 09-28-2004 03:31 PM
Teh stop OT from being boring by typing with your face thread! gongzero Off-Topic 37 05-18-2004 11:06 AM
Could a CEL be caused by TurboXS BOV? Jasno999 Factory 2.0L Turbo Powertrain 15 05-21-2002 07:07 AM


All times are GMT -4. The time now is 07:42 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.