Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-04-2006, 01:28 AM   #1
cornerbuddy28
Scooby Specialist
 
Member#: 88976
Join Date: Jun 2005
Chapter/Region: NESIC
Location: Hinesburg VT
Vehicle:
Main Ingredients:
WRX motor, PPG's, me

Default leg turbo idle problem + bogs down at WOT

My friend just bought a 95 impreza with a 94 legacy turbo motor swapped into it and we've been having some problems fixing it. When we picked it up it had some serious exhaust leaks and the bypass valve was not plumbed back into the intake and it was having idle problems so it was a rough ride but we got it back home safe and sound. We've been tearing it down, fixing leaks, plumbing issues, fixed up the a few shady contraptions on the throttle we put it all back together. The idle control valve is missing the motor or servo and one of the previous owners had just filled the exposed bearing with some kind of adhesive to attempt to seal it (unsuccessfully).
We started the car up today finally after 4 days of work and here's what's happening... Initially it would start right up and idle around 4000 rpm. So we turned the idle control valve by hand all the way closed and the idle settled to around 1100. So then we tried the throttle for response by blipping it quickly and it would bog down quickly and then rev up as you kept it depressed. We seemed to be able to get the throttle to respond correctly a few times but then the engine would only come down to idle at 3000 or 4000rpm and VERY slowly come down to 1500 or so. The throttle is not sticking and the ICV is closed so we're having a tough time figuring out what's making it stick at a high engine speed and slowly come down and also why it's bogging down on WOT.
One other thing we noticed just now is that originally there was a crank case breather and a head breather that were both plumbed back into the intake and now I think we have them into eachother.

Any ideas?
* Registered users of the site do not see these ads.
cornerbuddy28 is offline   Reply With Quote
Old 03-04-2006, 01:34 AM   #2
cornerbuddy28
Scooby Specialist
 
Member#: 88976
Join Date: Jun 2005
Chapter/Region: NESIC
Location: Hinesburg VT
Vehicle:
Main Ingredients:
WRX motor, PPG's, me

Default

oh yeah and now it won't rev over 4500. ever
cornerbuddy28 is offline   Reply With Quote
Old 03-04-2006, 12:26 PM   #3
Jaxx
NASIOC Supporter
 
Member#: 177
Join Date: Aug 1999
Chapter/Region: NWIC
Location: Boise,Idaho,USA
Vehicle:
The 93 Imp W/EJ20K
flat black

Default

dollars to dough-nuts they used the impreza ecu not the legacy turbo ecu

the LT IAC is not on the throttle body like the impreza ...my guess thats why they removed it it will NEVER idle/run stock like with that ecu setup (i know first hand- better during the summer but really bad during the winter)

lift up the carpet under the passenger foot rest and see if there is any sign of wire splicing / the codes on the ecu

-j
Jaxx is offline   Reply With Quote
Old 03-04-2006, 07:30 PM   #4
cornerbuddy28
Scooby Specialist
 
Member#: 88976
Join Date: Jun 2005
Chapter/Region: NESIC
Location: Hinesburg VT
Vehicle:
Main Ingredients:
WRX motor, PPG's, me

Default

hmmm. Well we reset the ECU today and plumbed those breathers back into the intake and fiddled around with the TPS, ICV, and BOV and now its running like a champ! Boosts about 10 lbs at WOT, pulls hard and it idles around 1000 to 1500.
cornerbuddy28 is offline   Reply With Quote
Old 03-06-2006, 12:59 AM   #5
cornerbuddy28
Scooby Specialist
 
Member#: 88976
Join Date: Jun 2005
Chapter/Region: NESIC
Location: Hinesburg VT
Vehicle:
Main Ingredients:
WRX motor, PPG's, me

Default

Ok now its cutting fuel at about -5 psi. It will rev high but only if you do it slowly without building any boost. as soon as you get up to -5 or so it just throws you foward and bucks like crazy.
cornerbuddy28 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
02 wrx hybrid bogging/hesitation at wot around 4400 rpms help!! STiGuy23 Built Motor Discussion 50 10-31-2009 11:41 AM
bogging/hesitation at wot around 4400 rpms help STiGuy23 Factory 2.0L Turbo Powertrain 0 09-20-2009 08:52 PM
Car seems to bog down at 3100 Rpm Patrick1948 Factory 2.0L Turbo Powertrain 0 03-13-2008 02:12 PM
When bogged down at work, how do you respond? El Camino Off-Topic 17 11-01-2007 02:51 PM
2nd Gear bog down at WOT Chuck Technical Forum Archive 5 08-14-2000 07:25 PM


All times are GMT -4. The time now is 09:12 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.