Welcome to the North American Subaru Impreza Owners Club Thursday July 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > UTEC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-29-2006, 08:53 PM   #1
H-I-M
Scooby Newbie
 
Member#: 90679
Join Date: Jul 2005
Location: OHIO
Vehicle:
03 WRX
WHITE

Default boost help

i just put my utec on updated it to the newest version, downloaded the maps and the 1-3 perameter. set my selecter switch to 3 and my boost level will not go over 10 pounds. i had some one that hooked one up before and worked at a tuner shop help. i had a manual boost contoler on it befor and was running on 17 pounds so i know the turbo works. we took it off and put hte one provided with it on. so please help i'm going crazy trying to get it to work. thanks.
* Registered users of the site do not see these ads.
H-I-M is offline   Reply With Quote
Old 07-29-2006, 09:09 PM   #2
hippy
Scooby Specialist
 
Member#: 36528
Join Date: May 2003
Location: florida
Vehicle:
2002 Impreza Wrx
Silver

Default

"brass and restrictor"
hippy is offline   Reply With Quote
Old 07-29-2006, 09:15 PM   #3
H-I-M
Scooby Newbie
 
Member#: 90679
Join Date: Jul 2005
Location: OHIO
Vehicle:
03 WRX
WHITE

Default

Quote:
Originally Posted by hippy
"brass and restrictor"
what does that mean?
H-I-M is offline   Reply With Quote
Old 07-29-2006, 10:32 PM   #4
hippy
Scooby Specialist
 
Member#: 36528
Join Date: May 2003
Location: florida
Vehicle:
2002 Impreza Wrx
Silver

Default

it means do a search for......
hippy is offline   Reply With Quote
Old 07-30-2006, 09:28 AM   #5
59wrx
Scooby Newbie
 
Member#: 115099
Join Date: May 2006
Chapter/Region: MAIC
Location: NoVA
Vehicle:
2005 Evo VIII MR
Graphite Grey

Default New Toy

What mods do you have? Some, none?
Did you try running off of Map #0/8, the stock mode, and see what you get?
Did you "hand poke" in your parameters or try downloading them? TurboXS says to input the upgrade parameters manually, not downlod them.
Are you using the TurboXS ABC or are you running an aftermarket MBC? Did you check your lines if you used either?

So many questions for information that you should've put in your original post.


Quote:
Originally Posted by H-I-M
i just put my utec on updated it to the newest version, downloaded the maps and the 1-3 perameter. set my selecter switch to 3 and my boost level will not go over 10 pounds. i had some one that hooked one up before and worked at a tuner shop help. i had a manual boost contoler on it befor and was running on 17 pounds so i know the turbo works. we took it off and put hte one provided with it on. so please help i'm going crazy trying to get it to work. thanks.
59wrx is offline   Reply With Quote
Old 07-30-2006, 11:48 AM   #6
hippy
Scooby Specialist
 
Member#: 36528
Join Date: May 2003
Location: florida
Vehicle:
2002 Impreza Wrx
Silver

Default

If he was using the mbc, he wouldn't have boost problems. I'd bet on the problem being the brass restrictor either being in the wrong spot or missing.

peace

Last edited by hippy; 07-30-2006 at 12:04 PM.
hippy is offline   Reply With Quote
Old 07-30-2006, 12:49 PM   #7
TurbojonLS
Scooby Guru
 
Member#: 38772
Join Date: Jun 2003
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2 Cars, No Bling

Default

Or didn't adjust the boost map at all...
TurbojonLS is offline   Reply With Quote
Old 07-30-2006, 12:52 PM   #8
hippy
Scooby Specialist
 
Member#: 36528
Join Date: May 2003
Location: florida
Vehicle:
2002 Impreza Wrx
Silver

Default

.....or open the abc....(true). I just assumed that since he had an mbc on b4, that he chucked the brass restrictor without knowing that he did. Either that, or when he hooked the factory boost lines back upto the turbo, he put em on backwards.

peace
hippy is offline   Reply With Quote
Old 07-30-2006, 09:45 PM   #9
H-I-M
Scooby Newbie
 
Member#: 90679
Join Date: Jul 2005
Location: OHIO
Vehicle:
03 WRX
WHITE

Default

it has the boost controler that came with the utec, i have a blitz nur exhaust , rsr down pipe and up pipe , hks blow off valve ,arc air box. i will look to see if the brass restrictor is missing if it is which line does it need to go too? and also i down loaded the maps and peramaters from turbo xs and didn't adjust any thing. thank you every one for your help.
H-I-M is offline   Reply With Quote
Old 07-30-2006, 09:47 PM   #10
hippy
Scooby Specialist
 
Member#: 36528
Join Date: May 2003
Location: florida
Vehicle:
2002 Impreza Wrx
Silver

Default

It needs to go in the small tube between the t fitting and the turbo(no one the other side between the fitting and the wastegate).

peace
hippy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Boost or No Boost Help Needed SteveTC Pre-2002 Factory Turbo Powertrain 7 09-03-2009 08:00 PM
Stock 04 wrx over boosts/under boosts HELP! KnightRiderWRX Newbies & FAQs 5 07-17-2009 11:41 AM
Boost spiking/half boost Help please! Hah72215 Factory 2.0L Turbo Powertrain 5 06-22-2006 12:36 AM
Boost Controller failure=can't hold boost, help! SoBaLo Factory 2.0L Turbo Powertrain 0 08-30-2002 01:11 AM
Boost Monkey + MBC cranked down = too much boost, help! Mephiska Factory 2.0L Turbo Powertrain 31 06-24-2002 03:17 PM


All times are GMT -4. The time now is 09:08 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.