Welcome to the North American Subaru Impreza Owners Club Saturday May 23, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > UTEC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-21-2006, 01:13 PM   #1
AXA
Scooby Newbie
 
Member#: 35566
Join Date: Apr 2003
Location: Miami Fl.
Vehicle:
2002 STI WRX GT30R
WRC Blue

Default UTEC Tuners help.

My car was tune for 8 month with out any issue… I change the fuel filter and the map went to hell when the water injection comes on line.
Can a fuel filter do that?… Was the fuel pressure that much of a difference?
I am changing my Tuna o2 sensor and check the map to make sure I have the correct AFR. The weir thing is the according to the old sensor the car has the same AFR that it had before the fuel filter change.
Another thing is I change my spark plug to the same brand IK22 Denso just in case I had bad spark plugs.
* Registered users of the site do not see these ads.
AXA is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-21-2006, 04:51 PM   #2
cdvma
Scooby Specialist
 
Member#: 21980
Join Date: Jul 2002
Chapter/Region: NESIC
Location: Central MA
Vehicle:
2002 PSM WRX (Sold)
2009 BMW X5

Default

Could be the tank of gas you are on or the water injection not doing its job. Check the lines and nozzle. Toss us some logs to look at.
cdvma is offline   Reply With Quote
Old 03-21-2006, 08:45 PM   #3
AXA
Scooby Newbie
 
Member#: 35566
Join Date: Apr 2003
Location: Miami Fl.
Vehicle:
2002 STI WRX GT30R
WRC Blue

Default

Is not the gas because the car is extremely rich after the fuel filter change….
I think the problem was I tune the car with a clog filter now I have more fuel do to free flow of the new filter making the car richer….

I decided to tune the car again but this time I am using a Perring Big maf intake so I only have to tune once….
I started the tune and boy this hard to tune with the big maf intake …
If some can help me with a base map for 2.0 L mod stock injectors with a Big maf intake it will be a great help.
The weir thing is that when I put the stock map in the UTEC the car is great and idles very well after the big maf intake installation.
Just in case a have a GT30R turbo with all supporting modification on a built WRX EJ20.
AXA is offline   Reply With Quote
Old 03-21-2006, 09:38 PM   #4
TravisSTi
Scooby Newbie
 
Member#: 51243
Join Date: Dec 2003
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2004 Subaru WRX STi
WRB - GTX30r

Default

The BIG MAF already has scaling built-in. see this post it may help:

http://forums.nasioc.com/forums/showthread.php?t=960104
TravisSTi is offline   Reply With Quote
Old 03-21-2006, 11:34 PM   #5
AXA
Scooby Newbie
 
Member#: 35566
Join Date: Apr 2003
Location: Miami Fl.
Vehicle:
2002 STI WRX GT30R
WRC Blue

Default

Quote:
Originally Posted by TravisSTi
The BIG MAF already has scaling built-in. see this post it may help:

http://forums.nasioc.com/forums/showthread.php?t=960104
Thank you for the post....
AXA is offline   Reply With Quote
Old 03-22-2006, 12:52 PM   #6
cdvma
Scooby Specialist
 
Member#: 21980
Join Date: Jul 2002
Chapter/Region: NESIC
Location: Central MA
Vehicle:
2002 PSM WRX (Sold)
2009 BMW X5

Default

I have a 70mm MAF with chopped stock injectors. It does not scale evently so you still have to make adjustments to the UTEC. Without injecto scaling I still run negative values everywhere. 0% has -5 to -7 and high loads (IIRC) are at -12-ish.
cdvma is offline   Reply With Quote
Old 03-22-2006, 01:33 PM   #7
AXA
Scooby Newbie
 
Member#: 35566
Join Date: Apr 2003
Location: Miami Fl.
Vehicle:
2002 STI WRX GT30R
WRC Blue

Default

The earlier post that talk about the injector scaling has help a lot with the idle and vacuum and cero loads acceleration.
But now I have miss fires after 6000 rpm or more than 11 PSI of boost and I don’t know why. I have tray changing the plugs and gapping them with no luck. I know is a spark issue, maybe I have one bad coil or something.


Jose
AXA is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help!! Need Utec Tuner Before Nov 6 MrH00nel2 Mid Atlantic Impreza Club -- MAIC 13 11-01-2005 10:44 AM
Help!! Need Utec Tuner Before Nov 6 MrH00nel2 Engine Management & Tuning 0 10-28-2005 12:45 PM
UTEC Maps ???? Tri State tuners HELP TRTrex Engine Management & Tuning 8 06-27-2004 12:19 AM
utec tuners, PLEASE HELP K2Skier Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 04-09-2004 11:26 AM
Need a UTEC Tuner in L.A. Please Help! natoli3 Southern California Impreza Club Forum -- SCIC 36 02-16-2004 11:37 AM


All times are GMT -4. The time now is 06:49 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.