Welcome to the North American Subaru Impreza Owners Club Sunday December 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-21-2006, 08:03 PM   #1
jasona
Scooby Specialist
 
Member#: 11786
Join Date: Oct 2001
Chapter/Region: AKIC
Location: Alaska
Vehicle:
2014 OB 2.5i 6MT
Silver

Default dash lights and tail lights quit working

My factory cd player finally died last week so I put in a cheap one from wal mart. I used all the same wires hooking it up, but it blew the illumination fuse. I replaced the fuse and it didn't blow the new one, but now the dash lights and tail lights don't work. I unplugged the cd player and it didn't help
Where should I start? I'm going on a trip thursday and I really need this fixed by then...
* Registered users of the site do not see these ads.
jasona is offline   Reply With Quote
Old 03-21-2006, 08:29 PM   #2
Handsdown
Scooby Guru
 
Member#: 29355
Join Date: Nov 2002
Chapter/Region: NWIC
Location: seattle
Vehicle:
2003 GD6 Hate chall
but i'mma maintain

Default

they're on the same fuse, but i think they might be sharing a different fuse in conjunction with the illumination fuse- your cheap head unit probably shorted something else out other than the illumination one- look at the fuse diagram for the one in the engine bay.
Handsdown is offline   Reply With Quote
Old 03-21-2006, 11:08 PM   #3
jasona
Scooby Specialist
 
Member#: 11786
Join Date: Oct 2001
Chapter/Region: AKIC
Location: Alaska
Vehicle:
2014 OB 2.5i 6MT
Silver

Default

that did it, thanks
jasona is offline   Reply With Quote
Old 03-21-2006, 11:22 PM   #4
Handsdown
Scooby Guru
 
Member#: 29355
Join Date: Nov 2002
Chapter/Region: NWIC
Location: seattle
Vehicle:
2003 GD6 Hate chall
but i'mma maintain

Default

no prob, glad you got it solved.
Handsdown is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Parking lights and tail lights EJ0626 Electrical & Lighting 15 11-28-2010 07:11 AM
head lights and tail lights b.rock.1989 Interior & Exterior Modification 4 04-13-2009 10:53 PM
Conversion: 2003 Wagon to 2004-2005 Head lights and Tail lights Needsacar Electrical & Lighting 6 11-03-2008 12:41 AM
head light and tail light overlays. STIFLYBY_RANGER Interior & Exterior Modification 6 05-05-2008 11:44 PM
dash lights and tail lights not working. eocarockwell Electrical & Lighting 1 04-24-2008 12:57 PM


All times are GMT -4. The time now is 07:52 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.