Welcome to the North American Subaru Impreza Owners Club Tuesday July 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-01-2001, 04:41 PM   #1
rwroth
Scooby Newbie
 
Member#: 6431
Join Date: May 2001
Location: Denver, CO USA
Vehicle:
2002 WRX
Midnight Black Pearl

Default P1904 CEL code

Can someone tell me what a P1904 CEL is on a WRX? At 1900 miles this morning mine came on and that's the code my OBD2 software reports... only mod (on the drivetrain, at least ) is a hyperflow CAI.

Thanks
* Registered users of the site do not see these ads.
rwroth is offline   Reply With Quote
Old 10-01-2001, 05:00 PM   #2
K-WRX
Scooby Newbie
 
Member#: 6925
Join Date: May 2001
Location: DFW, USA
Vehicle:
2006 Cayman S

Default Re: P1904

According to my reference a P19XX is a manufacturer controlled code having to do with the transmission - sorry I can't be of more help. Maybe u better check with a dealer if no one else can help.

Andrew
K-WRX is offline   Reply With Quote
Old 10-01-2001, 05:02 PM   #3
RiftsWRX
Scooby Guru
 
Member#: 6124
Join Date: Apr 2001
Chapter/Region: MWSOC
Location: Glendale Hts, IL, USA
Vehicle:
2000 NFR AP1 S2000
'07 Honda FIT sport (5MT)

Default

I'll check tonight when I get home, in my factory manual.

*if someone doesn't beat me too it hehe*

Jorge (RiftsWRX)
www.ProjectWRX.com
RiftsWRX is offline   Reply With Quote
Old 10-01-2001, 05:20 PM   #4
rwroth
Scooby Newbie
 
Member#: 6431
Join Date: May 2001
Location: Denver, CO USA
Vehicle:
2002 WRX
Midnight Black Pearl

Default Thanks

Thanks - I'd be surprised if it's really transmission related... seems like I'm hearing a slightly different 'sound' from the engine and turbo... Also, the CAI has been on for 1400 miles so far - so it has been there a while with no CELs.
rwroth is offline   Reply With Quote
Old 10-01-2001, 07:05 PM   #5
Jon [in CT]
*** Banned ***
 
Member#: 2992
Join Date: Nov 2000
Chapter/Region: NESIC
Location: Connecticut, USA
Vehicle:
02 WRX Sedan
Silver

Default

I'd like to see your tech's expression when he pulls this code and finds it's not in the shop manual.

Maybe the code was actually P1094 (Tumble Generator Valve Circuit #1 [Open Circuit])?
Jon [in CT] is offline   Reply With Quote
Old 10-01-2001, 10:21 PM   #6
rwroth
Scooby Newbie
 
Member#: 6431
Join Date: May 2001
Location: Denver, CO USA
Vehicle:
2002 WRX
Midnight Black Pearl

Default Thanks

Hum - did the ECU reset and it seems to have gone away... definately was coming up as P1904 from the OBD2 software.

Thanks for looking.
rwroth is offline   Reply With Quote
Old 10-02-2001, 03:40 AM   #7
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

hmmm...resetting the ECU will just make it take longer for the code to come back. the 1 means it's a manufacturer specific code. Oh yeah guys don't forget there are always add ons to those manuals you have, especially for FIrst model year vehicles. better make sure you get all the updates.

Jeremy

I wouldn't have cleared the code till you found out what it meant
HndaTch627 is offline   Reply With Quote
Old 10-02-2001, 11:13 AM   #8
rwroth
Scooby Newbie
 
Member#: 6431
Join Date: May 2001
Location: Denver, CO USA
Vehicle:
2002 WRX
Midnight Black Pearl

Default Tech's reply

I saved a log of the code, etc from my OBD-2 session. After the reset the car runs the best it has since I bought it....

Also, a tech at the local subaru said he has seen some strange codes reported when the gas-cap is loose...

Thanks
rwroth is offline   Reply With Quote
Old 10-02-2001, 01:00 PM   #9
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

yeah agas capw ill trigger a factory emissions system leak code. But IIRC OBD means it would be a 14XX code. But in any case, i have seem some pretty funky codes that have never come back after clearing them myself.

Jeremy
HndaTch627 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
STG2: Flashing CEL but no CEL code mvitic AccessPort 1 08-10-2006 09:43 PM
HELP: where can I borrow a CEL code reader or get the code pulled for free? anonymous_wolf Vancouver Impreza Club Forum -- VIC 5 08-11-2005 01:40 AM
How to get the CEL codes from my computer wrxblitz Factory 2.0L Turbo Powertrain 4 11-14-2001 04:10 PM
('93-'01) CEL code ???? UU AR EX Impreza Forum 2 10-15-2001 01:23 PM


All times are GMT -4. The time now is 01:44 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.